Bug 472818

Summary: Window position isn't saved
Product: [Plasma] kwin Reporter: Piotr Mierzwinski <piotr.mierzwinski>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: piotr.mierzwinski, xaver.hugl
Priority: NOR Keywords: qt6, wayland
Version: master   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Piotr Mierzwinski 2023-07-31 00:46:06 UTC
SUMMARY
Seems window position isn't saved. I tested this for Dolphin and Kwrite. I moved newly opened window to left edge and close application. After reopen I got centred window.


STEPS TO REPRODUCE
1.  Start Dolphin
2. Move window to any edge
3. Close application
4. Start again Dolphin

OBSERVED RESULT
Window is placed in center of desktop

EXPECTED RESULT
Window should be shown in position when user recently moved it.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.27.80
KDE Frameworks Version: 5.240.0
Qt Version: 6.6.0 beta2

ADDITIONAL INFORMATION
Wayland
Comment 1 Zamundaaa 2023-07-31 12:43:37 UTC

*** This bug has been marked as a duplicate of bug 15329 ***