Bug 460280

Summary: Moving Displays in Display Configuration moves the whole window
Product: [Applications] systemsettings Reporter: Viko <transtrike>
Component: kcm_kscreenAssignee: kscreen-bugs-null <kscreen-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: nate, plasma-bugs, postix
Priority: VHI Keywords: regression
Version: git-stable-Plasma/5.26   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In: 5.26.1
Sentry Crash Report:
Attachments: Screen Capture of the effect

Description Viko 2022-10-12 07:37:33 UTC
Created attachment 152727 [details]
Screen Capture of the effect

SUMMARY
***
Trying to reposition display moves the whole window the first time 
***

STEPS TO REPRODUCE
1. Have connected at least 2 displays
2. Open Display Configuration
3. Try to rearrange one display

OBSERVED RESULT
Clicking and moving a display moves whole window the first time.

EXPECTED RESULT
Clicking and moving a display rearranges the display, while the window position doesn't change.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux 5.19.13-zen1-1-zen (64-bit)
KDE Plasma Version: 5.25.90
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6

ADDITIONAL INFORMATION
Kernel version doesn't affect behavior, from my testing
Comment 1 Nate Graham 2022-10-12 18:48:32 UTC
Should be fixed with https://invent.kde.org/plasma/kscreen/-/merge_requests/135.
Comment 2 Viko 2022-10-13 07:02:54 UTC
(In reply to Nate Graham from comment #1)
> Should be fixed with
> https://invent.kde.org/plasma/kscreen/-/merge_requests/135.

Then I hope this gets merged soon, rather than later. I'm changing screens often and it's not that it problematic, just quite annoying.
Comment 3 Nicolas Fella 2022-10-14 13:26:52 UTC
*** Bug 460432 has been marked as a duplicate of this bug. ***
Comment 4 Marco Martin 2022-10-14 15:09:37 UTC
Git commit f2489261c10e5fea864cda9c075a1b6613c878d4 by Marco Martin.
Committed on 14/10/2022 at 15:09.
Pushed by mart into branch 'master'.

Make the Output component accept events

This is a workaround to the "drag from empty areas" hack in breeze.
since this uses Event Handlers to manage the drag, the withinBounds property will make it accept the events
also use grabPerimissions to stop anything else from managing the events
FIXED-IN: 5.26.1

M  +14   -9    kcm/package/contents/ui/Output.qml
M  +3    -0    kcm/package/contents/ui/main.qml

https://invent.kde.org/plasma/kscreen/commit/f2489261c10e5fea864cda9c075a1b6613c878d4
Comment 5 Marco Martin 2022-10-14 15:13:28 UTC
Git commit f9d691d9cd9980cc1c2737ebc64cdb8b4cc843e3 by Marco Martin.
Committed on 14/10/2022 at 15:12.
Pushed by mart into branch 'Plasma/5.26'.

Make the Output component accept events

This is a workaround to the "drag from empty areas" hack in breeze.
since this uses Event Handlers to manage the drag, the withinBounds property will make it accept the events
also use grabPerimissions to stop anything else from managing the events
FIXED-IN: 5.26.1

M  +17   -9    kcm/package/contents/ui/Output.qml
M  +3    -0    kcm/package/contents/ui/main.qml

https://invent.kde.org/plasma/kscreen/commit/f9d691d9cd9980cc1c2737ebc64cdb8b4cc843e3