Bug 455786

Summary: Filter isn't reset after effect ends, thus e.g. breaking it for choosing grouped windows
Product: [Plasma] kwin Reporter: Christian (Fuchs) <kde>
Component: effects-present-windowsAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: major CC: nate, niklas.stephanblome
Priority: NOR    
Version: 5.25.1   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Current behaviour, notice that on click on the taskmanager the user gets presented with a blurred screen of nothing
Suggested behaviour, effect works as expected on re-activating it

Description Christian (Fuchs) 2022-06-22 12:40:51 UTC
SUMMARY
There is a filter function which filters windows based on its title. Unfortunately it is not cleared after the effect ends.

STEPS TO REPRODUCE
1. Open present window effect
2. Type something in the filter, e.g. firefox
3. Close the effect
4. Click on grouped tasks in the taskmanager, e.g. if you have two console windows open

OBSERVED RESULT
You can't choose between the two console windows, since the filter on "firefox" is still active

EXPECTED RESULT
Filter is cleared, effect works as expected

SOFTWARE/OS VERSIONS
Operating System: Fedora Linux 36
KDE Plasma Version: 5.25.1
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.3
Kernel Version: 5.18.5-200.fc36.x86_64 (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5600X 6-Core Processor
Memory: 31.2 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3070/PCIe/SSE2
Comment 1 Christian (Fuchs) 2022-06-22 12:57:03 UTC
A workaround (or maybe even fix) is to simply

--- main.qml.orig       2022-06-22 14:55:29.527338810 +0200
+++ main.qml    2022-06-22 14:54:58.916537416 +0200
@@ -28,6 +28,7 @@
     function start() {
         container.animationEnabled = true;
         container.organized = true;
+        effect.searchText = ""
     }
 
     function stop() {


but since I don't know what else might trigger that effect, this might come with side effects. Imho the correct behaviour, UX wise, would be to always clear the filter when the effect is freshly started though, no matter what triggered this. I'll poke VDG folk about it.
Comment 2 Christian (Fuchs) 2022-06-22 13:16:20 UTC
Created attachment 150049 [details]
Current behaviour, notice that on click on the taskmanager the user gets presented with a blurred screen of nothing
Comment 3 Christian (Fuchs) 2022-06-22 13:16:45 UTC
Created attachment 150050 [details]
Suggested behaviour, effect works as expected on re-activating it
Comment 4 Niklas Stephanblome 2022-06-22 15:07:49 UTC
This is already fixed as part of a merge request that is going to be merged in a couple of hours: https://invent.kde.org/plasma/kwin/-/merge_requests/2562
Comment 5 Christian (Fuchs) 2022-06-22 15:09:35 UTC
Oh, aw, and I was currently setting up kdesrc-build, next time, then. 

Thanks for the heads up
Comment 6 Niklas Stephanblome 2022-06-22 15:11:36 UTC
(In reply to Christian (Fuchs) from comment #5)
> Oh, aw, and I was currently setting up kdesrc-build, next time, then. 
> 
> Thanks for the heads up

Didn't see this bug report earlier, just noticed that it wasn't clearing while working on it yesterday, so I thought I might aswell fix it with one line.
Comment 7 Christian (Fuchs) 2022-06-22 15:13:23 UTC
(In reply to Niklas Stephanblome from comment #6)
> (In reply to Christian (Fuchs) from comment #5)
> > Oh, aw, and I was currently setting up kdesrc-build, next time, then. 
> > 
> > Thanks for the heads up
> 
> Didn't see this bug report earlier, just noticed that it wasn't clearing
> while working on it yesterday, so I thought I might aswell fix it with one
> line.

That's perfectly fine, I'm sure I'll find other simple things to start work on. 

Sidenote: probably less simple and thus not for me, but  probably also a candidate for the current effort, if not fixed already: https://bugs.kde.org/show_bug.cgi?id=455783

Thanks for your work :)
Comment 8 Niklas Stephanblome 2022-06-22 15:16:22 UTC
> Sidenote: probably less simple and thus not for me, but  probably also a
> candidate for the current effort, if not fixed already:
> https://bugs.kde.org/show_bug.cgi?id=455783
> 
> Thanks for your work :)

I'll leave the offer up to anyone else because I don't use two monitors (I have an ultrawide monitor instead). But maybe give it a try :) I had to work my way into the codebase too (as it got a complete QML rewrite in 5.25 and I didn't really know QML...)
Comment 9 Nate Graham 2022-06-22 18:54:53 UTC

*** This bug has been marked as a duplicate of bug 455753 ***