Bug 451611

Summary: Cannot download more themes/colours/decoration when systemsettings is in a language other than English. 15-Minutes Bug!
Product: [Applications] systemsettings Reporter: Johannes <lemondejojo>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Severity: normal CC: nate
Priority: NOR    
Version: 5.24.3   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Error when in French (left) and no error when in English (right)

Description Johannes 2022-03-17 09:42:24 UTC
Created attachment 147546 [details]
Error when in French (left) and no error when in English (right)

Whenever trying to download themes or colour schemes or window decorations from systemsettings with systemsettings running in another language than English, the window returns an error "Unknown Open Collaboration Service API error. (0)" (here I translated the error message). However, when running systemsettings in English, there is no bug.

1. Use KDE in e.g. French (for instance in a fresh installed VM)
2. Open systemsettings (Discover)
3. Try to download a theme or window decoration within the Appearance menu. This does not work.
4. Then open a terminal and run `LANG=C systemsettings` where LANG=C stands for default US English.
5. Try again, and now it works (but it is in English, which may not be the user's language).

Linux kernel: 5.13.0-35-generic
Distro: Kubuntu with enabled KDE backports
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.2

I tagged the 15-Minutes Bug Initiative in the title because changing themes is what many people do in the first 15 minutes AND the bug is reproducible on a freshly installed KDE Neon VM set-up to French during the install, which I tried out. There is also someone pointing to this on an Arch forum: https://bbs.archlinux.org/viewtopic.php?id=257236

Note that I am not sure it has to do with systemsettings directly, because whenever a theme or colour scheme or kwin script is installed and gets an update in plasma-discover, plasma-discover would fail at doing the update unless I run it in English (`LANG=C plasma-discover`).
Comment 1 Antonio Rojas 2022-03-17 10:39:46 UTC

*** This bug has been marked as a duplicate of bug 451088 ***
Comment 2 Nate Graham 2022-03-27 04:04:08 UTC

*** This bug has been marked as a duplicate of bug 451165 ***