Bug 447001

Summary: Zoom: Labels and Icons are missplaced on (old) window overview effect while zoom is active
Product: [Plasma] kwin Reporter: Christian H <chrys87>
Component: effects-present-windowsAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: nate
Priority: NOR Keywords: accessibility
Version: 5.24.4   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In: 5.25

Description Christian H 2021-12-14 23:28:56 UTC
SUMMARY
***
When you zoom in with the zoom plugin Meta+= and open the show window effect the labels and icons are not placed correctly ontop of the window previews but flying around with the magnification area. Seems those are painted ontop of the zoom. On the places where the  labels should be are graphical artifacts / glitches.
***


STEPS TO REPRODUCE
1. Zoom in with Meta+= (several times, to see it more easy)
2. Invoke the "old" window overview mode by move the mouse to the most upper left corner
3. move mouse with zoom area arround and look at the window icons / labels

OBSERVED RESULT
the icons / labels are glued to the zoom area and move arround while move the zoom area.

EXPECTED RESULT
the icons / labels should just stay ontop of the window previews
Comment 1 Christian H 2021-12-15 17:56:58 UTC
I created an review video on youtube about the zoom.
https://youtu.be/GfLbDYR7PYE

so you can see the different kind off issues more easy
Comment 2 Nate Graham 2022-05-05 15:16:29 UTC
With the rewrite in Plasma 5.25, now the Zoom effect doesn't work at all in it. :( Probably the same root cause as Bug 447002, now that both effects share the same technology stack.
Comment 3 Christian H 2022-05-05 20:19:11 UTC
(In reply to Nate Graham from comment #2)
> With the rewrite in Plasma 5.25, now the Zoom effect doesn't work at all in
> it. :( 

Ok, i hope we get this fixed then. otherwhise i sadly have to stop use KDE software. Zoom is mandatory for me to use an computer. it would be a big step back. Its for me like just turn of the Screen.


> Probably the same root cause as Bug 447002, now that both effects
> share the same technology stack.

maybe. i dont know. i didnĀ“t now that its not working in 5.25. so i cannot say the reason for. we might need to ask the developer who rewrite this.
Comment 4 Marco Martin 2022-05-06 11:37:26 UTC
Git commit ae1937badc097a864ecfc62e79e7a3899c3be572 by Marco Martin.
Committed on 06/05/2022 at 11:37.
Pushed by mart into branch 'master'.

Remove completely present windows

since it has been replaced by windowview, and Desktop Grid
is ported as well, remove present windows which is effectively dead code
now
Related: bug 362844, bug 450487, bug 453426, bug 374481, bug 185381, bug 413342, bug 451150, bug 283333, bug 315314, bug 397500, bug 321236, bug 436572, bug 335782

M  +0    -1    src/effects/CMakeLists.txt
D  +0    -45   src/effects/presentwindows/CMakeLists.txt
D  +0    -17   src/effects/presentwindows/main.cpp
D  +0    -18   src/effects/presentwindows/main.qml
D  +0    -75   src/effects/presentwindows/metadata.json
D  +0    -2054 src/effects/presentwindows/presentwindows.cpp
D  +0    -343  src/effects/presentwindows/presentwindows.h
D  +0    -51   src/effects/presentwindows/presentwindows.kcfg
D  +0    -104  src/effects/presentwindows/presentwindows_config.cpp
D  +0    -46   src/effects/presentwindows/presentwindows_config.h
D  +0    -487  src/effects/presentwindows/presentwindows_config.ui
D  +0    -36   src/effects/presentwindows/presentwindows_proxy.cpp
D  +0    -35   src/effects/presentwindows/presentwindows_proxy.h
D  +0    -6    src/effects/presentwindows/presentwindowsconfig.kcfgc

https://invent.kde.org/plasma/kwin/commit/ae1937badc097a864ecfc62e79e7a3899c3be572
Comment 5 Nate Graham 2022-05-06 13:15:58 UTC
New bug report to track that: Bug 453467.