Bug 443840

Summary: touchpad scrolling not working when cursor is over notification's body in notifications' history tray applet.
Product: plasmashell Reporter: KDamian <damikope>
Component: NotificationsAssignee: Kai Uwe Broulik <kde>
Status: RESOLVED FIXED    
Severity: normal CC: liubomirwm, nate, plasma-bugs
Priority: NOR Keywords: usability
Version: 5.23.0   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 5.24
Attachments: from where the cursor is the notification list cannot be scrolled with touchpad.
from here the list can be scrolled with touchpad.

Description KDamian 2021-10-16 14:26:55 UTC
Created attachment 142504 [details]
from where the cursor is the notification list cannot be scrolled with touchpad.

SUMMARY

touchpad scrolling not working when cursor is over notification's body in notifications' history tray applet - scrolling is only possible if cursor is either on notification header, on the side or in empty space between notifications.

STEPS TO REPRODUCE
1. Make sure there are enough notifications for scrolling to be activated
2. try scrolling while on one of the notification's body
3. then try scrolling on side/on notification's header/between notifications.

OBSERVED RESULT

Notification cannot be scrolled with touchpad if cursor is over notification's body.

EXPECTED RESULT

Notification list should be scrolled even if cursor is over notification's body.

SOFTWARE/OS VERSIONS

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-37-generic (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-2520M CPU @ 2.50GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 3000

ADDITIONAL INFORMATION

I am using Wayland.
Comment 1 KDamian 2021-10-16 14:28:46 UTC
Created attachment 142505 [details]
from here the list can be scrolled with touchpad.

either from here, notification header or scrollbar notification list can be scrolled with touchpad.
Comment 2 Nate Graham 2021-10-17 22:14:05 UTC
Confirmed. Probably the applet's scrollview and the scrollviews in each notification compete with each other.
Comment 3 Bug Janitor Service 2021-12-01 13:57:25 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1239
Comment 4 Nate Graham 2021-12-01 20:54:25 UTC
*** Bug 446325 has been marked as a duplicate of this bug. ***
Comment 5 Fushan Wen 2021-12-02 04:41:19 UTC
Git commit 3a1603a4e1c88eb5efc83c646855dbc22ba76d7f by Fushan Wen.
Committed on 02/12/2021 at 00:05.
Pushed by ngraham into branch 'master'.

applets/notifications: Pass wheel events of TextArea to ListView

Prevent `TextArea` in SelectableLabel from accepting wheel
events when the notification item is in FullRepresentation,
and pass wheel events to `ListView` in FullRepresentation when the
cursor is over the `TextArea`.
FIXED-IN: 5.24

M  +1    -0    applets/notifications/package/contents/ui/FullRepresentation.qml
M  +2    -0    applets/notifications/package/contents/ui/NotificationItem.qml
M  +13   -0    applets/notifications/package/contents/ui/SelectableLabel.qml

https://invent.kde.org/plasma/plasma-workspace/commit/3a1603a4e1c88eb5efc83c646855dbc22ba76d7f