Bug 433138

Summary: Since update to 5.21, system tray icons on a very thin panel are smaller
Product: [Plasma] plasmashell Reporter: Jan Pavlicek <jan.pavlicek>
Component: System TrayAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED INTENTIONAL    
Severity: normal CC: a.geno, dev-kde, geisserml, ilia-kats, KDE, mat.mueller, materka, nate, niccolo.venerandi
Priority: HI Keywords: regression
Version: 5.21.0   
Target Milestone: 1.0   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In: 5.21.2
Attachments: Original icons size now available only when panel size is 35 or higher
New smaller icon size for panel with size 24
Plasma panel 5.20. and 5.21 in horizontal orientation
The panel on the last of the four systems I upgraded today, before and after re-login
Icon Sizes in 5.21 Tray
Demonstration of different icons sizes in different themes
panels of different heights
What needs to be changed in panel background to make icons large again
Whoopsie, forgot the screenshot.

Description Jan Pavlicek 2021-02-18 07:26:03 UTC
SUMMARY

Hello everyone,

since the update to plasma 5.21, the icons in system tray are significantly smaller. More precisely, the threshold for smaller-scale icons changed from panel size 24 to 35. The small icons are very hard to read, but I really don't want to enlarge my panels by that much. I use oxygen-colors theme, but I think this applies to any theme. I have added a screenshot to ilustrate.

Would it be possible to revert this change? Is there a reason for it and if so, could it be made configurable?

Thanks and have a nice day!

STEPS TO REPRODUCE
1. Update to 5.21
2. Observe the icons in systray get significantly smaller
3. Set panel size to 35, icons get to their original size

OBSERVED RESULT
Small icons in systray when panel size is <35

EXPECTED RESULT
Larger icons in systray when panel size is >23
Comment 1 Jan Pavlicek 2021-02-18 07:26:45 UTC
Created attachment 135811 [details]
Original icons size now available only when panel size is 35 or higher
Comment 2 Jan Pavlicek 2021-02-18 07:27:08 UTC
Created attachment 135812 [details]
New smaller icon size for panel with size 24
Comment 3 Frank Steinmetzger 2021-02-18 10:29:03 UTC
Created attachment 135828 [details]
Plasma panel 5.20. and 5.21 in horizontal orientation

I also noticed issues with my panel icons. But mine are in fact bigger now; exactly one pixel wider, but with the same height. This causes them to appear blurred. The same goes for task switcher icons. Panel height is set at 28.
Comment 4 Nate Graham 2021-02-18 14:19:16 UTC
Do you have a Margins Separator applet in your panel?
Comment 5 Frank Steinmetzger 2021-02-18 17:23:16 UTC
No. I never even heard of it until you asked.

I just tested it on another machine (not the one from my screenshot) which also shows some blur in its horizontal panel, only this panel is a little higher for touch-friendliness. Adding a margin applet and removing it again also made no difference.
Comment 6 Nate Graham 2021-02-18 17:39:07 UTC
Can confirm now.

Niccolò, perhaps this is some fallout from the margin changes? At very very thin panel thicknesses, we need to basically be using no extra margins or else things are too small.
Comment 7 Frank Steinmetzger 2021-02-18 19:07:11 UTC
Created attachment 135863 [details]
The panel on the last of the four systems I upgraded today, before and after re-login

Aw man, now it’s getting complicated. :(
I just had the time to looked at the last of my machines and this one is just fine.

The icons do take up less space (less margin, apparently), but their size has not changed and they are not stretched. And this here panel is even only 26 px high because the screen is a desktop monitor with only 108 DPI. My previous screenshot comes from a laptop with a 172 DPI screen, hence a few more pixels.

To summarise:
Today I upgraded four systems: PC, Laptop, Tablet, virtual machine, all running the same distribution and package versions. I use Oxygen as my main icon theme on all of them, in case that’s relevant.

System    Panel height    Graphics    Font DPI    Icons look…
-------------------------------------------------------------
Laptop       28 px         Intel        172       blurry
Tablet       38 px         Intel        192       blurry
PC           26 px         Radeon       108       normal
VM          vertical       VMware                 normal
Comment 8 Matthias Mueller 2021-02-25 08:14:47 UTC
Created attachment 136142 [details]
Icon Sizes in 5.21 Tray

i can also confirm an undesirable change in the icon size. I've got a vertical panel and after updating to 5.21 the icons with the setting "fit to panel size" are way bigger than before, "small" icons are (i think?) even smaller than before.
Ideally the icons with setting "fit to size" should be the same size as in the taskbar for the running programs imho.
In 5.20, that was (at least roughly) the case when using "fit to size" (at least with my panel width 50)
Comment 9 Nate Graham 2021-02-25 16:40:57 UTC
I talked with the author of this change and discovered that the blurriness is already fixed in Plasma 5.22, but unfortunately the change to do so could not be backported to Plasma 5.21 because it depended on a Frameworks version that was newer than the Plasma 5.21 dependency version.

We're going to see if we can backport a smaller version of it that fixes the bug in Plasma 5.21 without depending on a newer Frameworks version.
Comment 10 Nate Graham 2021-02-25 17:01:59 UTC
We have a fix: https://invent.kde.org/plasma/plasma-desktop/-/commit/1d53973d633dcd9073efe6b38d0cafb6344d89d0

Please test that or wait for Plasma 5.21.2.
Comment 11 Jan Pavlicek 2021-02-25 17:20:02 UTC
Hi,

thanks very much for taking the time to work on this. I'm on Arch packages, so I should have the 5.21.2 version soon. I'll test it when it lands in repos and let you know right away!

Thanks
Comment 12 Ilia Kats 2021-02-26 09:27:22 UTC
Doesn't work for me. I just edited /usr/share/plasma/plasmoids/org.kde.panel/contents/ui/main.qml and restarted plasmashell, icons are still too small. Note that editing my plasma theme and setting the margin hints in panel-background.svg to 1px helps.
Comment 13 veggero 2021-02-26 09:33:07 UTC
To clarify, the fix is regarding the blurryness of the icons, not their size. I'm afraid the size change is intentional.
Comment 14 Matthias Mueller 2021-02-26 09:37:18 UTC
The i guess we shouldn't mark this report as resolved fixed as it originally is about the size and not the blurriness?
Comment 15 veggero 2021-02-26 09:39:00 UTC
Right.
Comment 16 Matthias Mueller 2021-02-26 09:43:12 UTC
I don't know if resolved is even the right category - even if it is intentionally, it still looked way better before imho.  Or are suggestions/requests tracked elsewhere that i don't know of yet?
Comment 17 veggero 2021-02-26 10:07:40 UTC
After giving this bug a bit more thought, I gotta say I'm really confused. It's a mess of different bugs mixed in. So let me discuss each one singularly.

Jan: could you upload a couple more screenshot with your panel at size 34, 30, and maybe 26? Weirdly enough, I cannot reproduce smaller icons at size <35, for me it's <44 with Oxygen. I think what you are seeing at size 24 are 16px icon, that - to me - disappear at 24px size. From 24px and on, I get the 22px icons, which is correct. The other screenshot, panel size 35 or higher, show 22px icons that should appear from 24px. What theme are you using? It does not look like pure Oxygen.

Frank: The blurryness should have been fixed in 5.21.2 thanks to the above patch. Please report to me whether everything is fine whet it comes out.

Matthias: Stupid me. After spending lots of time trying to figure out what the hell was happening, I remember this is actually a know bug that's fixed in 5.22. It only affects vertical panels. Sorry about the confusion.
Comment 18 Jan Pavlicek 2021-02-26 11:09:40 UTC
Hi, I must say I was a little bit confused too, but it seems clear to me now. I will upload more screenshots today when I get back to my work machine - I am not using pure Oxygen (I use oxygen-colors), but I am able to reproduce it with stock Oxygen as well - I'll do a bunch of screenshots and upload.

Thanks!
Comment 19 Jan Pavlicek 2021-03-01 12:42:47 UTC
Created attachment 136279 [details]
Demonstration of different icons sizes in different themes
Comment 20 Jan Pavlicek 2021-03-01 12:49:13 UTC
I have added bunch of screenshots with different panel heights as veggero to further clarify the problem. While doing that, I have found that this issue does not affect Breeze - that theme behaves as Oxygen did before. But I was able to reproduce the behavior with stock Oxygen as well as my edited one with colored tray icons.
Comment 21 Jan Pavlicek 2021-03-01 12:53:54 UTC
(In reply to Ilia Kats from comment #12)
> Doesn't work for me. I just edited
> /usr/share/plasma/plasmoids/org.kde.panel/contents/ui/main.qml and restarted
> plasmashell, icons are still too small. Note that editing my plasma theme
> and setting the margin hints in panel-background.svg to 1px helps.

Could you elaborate on how to set the margin hits? I tried dragging the green boxes in Inkscape, but with no effect - I suspect that their actual size on the page is not relevant and the 1px height is set elsewhere? Thanks!
Comment 22 Ilia Kats 2021-03-01 14:03:48 UTC
Created attachment 136282 [details]
panels of different heights

In contrast to Jan, I can also reproduce this with the Breeze theme (attached screenshots using Breeze Dark). Note that I normally have the panel set to 36px, with Plasma 5.20 the icons would have the full height of the panel.

Jan: For me it really was enough to change the size of the margin-hints object and restart plasmashell. But there are several plasma-background.svg files, one in widgets, one in translucent/widgets and one in opaque/widgets, you may need to edit all of them.
Comment 23 Frank Steinmetzger 2021-03-03 14:23:49 UTC
veggero: I just installed 5.21.2 on the two affected systems and another unaffected one. The icon bluriness has gone away now, both in the taskbar and also in the tray area. I made comparative screenshots and looking at 5.21.1 again, the taskbar items themselves also had aliased (not-sharp) borders on the left and right. Those are fixed as well.
Comment 24 Nate Graham 2021-03-09 03:48:59 UTC
*** Bug 433777 has been marked as a duplicate of this bug. ***
Comment 25 Jan Pavlicek 2021-03-24 09:35:40 UTC
I was able to finaly work around this by modifying the SVG files of the Oxygen theme. For me, changing only the margin hits to 1px, as Ilia Kats said, didn't work. I had to change the sizes of the panel corners themselves. I have attached a screenshot of what needs to be done to solve this - the file I changed is in /usr/share/plasma/desktoptheme/oxygen2/widgets/panel-background.svgz (archlinux, might be different elsewhere) - there is also a mask that needs to be resized in the same way.

I'm not sure what to do with this bug, but I think it can be closed since workaround exists and if I understand correctly, there are no plans to revert changes that made this workaround necessary.

Thanks to everyone looking into this, especially Ilia Kats for pointing me into the right direction.
Comment 26 Jan Pavlicek 2021-03-24 09:36:33 UTC
Created attachment 137018 [details]
What needs to be changed in panel background to make icons large again
Comment 27 Nate Graham 2021-03-24 17:26:28 UTC
You could perhaps submit that change to the Oxygen theme: https://invent.kde.org/plasma/oxygen/-/merge_requests
Comment 28 Jan Pavlicek 2021-03-24 17:30:11 UTC
You're right, I'll double check that the change didn't break anything when I have a bit of time and issue a merge request.
Comment 29 Matthias Mueller 2021-05-22 10:25:36 UTC
I'm now on 5.21.5 and still got the same issue - see my earlier screenshot - i somehow can't believe THAT should be intentional?!
Comment 30 Frank Steinmetzger 2022-01-19 21:01:13 UTC
(In reply to veggero from comment #17)
> […]
> Frank: The blurryness should have been fixed in 5.21.2 thanks to the above
> patch. Please report to me whether everything is fine whet it comes out.

(In reply to Frank Steinmetzger from comment #23)
> veggero: I just installed 5.21.2 on the two affected systems and another
> unaffected one. The icon bluriness has gone away now, both in the taskbar
> and also in the tray area.

I’m sorry, but I must rescind my previous answer. I’ve been having blurry icons again on my laptop (the one with 176 DPI setting) for quite some time now. I narrowed it down by setting a new DPI and restarting plasmasession. Please look at the screenshot. The panel is always the same size (in pixels). As you can see from the clock’s font, the margin is increasing in pixel count (as is expected to compensate for the higher pixel density, so it always looks the same physically). But for the icons the margins actually shrink. Could this be a sign error? :-)

The clipboard icon for 142 DPI is clearly 16×16. But the one for 144 DPI is only 18 px high instead of the next common icon size (22 I believe). So I think it would be nice if plasma knew which sizes it may draw (16, 22, 48, 64 and so in) and which not in order to avoid this.
Comment 31 Frank Steinmetzger 2022-01-19 21:01:43 UTC
Created attachment 145651 [details]
Whoopsie, forgot the screenshot.