Bug 430431

Summary: Dolphin crashed while inserting pen drive
Product: [Plasma] plasmashell Reporter: Marcelo Jimenez <marcelo.jimenez>
Component: generalAssignee: David Edmundson <kde>
Status: RESOLVED DUPLICATE    
Severity: crash CC: nate, plasma-bugs
Priority: NOR Keywords: drkonqi
Version: 5.20.3   
Target Milestone: 1.0   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Marcelo Jimenez 2020-12-15 16:25:53 UTC
Application: plasmashell (5.20.3)

Qt Version: 5.15.2
Frameworks Version: 5.76.0
Operating System: Linux 5.9.11-1-default x86_64
Windowing system: X11
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:

I had just completed inserting the pen drive and clicked on the icon on the system tray in order to mount it.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault

[New LWP 18282]
[New LWP 18293]
[New LWP 18669]
[New LWP 22623]
[New LWP 23222]
[New LWP 25620]
[New LWP 3210]
[New LWP 3211]
[New LWP 3212]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
0x00007fe4685b183f in __GI___poll (fds=0x7ffcf7c96b70, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
29	  return SYSCALL_CANCEL (poll, fds, nfds, timeout);
[Current thread is 1 (Thread 0x7fe466490840 (LWP 18271))]

Thread 10 (Thread 0x7fe3fa9ef640 (LWP 3212)):
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007fe468961091 in QtLinuxFutex::_q_futex(int*, int, int, unsigned long long, int*, int) (val3=0, addr2=0x0, val2=0, val=<optimized out>, op=0, addr=<optimized out>) at thread/qfutex_p.h:133
#2  QtLinuxFutex::futexWait<QBasicAtomicInteger<unsigned int> >(QBasicAtomicInteger<unsigned int>&, QBasicAtomicInteger<unsigned int>::Type) (expectedValue=<optimized out>, futex=...) at thread/qfutex_p.h:135
#3  futexSemaphoreTryAcquire_loop<false>(QBasicAtomicInteger<unsigned long long>&, unsigned long long, unsigned long long, int) (timeout=-1, nn=8589934593, curValue=<optimized out>, u=...) at thread/qsemaphore.cpp:219
#4  futexSemaphoreTryAcquire<false>(QBasicAtomicInteger<unsigned long long>&, int, int) (timeout=-1, n=<optimized out>, u=...) at thread/qsemaphore.cpp:262
#5  QSemaphore::acquire(int) (this=0x7fe4683f0920, n=<optimized out>) at thread/qsemaphore.cpp:326
#6  0x00007fe46833f934 in  () at /usr/lib64/libQt5Network.so.5
#7  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x7fe4683f0900) at thread/qthread_unix.cpp:329
#8  0x00007fe467af13e9 in start_thread (arg=0x7fe3fa9ef640) at pthread_create.c:463
#9  0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 9 (Thread 0x7fe3f91ec640 (LWP 3211)):
#0  0x00007fe4685b183f in __GI___poll (fds=0x7fe4240013e0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe466f6b00e in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe466f6b12f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe468b977fb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fe424000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fe468b3ec4b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fe3f91ebcc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007fe46895dd0e in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x561f306bce20) at thread/qthread_unix.cpp:329
#7  0x00007fe467af13e9 in start_thread (arg=0x7fe3f91ec640) at pthread_create.c:463
#8  0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7fe447fff640 (LWP 3210)):
#0  0x00007fe466f6a458 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#1  0x00007fe466f6af3b in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe466f6b12f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe468b977fb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fe44000ea80, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fe468b3ec4b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fe447ffecc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007fe46895dd0e in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x561f2d1d54c0) at thread/qthread_unix.cpp:329
#7  0x00007fe467af13e9 in start_thread (arg=0x7fe447fff640) at pthread_create.c:463
#8  0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fe446dfd640 (LWP 25620)):
#0  0x00007fe4685b183f in __GI___poll (fds=0x7fe434002570, nfds=3, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe44f05d542 in  () at /usr/lib64/libpulse.so.0
#2  0x00007fe44f04ef89 in pa_mainloop_poll () at /usr/lib64/libpulse.so.0
#3  0x00007fe44f04f60f in pa_mainloop_iterate () at /usr/lib64/libpulse.so.0
#4  0x00007fe44f04f6c0 in pa_mainloop_run () at /usr/lib64/libpulse.so.0
#5  0x00007fe44f05d619 in  () at /usr/lib64/libpulse.so.0
#6  0x00007fe44edb75e8 in  () at /usr/lib64/pulseaudio/libpulsecommon-13.0.so
#7  0x00007fe467af13e9 in start_thread (arg=0x7fe446dfd640) at pthread_create.c:463
#8  0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fe44484c640 (LWP 23222)):
#0  0x00007fe466f68de0 in g_source_ref () at /usr/lib64/libglib-2.0.so.0
#1  0x00007fe466f68ec8 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe466f6a403 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe466f6af3b in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fe466f6b12f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007fe468b977fb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fe418000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007fe468b3ec4b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fe44484bc80, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#7  0x00007fe46895dd0e in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#8  0x00007fe444d92438 in KCupsConnection::run() () at /usr/lib64/libkcupslib.so
#9  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x561f1bbfa7e0) at thread/qthread_unix.cpp:329
#10 0x00007fe467af13e9 in start_thread (arg=0x7fe44484c640) at pthread_create.c:463
#11 0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fe44ffa5640 (LWP 22623)):
#0  0x00007fe466f68df8 in g_source_ref () at /usr/lib64/libglib-2.0.so.0
#1  0x00007fe466f68ec8 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe466f6a403 in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe466f6af3b in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007fe466f6b12f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007fe468b977fb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fe448003040, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007fe468b3ec4b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fe44ffa4c80, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#7  0x00007fe46895dd0e in QThread::exec() (this=this@entry=0x561f1b7da450) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#8  0x00007fe46a5fff26 in QQuickPixmapReader::run() (this=0x561f1b7da450) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/quick/util/qquickpixmapcache.cpp:1024
#9  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x561f1b7da450) at thread/qthread_unix.cpp:329
#10 0x00007fe467af13e9 in start_thread (arg=0x7fe44ffa5640) at pthread_create.c:463
#11 0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fe462506640 (LWP 18669)):
#0  0x00007fe4685b183f in __GI___poll (fds=0x7fe458004a60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe466f6b00e in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe466f6b12f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe468b977fb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fe458000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fe468b3ec4b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fe462505ca0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007fe46895dd0e in QThread::exec() (this=this@entry=0x561f1af23420) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007fe46a220675 in QQmlThreadPrivate::run() (this=0x561f1af23420) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/ftw/qqmlthread.cpp:155
#7  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x561f1af23420) at thread/qthread_unix.cpp:329
#8  0x00007fe467af13e9 in start_thread (arg=0x7fe462506640) at pthread_create.c:463
#9  0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fe46377c640 (LWP 18293)):
#0  0x00007fe4685b183f in __GI___poll (fds=0x7fe454014f00, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe466f6b00e in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fe466f6b12f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fe468b977fb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fe454000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fe468b3ec4b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fe46377bc70, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007fe46895dd0e in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007fe4695667c7 in  () at /usr/lib64/libQt5DBus.so.5
#7  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x7fe4695d4420) at thread/qthread_unix.cpp:329
#8  0x00007fe467af13e9 in start_thread (arg=0x7fe46377c640) at pthread_create.c:463
#9  0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fe4643c4640 (LWP 18282)):
#0  0x00007fe4685b183f in __GI___poll (fds=0x7fe4643c3bc8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe46ab1c862 in  () at /usr/lib64/libxcb.so.1
#2  0x00007fe46ab1e26c in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007fe464599fb0 in QXcbEventQueue::run() (this=0x561f1aaa0380) at qxcbeventqueue.cpp:228
#4  0x00007fe46895ee51 in QThreadPrivate::start(void*) (arg=0x561f1aaa0380) at thread/qthread_unix.cpp:329
#5  0x00007fe467af13e9 in start_thread (arg=0x7fe4643c4640) at pthread_create.c:463
#6  0x00007fe4685bc943 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fe466490840 (LWP 18271)):
[KCrash Handler]
#4  std::__atomic_base<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/bits/atomic_base.h:741
#5  std::atomic<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/atomic:523
#6  QAtomicOps<QThreadData*>::loadRelaxed<QThreadData*>(std::atomic<QThreadData*> const&) (_q_value=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/qt5/QtCore/qatomic_cxx11.h:239
#7  QBasicAtomicPointer<QThreadData>::loadRelaxed() const (this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/qt5/QtCore/qbasicatomic.h:248
#8  QQmlNotifierEndpoint::connect(QObject*, int, QQmlEngine*, bool) (this=this@entry=0x561f2914cc10, source=0x561f3f045170, sourceSignal=46, engine=0x0, doNotify=doNotify@entry=true) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlnotifier.cpp:122
#9  0x00007fe46a1710d4 in QQmlVMEMetaObjectEndpoint::tryConnect() (this=0x561f2914cc10) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:266
#10 0x00007fe46a1c4a49 in QQmlNotifierEndpoint::connect(QObject*, int, QQmlEngine*, bool) (this=this@entry=0x561f2a4cece0, source=source@entry=0x561f4b127f50, sourceSignal=sourceSignal@entry=32, engine=0x561f1af2bd90, doNotify=doNotify@entry=true) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmlnotifier.cpp:138
#11 0x00007fe46a1e11a6 in QQmlPropertyCapture::captureProperty(QObject*, int, int, bool) (this=0x7ffcf7c978c0, o=o@entry=0x561f4b127f50, c=<optimized out>, n=32, doNotify=doNotify@entry=true) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/src/qml/qml/qqmljavascriptexpression.cpp:315
#12 0x00007fe46a0abd9d in QV4::QObjectWrapper::getProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData*) (engine=0x561f1adc3560, object=0x561f4b127f50, property=0x7fe4589365c8) at /usr/src/debug/libqt5-qtdeclarative-5.15.2-1.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:285
#13 0x00007fe45058eb9d in  ()
#14 0x0000000000000000 in  ()
[Inferior 1 (process 18271) detached]

The reporter indicates this bug may be a duplicate of or related to bug 427945.

Possible duplicates by query: bug 427945, bug 422533.

Reported using DrKonqi
Comment 1 Nate Graham 2020-12-16 21:43:25 UTC
eeeeeeeeeee


#4  std::__atomic_base<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/bits/atomic_base.h:741
#5  std::atomic<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/atomic:523
#6  QAtomicOps<QThreadData*>::loadRelaxed<QThreadData*>(std::atomic<QThreadData*> const&) (_q_value=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/qt5/QtCore/qatomic_cxx11.h:239
Comment 2 Nate Graham 2021-02-26 17:06:23 UTC

*** This bug has been marked as a duplicate of bug 427945 ***