| Summary: | Change "Delete" to "Delete Forever" for delete action to emphasize permanence | ||
|---|---|---|---|
| Product: | [Frameworks and Libraries] frameworks-kconfigwidgets | Reporter: | Andres Betts <anditosan1000> |
| Component: | general | Assignee: | kdelibs bugs <kdelibs-bugs-null> |
| Status: | RESOLVED INTENTIONAL | ||
| Severity: | wishlist | CC: | dolphin-bugs-null, nate |
| Priority: | NOR | ||
| Version First Reported In: | 5.76.0 | ||
| Target Milestone: | --- | ||
| Platform: | Other | ||
| OS: | Linux | ||
| Latest Commit: | Version Fixed/Implemented In: | ||
| Sentry Crash Report: | |||
|
Description
Andres Betts
2020-11-17 16:00:59 UTC
One item/bug/request per bug report please. :) Let's use this to track #1, changing "Delete" to "Delete Forever". That seems reasonable. The text of this item lives in kconfigwidgets; moving there. Please do file new bug reports for the other things so they don't get lost. A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kconfigwidgets/-/merge_requests/27 Consistency is important too. "Delete" is generally used, not "Delete forever". Same for "Properties": otherwise you would have to add the object name to any action. The object of the action is by default the object you are acting upon. I would personally be much against both kind of changes. The "move to trash" suggestions are a bit different and may be interesting to think about them My merge requests to change the standard text were not met with much enthusiasm. I suppose we could still override the standard text in just the relevant apps (Dolphin, KIO's KDirOperator, Plasma folder view, Kate). This would involve quite a few merge requests though, and there's the risk of them drifting out of sync later. I feel that this would defeat the point of having standard text in the first place. Doesn't seem like we'll end up doing this, sorry. :) |