Bug 428222

Summary: Add option to highlight all occurrences of the search-term.
Product: [Applications] okular Reporter: Clarc <f.thaler>
Component: generalAssignee: Okular developers <okular-devel>
Status: RESOLVED DUPLICATE    
Severity: wishlist CC: aacid, nate
Priority: NOR    
Version: 1.11.2   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: qpdfview highlight all occurences

Description Clarc 2020-10-25 09:27:28 UTC
SUMMARY
Add option to highlight all occurrences of the search-term. This should make spotting them way easier, even if you're not clicking through every single instance to highlight them one after the other.

Many PDF-readers have this useful feature and I think it's important for Okular to add it as well.

I added a screenshot from "qpdfview" to highlight what I'm talking about.



SYSTEM INFORMATION
Okular-Verstion: Version 1.11.2
Linux Mint 20
KDE Frameworks 5.74.0
Qt 5.15.1 (built against 5.15.1)
The xcb windowing system
Comment 1 Clarc 2020-10-25 09:27:46 UTC
Created attachment 132716 [details]
qpdfview highlight all occurences
Comment 2 Albert Astals Cid 2020-10-25 10:58:10 UTC
FWIW this feature kind of already exists, you just need to find in the thumbnail view
Comment 3 Clarc 2020-10-25 17:14:55 UTC
(In reply to Albert Astals Cid from comment #2)
> FWIW this feature kind of already exists, you just need to find in the
> thumbnail view

I'm not sure what you mean. I would expect it to be in the options-popup in the search-bar. I searched for it and couldn't find it.
Could you specify the location?
Comment 4 Nate Graham 2020-10-25 17:28:40 UTC

*** This bug has been marked as a duplicate of bug 377487 ***