Bug 427154

Summary: Non-Latin letters invisible in Okular annotations in PDF documents
Product: [Applications] okular Reporter: Serhiy Zahoriya <serhiy.int>
Component: PDF backendAssignee: Okular developers <okular-devel>
Status: RESOLVED DUPLICATE    
Severity: major CC: yurchor
Priority: NOR    
Version: 1.9.3   
Target Milestone: ---   
Platform: Kubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Serhiy Zahoriya 2020-09-30 14:21:13 UTC
SUMMARY
When trying to add a Typewriter annotation to a PDF in Okular only Latin letters are visible.

STEPS TO REPRODUCE
1. Open any PDF in Okular
2. Press F6, select Typewriter annotation tool
3. Create an annotation with this text:
"annotation анотація annotation анотація"

OBSERVED RESULT
Only latin letters are visible, Cyrillic letters don't even take any space between Latin.

EXPECTED RESULT
All UTF-8 characters presented in some form.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma:
KDE Plasma Version: 5.18.5
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8

ADDITIONAL INFORMATION
All the letters are visible when it's not a PDF, tried with opening a Markdown file.
Comment 1 Yuri Chornoivan 2020-09-30 14:26:28 UTC

*** This bug has been marked as a duplicate of bug 305534 ***