Bug 421100

Summary: Plasmashell crashes right after start
Product: plasmashell Reporter: sedrubal <kde>
Component: generalAssignee: David Edmundson <kde>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adundovi, avallash, dssouzadan, plasma-bugs, travneff
Priority: NOR Keywords: drkonqi
Version: 5.18.3   
Target Milestone: 1.0   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description sedrubal 2020-05-06 11:03:56 UTC
Application: plasmashell (5.18.3)

Qt Version: 5.13.2
Frameworks Version: 5.68.0
Operating System: Linux 5.6.8-300.fc32.x86_64 x86_64
Windowing system: X11
Distribution: Fedora 32 (Thirty Two)

-- Information about the crash:
- What I was doing when the application crashed:

I think, as soon as a notification comes in, plasmashell / plasmaworkspace crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbf33935580 (LWP 9938))]

Thread 12 (Thread 0x7fbee2570700 (LWP 9991)):
[KCrash Handler]
#6  std::__atomic_base<int>::operator++ (this=0x1296) at /usr/include/c++/10/bits/atomic_base.h:325
#7  QAtomicOps<int>::ref<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:265
#8  QBasicAtomicInteger<int>::ref (this=0x1296) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:114
#9  QRawFontPrivate::setFontEngine (engine=0x128a, this=0x7fbed40e5550) at text/qrawfont_p.h:128
#10 glyphRunWithInfo (fontEngine=0x128a, glyphLayout=..., pos=..., flags=..., selectionX=..., selectionWidth=..., glyphsStart=28, glyphsEnd=28, logClusters=<optimized out>, textPosition=0, textLength=44) at text/qtextlayout.cpp:2239
#11 0x00007fbf37ba219e in QTextLine::glyphRuns (this=this@entry=0x7fbee256d5c0, from=from@entry=0, length=<optimized out>, length@entry=44) at ../../include/QtCore/../../src/corelib/tools/qarraydata.h:211
#12 0x00007fbf390d2090 in QQuickTextNodeEngine::addGlyphsInRange (this=this@entry=0x7fbee256d560, rangeStart=rangeStart@entry=0, rangeLength=rangeLength@entry=44, color=..., backgroundColor=..., selectionStart=selectionStart@entry=-1, selectionEnd=-1) at items/qquicktextnodeengine.cpp:593
#13 0x00007fbf390d26d4 in QQuickTextNodeEngine::addGlyphsForRanges (this=this@entry=0x7fbee256d560, ranges=..., start=start@entry=0, end=44, selectionStart=selectionStart@entry=-1, selectionEnd=selectionEnd@entry=-1) at /usr/include/qt5/QtGui/qcolor.h:290
#14 0x00007fbf390d0fcb in QQuickTextNode::addTextLayout (this=this@entry=0x7fbed457cde0, position=..., textLayout=0x561d908a65d0, color=..., style=QQuickText::Normal, styleColor=..., anchorColor=..., selectionColor=..., selectedTextColor=..., selectionStart=-1, selectionEnd=-1, lineStart=0, lineCount=1) at items/qquicktextnode.cpp:268
#15 0x00007fbf390cf7e1 in QQuickText::updatePaintNode (this=0x561d8d3b7580, oldNode=<optimized out>, data=<optimized out>) at /usr/include/qt5/QtCore/qpoint.h:287
#16 0x00007fbf39085778 in QQuickWindowPrivate::updateDirtyNode (this=0x561d8b3d44f0, item=0x561d8d3b7580) at items/qquickwindow.cpp:3532
#17 0x00007fbf3908600b in QQuickWindowPrivate::updateDirtyNodes (this=this@entry=0x561d8b3d44f0) at items/qquickwindow.cpp:3277
#18 0x00007fbf390876d6 in QQuickWindowPrivate::syncSceneGraph (this=this@entry=0x561d8b3d44f0) at items/qquickwindow.cpp:437
#19 0x00007fbf3902d962 in QSGRenderThread::sync (this=this@entry=0x561d8d3ff480, inExpose=inExpose@entry=false) at scenegraph/qsgthreadedrenderloop.cpp:563
#20 0x00007fbf3902ef14 in QSGRenderThread::syncAndRender (this=this@entry=0x561d8d3ff480) at scenegraph/qsgthreadedrenderloop.cpp:610
#21 0x00007fbf3902f3b8 in QSGRenderThread::run (this=0x561d8d3ff480) at scenegraph/qsgthreadedrenderloop.cpp:730
#22 0x00007fbf3759b846 in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:360
#23 0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#24 0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7fbee886c700 (LWP 9983)):
#0  0x00007fbf35e99c2d in g_source_unref_internal () from /lib64/libglib-2.0.so.0
#1  0x00007fbf35e9b985 in g_source_iter_next () from /lib64/libglib-2.0.so.0
#2  0x00007fbf35e9cf23 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#3  0x00007fbf35e9da1b in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#4  0x00007fbf35e9dc23 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00007fbf37772c23 in QEventDispatcherGlib::processEvents (this=0x7fbedc000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007fbf3772621b in QEventLoop::exec (this=this@entry=0x7fbee886bd60, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#7  0x00007fbf3759a577 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#8  0x00007fbee8d8d66c in KCupsConnection::run() () from /lib64/libkcupslib.so
#9  0x00007fbf3759b846 in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:360
#10 0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#11 0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7fbeeac3a700 (LWP 9969)):
#0  0x00007fbf35eec1d8 in g_mutex_unlock () from /lib64/libglib-2.0.so.0
#1  0x00007fbf35e9dc2e in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#2  0x00007fbf37772c23 in QEventDispatcherGlib::processEvents (this=0x7fbee4000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#3  0x00007fbf3772621b in QEventLoop::exec (this=this@entry=0x7fbeeac39da0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#4  0x00007fbf3759a577 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#5  0x00007fbf3759b846 in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:360
#6  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#7  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7fbf05d38700 (LWP 9958)):
#0  0x00007fbf36af1e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbf375a1463 in QWaitConditionPrivate::wait (deadline=..., deadline=..., this=0x561d8b32aaf0) at thread/qwaitcondition_unix.cpp:146
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x561d8b328d10, deadline=...) at thread/qwaitcondition_unix.cpp:225
#3  0x00007fbf3902df64 in QSGRenderThreadEventQueue::takeEvent (wait=true, this=0x561d8b328d08) at scenegraph/qsgthreadedrenderloop.cpp:245
#4  QSGRenderThread::processEventsAndWaitForMore (this=this@entry=0x561d8b328c90) at scenegraph/qsgthreadedrenderloop.cpp:710
#5  0x00007fbf3902f44d in QSGRenderThread::run (this=0x561d8b328c90) at scenegraph/qsgthreadedrenderloop.cpp:739
#6  0x00007fbf3759b846 in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:360
#7  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#8  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fbf0ea9c700 (LWP 9956)):
#0  0x00007fbf36af1e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbf1e1e813b in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007fbf1e1e7c0b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fbf0f29d700 (LWP 9955)):
#0  0x00007fbf36af1e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbf1e1e813b in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007fbf1e1e7c0b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fbf1cb77700 (LWP 9954)):
#0  0x00007fbf36af1e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbf1e1e813b in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007fbf1e1e7c0b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fbf1d378700 (LWP 9953)):
#0  0x00007fbf36af1e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbf1e1e813b in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007fbf1e1e7c0b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fbf1ffff700 (LWP 9952)):
#0  0x00007fbf37217b6f in poll () from /lib64/libc.so.6
#1  0x00007fbf35e9daee in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#2  0x00007fbf35e9dc23 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fbf37772c23 in QEventDispatcherGlib::processEvents (this=0x7fbf14000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fbf3772621b in QEventLoop::exec (this=this@entry=0x7fbf1fffed80, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#5  0x00007fbf3759a577 in QThread::exec (this=this@entry=0x561d8ab6f1d0) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#6  0x00007fbf38cc8d89 in QQmlThreadPrivate::run (this=0x561d8ab6f1d0) at qml/ftw/qqmlthread.cpp:152
#7  0x00007fbf3759b846 in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:360
#8  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fbf25a67700 (LWP 9948)):
#0  0x00007fbf37217b6f in poll () from /lib64/libc.so.6
#1  0x00007fbf35e9daee in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#2  0x00007fbf35e9dc23 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fbf37772c23 in QEventDispatcherGlib::processEvents (this=0x7fbf18000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fbf3772621b in QEventLoop::exec (this=this@entry=0x7fbf25a66d50, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#5  0x00007fbf3759a577 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#6  0x00007fbf386654da in QDBusConnectionManager::run (this=0x7fbf386d3060 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#7  0x00007fbf3759b846 in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:360
#8  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fbf2663f700 (LWP 9947)):
#0  0x00007fbf37217b6f in poll () from /lib64/libc.so.6
#1  0x00007fbf3940d38a in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007fbf3940f71a in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007fbf2681ed58 in QXcbEventQueue::run (this=0x561d8a9095a0) at qxcbeventqueue.cpp:228
#4  0x00007fbf3759b846 in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:360
#5  0x00007fbf36aeb432 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fbf372229d3 in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fbf33935580 (LWP 9938)):
#0  0x00007fbf36af1e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbf375a1463 in QWaitConditionPrivate::wait (deadline=..., deadline=..., this=0x561d8d3bd220) at thread/qwaitcondition_unix.cpp:146
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x561d8d3ff4c0, deadline=...) at thread/qwaitcondition_unix.cpp:225
#3  0x00007fbf3902f822 in QSGThreadedRenderLoop::polishAndSync (this=0x561d8af7c040, w=0x561d8d3ffd20, inExpose=<optimized out>) at scenegraph/qsgthreadedrenderloop.cpp:1217
#4  0x00007fbf39093bd7 in QQuickWindow::event (this=0x561d8b3c7150, e=0x7ffdfab2e740) at items/qquickwindow.cpp:1676
#5  0x00007fbf38084e76 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x561d8b3c7150, e=0x7ffdfab2e740) at kernel/qapplication.cpp:3703
#6  0x00007fbf377278a0 in QCoreApplication::notifyInternal2 (receiver=0x561d8b3c7150, event=0x7ffdfab2e740) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:143
#7  0x00007fbf37ad0d54 in QPlatformWindow::windowEvent (this=<optimized out>, event=<optimized out>) at kernel/qplatformwindow.cpp:793
#8  0x00007fbf3808c15b in QApplication::notify (this=0x7ffdfab2ed30, receiver=0x561d8b3c7150, e=0x7ffdfab2e9b0) at kernel/qapplication.cpp:2909
#9  0x00007fbf377278a0 in QCoreApplication::notifyInternal2 (receiver=0x561d8b3c7150, event=0x7ffdfab2e9b0) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:143
#10 0x00007fbf37771f13 in QTimerInfoList::activateTimers (this=0x561d8a9b9c90) at kernel/qtimerinfo_unix.cpp:643
#11 0x00007fbf3777280c in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:183
#12 0x00007fbf35e9d7cf in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#13 0x00007fbf35e9db58 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#14 0x00007fbf35e9dc23 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#15 0x00007fbf37772c06 in QEventDispatcherGlib::processEvents (this=0x561d8a9bc0f0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#16 0x00007fbf3772621b in QEventLoop::exec (this=this@entry=0x7ffdfab2ebf0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#17 0x00007fbf3772ddf6 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#18 0x0000561d8a33cb81 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/plasma-workspace-5.18.4-1.fc32.x86_64/shell/main.cpp:228
[Inferior 1 (process 9938) detached]

Possible duplicates by query: bug 411883, bug 381245, bug 370718.

Reported using DrKonqi
Comment 1 Andrej Dundovic 2020-05-09 20:44:24 UTC
Created attachment 128312 [details]
New crash information added by DrKonqi

plasmashell (5.18.3) using Qt 5.13.2

This is related to bugreport #420808

-- Backtrace (Reduced):
#6  std::__atomic_base<int>::operator++ (this=0x7ff0545c50c8) at /usr/include/c++/10/bits/atomic_base.h:325
#7  QAtomicOps<int>::ref<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:265
[...]
#10 QString::QString (other=..., this=0x7ff01964acc8) at ../../include/QtCore/../../src/corelib/tools/qstring.h:956
#11 QFontEngineMulti::fallbackFamilyAt (at=<optimized out>, this=0x7ff01004bd80) at ../../include/QtGui/5.13.2/QtGui/private/../../../../../src/gui/text/qfontengine_p.h:495
#12 QFontEngineMulti::loadEngine (this=0x7ff01004bd80, at=<optimized out>) at text/qfontengine.cpp:1832
Comment 2 Marco Martin 2020-05-21 12:01:24 UTC
*** Bug 416068 has been marked as a duplicate of this bug. ***
Comment 3 Marco Martin 2020-05-21 12:01:33 UTC
*** Bug 421217 has been marked as a duplicate of this bug. ***
Comment 4 David Edmundson 2021-02-25 23:04:26 UTC

*** This bug has been marked as a duplicate of bug 424792 ***