Bug 416780

Summary: Akregator does not order items correctly by date.
Product: [Applications] akregator Reporter: stakanov.s
Component: metakit pluginAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: minor CC: montel, wbauer
Priority: NOR    
Version: 5.12.80   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Not working order by date akregator screenshot

Description stakanov.s 2020-01-26 09:51:42 UTC
Created attachment 125423 [details]
Not working order by date akregator screenshot

SUMMARY
Ordering items in akregator results in a somewhat random order. It seams that the function to order articles by date is broken. I joined a screen shot. Reverse order gives the same issue. Maybe this is database (akonadi) related? 
It is however a constant problem. 

STEPS TO REPRODUCE
1. order by date with new articles
2. new articles are not listed first in the row
3. A bunch of old articles are listed first, then the list is ordered correctly. 

OBSERVED RESULT
does not order by date. If you select a filter: show only new or unread then the respective function orders the new articles in the list correctly

EXPECTED RESULT
Ordered by date should be ordered by date (linear).

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.12.8
KDE Frameworks Version: 5.55.5
Qt Version: 5.9.7

ADDITIONAL INFORMATION
Opensuse (stock) 15.1, akonadi driven by mariadb (stock).

I select storage, but I am not sure if this is the right component. Please adjust in case.
Comment 1 Wolfgang Bauer 2020-01-26 12:29:02 UTC
Comment on attachment 125423 [details]
Not working order by date akregator screenshot

AFAICS, the order is correct in the screenshot.
The problem seems to be that some articles have a date/time of 07/02/06 07:28, which is actually 07-02-2106 and therefore newer than 26-01-2020.

See also bug#256034.
Comment 2 Wolfgang Bauer 2020-01-26 12:32:38 UTC
(In reply to Wolfgang Bauer from comment #1)
> The problem seems to be that some articles have a date/time of 07/02/06
> 07:28, which is actually 07-02-2106 and therefore newer than 26-01-2020.
PS: 07/02/06 07:28 corresponds to a timestamp of -1.
Comment 3 Christophe Giboudeaux 2020-01-26 13:09:53 UTC

*** This bug has been marked as a duplicate of bug 256034 ***