Bug 415110

Summary: Latte Dock crash on open
Product: kde Reporter: DarnedDev <mikesht10>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description DarnedDev 2019-12-12 21:44:43 UTC
Application: latte-dock (0.9.3)

Qt Version: 5.12.4
Frameworks Version: 5.62.0
Operating System: Linux 5.3.0-24-generic x86_64
Distribution: Ubuntu 19.10

-- Information about the crash:
- Unusual behavior I noticed:
The dock crashes immediately when trying to run, no GUI appears

The crash can be reproduced every time.

-- Backtrace:
Application: Latte Dock (latte-dock), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0bbb7c7c80 (LWP 20029))]

Thread 5 (Thread 0x7f0ba156a700 (LWP 20040)):
#0  0x00007f0bbe1a72c6 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55f6075c38d4) at ../sysdeps/unix/sysv/linux/futex-internal.h:80
#1  0x00007f0bbe1a72c6 in __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55f6075c3880, cond=0x55f6075c38a8) at pthread_cond_wait.c:508
#2  0x00007f0bbe1a72c6 in __pthread_cond_wait (cond=0x55f6075c38a8, mutex=0x55f6075c3880) at pthread_cond_wait.c:638
#3  0x00007f0bbf193def in QWaitCondition::wait(QMutex*, QDeadlineTimer) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f0bbf193ee1 in QWaitCondition::wait(QMutex*, unsigned long) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f0bc0e987b9 in  () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007f0bc0e98a1a in  () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f0bbf18dcc2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f0bbe1a0669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#9  0x00007f0bbeca9323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f0bb246e700 (LWP 20036)):
#0  0x00007f0bbec9cc2f in __GI___poll (fds=0x7f0ba80025e0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f0bbd7c3a3e in  () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0bbd7c3b73 in g_main_context_iteration () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0bbf3ac6c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f0bbf35363b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f0bbf18ca75 in QThread::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f0bc0b3d319 in  () at /lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f0bbf18dcc2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f0bbe1a0669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#9  0x00007f0bbeca9323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f0bb99e8700 (LWP 20031)):
#0  0x00007f0bbd80fc60 in g_mutex_unlock () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0bbd7c2fb1 in g_main_context_prepare () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0bbd7c396b in  () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0bbd7c3b73 in g_main_context_iteration () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0bbf3ac6c3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f0bbf35363b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f0bbf18ca75 in QThread::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f0bbf684efa in  () at /lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007f0bbf18dcc2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f0bbe1a0669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#10 0x00007f0bbeca9323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f0bba92f700 (LWP 20030)):
#0  0x00007f0bbec9cc2f in __GI___poll (fds=0x7f0bba92eca8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f0bc12a7917 in  () at /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f0bc12a953a in xcb_wait_for_event () at /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f0bbb112288 in  () at /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f0bbf18dcc2 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f0bbe1a0669 in start_thread (arg=<optimized out>) at pthread_create.c:479
#6  0x00007f0bbeca9323 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f0bbb7c7c80 (LWP 20029)):
[KCrash Handler]
#5  0x00007f0bbed091b0 in __strncmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp-sse42.S:199
#6  0x00007f0bbfdef9b3 in  () at /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#7  0x00007f0bbfdec42b in KSharedDataCache::find(QString const&, QByteArray*) const () at /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#8  0x00007f0bc123c154 in Plasma::Theme::findInCache(QString const&, QPixmap&, unsigned int) () at /lib/x86_64-linux-gnu/libKF5Plasma.so.5
#9  0x00007f0bc1236656 in  () at /lib/x86_64-linux-gnu/libKF5Plasma.so.5
#10 0x00007f0bc1236b59 in Plasma::Svg::image(QSize const&, QString const&) () at /lib/x86_64-linux-gnu/libKF5Plasma.so.5
#11 0x00007f0bb057555d in  () at /usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#12 0x00007f0bc0eeeecb in QQuickWindowPrivate::polishItems() () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f0bc0e96c27 in  () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f0bc0e97952 in  () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f0bc0ef9726 in QQuickWindow::event(QEvent*) () at /lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x000055f60527c79a in Latte::View::event(QEvent*) ()
#17 0x00007f0bc0045a86 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#18 0x00007f0bc004ee00 in QApplication::notify(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007f0bbf354a9a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f0bbf88bae4 in QPlatformWindow::windowEvent(QEvent*) () at /lib/x86_64-linux-gnu/libQt5Gui.so.5
#21 0x00007f0bc004eb7b in QApplication::notify(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#22 0x00007f0bbf354a9a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f0bbf3aba00 in QTimerInfoList::activateTimers() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f0bbf3ac324 in  () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007f0bbd7c384d in g_main_context_dispatch () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f0bbd7c3ad0 in  () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f0bbd7c3b73 in g_main_context_iteration () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f0bbf3ac6a5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f0bbf35363b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007f0bbf35b3a6 in QCoreApplication::exec() () at /lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x000055f6051ccb2e in main ()
[Inferior 1 (process 20029) detached]

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2020-01-01 17:10:05 UTC

*** This bug has been marked as a duplicate of bug 415109 ***