Bug 408468

Summary: [Wayland] Yakuake on Wayland appears under top panel at start
Product: [Applications] yakuake Reporter: Eugene <ken20001>
Component: generalAssignee: Eike Hein <hein>
Status: RESOLVED FIXED    
Severity: major CC: agurenko, andy_morris22, bugseforuns, butirsky, cybeatb, dabiswas112, gbassi, hsantanna, lukas, nate, postix, robby.engelmann, schwancarl, simon.westersund, trmdi
Priority: HI Keywords: usability
Version: Git (Frameworks 5)   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=386114
https://bugs.kde.org/show_bug.cgi?id=442605
https://bugs.kde.org/show_bug.cgi?id=378694
https://bugs.kde.org/show_bug.cgi?id=437139
Latest Commit: Version Fixed In: 21.12.1
Attachments: Yakuake expanded under Wayland with Kickoff panel located at the top of the screen
yakuake compiled with patch

Description Eugene 2019-06-09 01:18:26 UTC
SUMMARY

Yakuake should expand in foreground under Wayland but now it expands in a background, so the command line prompt is not visible because the kickoff panel overlaps it. Please, fix this annoying bug to be able you use yakuake under Wayland comfortably.


SOFTWARE/OS VERSIONS

Linux/KDE Plasma:
Kubuntu 19.04
Linux 5.0.0-16 x86_64
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.2
Comment 1 Eugene 2019-06-09 01:25:28 UTC
Created attachment 120709 [details]
Yakuake expanded under Wayland with Kickoff panel located at the top of the screen
Comment 2 Patrick Silva 2019-07-08 19:22:42 UTC
It seems related/duplicate to/of bug 386114
Comment 3 Eugene 2019-07-31 23:26:52 UTC

*** This bug has been marked as a duplicate of bug 386114 ***
Comment 4 Nate Graham 2019-08-01 22:47:46 UTC
This is not a duplicate. Either both are app-specific issues, or else both are actually duplicates of a not-yet-filed bug on the panel itself, if that's where the issue lies. Not knowing which of those is true, let's keep them both open for now.
Comment 5 Patrick Silva 2019-09-24 11:31:46 UTC
*** Bug 412221 has been marked as a duplicate of this bug. ***
Comment 6 Simon Westersund 2019-10-15 18:41:02 UTC
Since this bug is kept open too, I'll repeat my comment from the related bug 386114: https://bugs.kde.org/show_bug.cgi?id=386114#c21

This reproduces also with KDE Neon. Other versions:

Linux 5.0.0-31-generic x86_64
KDE Plasma Version: 5.17.0
KDE Frameworks Version: 5.63.0
Qt Version: 5.13.1
Comment 7 Patrick Silva 2019-10-30 17:01:40 UTC
*** Bug 413635 has been marked as a duplicate of this bug. ***
Comment 8 Patrick Silva 2019-11-29 13:27:16 UTC
*** Bug 414597 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2020-02-05 21:59:48 UTC
*** Bug 417119 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2020-02-28 17:58:23 UTC
Fixed with the fix for Bug 386114!

*** This bug has been marked as a duplicate of bug 386114 ***
Comment 11 trmdi 2020-02-28 18:24:18 UTC
(In reply to Nate Graham from comment #10)
> Fixed with the fix for Bug 386114!
> 
> *** This bug has been marked as a duplicate of bug 386114 ***

Maybe this need another patch. That one only fixed krunner.
Comment 12 Patrick Silva 2020-02-29 12:38:32 UTC
krunner issue is fixed on Neon unstable, but this issue persists.
Comment 13 trmdi 2020-02-29 13:34:18 UTC
(In reply to Patrick Silva from comment #12)
> krunner issue is fixed on Neon unstable, but this issue persists.

I sent a similar patch for yakuake: https://phabricator.kde.org/D27733
Comment 14 Nate Graham 2020-06-10 15:41:50 UTC
Just fixed with https://invent.kde.org/utilities/yakuake/-/merge_requests/10
Comment 15 Eugene 2020-10-03 15:31:41 UTC
It is not fixed fully as it should be. First appearing of Yakuake is still occurs behind taskbar and only from second call of Yakuake it appears correctly.
Similar report: https://bugs.kde.org/show_bug.cgi?id=426542
Comment 16 Nate Graham 2020-10-04 02:17:43 UTC
What versions of Yakuake and Plasma are you using?
Comment 17 Eugene 2020-10-04 21:55:42 UTC
(In reply to Nate Graham from comment #16)
> What versions of Yakuake and Plasma are you using?

Hello, Nate.

Yakuake: 20.08.1
Plasma KDE: 5.19.5
Frameworks KDE: 5.74.0
QT: 5.14.2
Linux: 5.8.0-20-generic
Kubuntu 20.10 (development branch)
Comment 18 Nate Graham 2020-10-05 16:52:30 UTC
*** Bug 426542 has been marked as a duplicate of this bug. ***
Comment 19 Nate Graham 2020-10-05 16:58:06 UTC
Darn. I wonder if this requires Plasma 5.20 stuff. Can you test with that, if possible?
Comment 20 Eugene 2020-10-05 20:31:07 UTC
(In reply to Nate Graham from comment #19)
> Darn. I wonder if this requires Plasma 5.20 stuff. Can you test with that,
> if possible?

It's a pity but there is no packages of Plasma 5.20 for Kubuntu 20.10, so I am not able to test with that.
Comment 21 Eugene 2021-05-21 19:08:22 UTC
yakuake 21.04.1
First start it appears in background - under kickoff panel. Double push F12 brings it foreground. So second start looks normal.
Comment 22 Henrique Sant'Anna 2021-08-20 21:53:08 UTC
With a top Latte panel Yakuake appears right next to the top panel. Works good.
Comment 23 Robby Engelmann 2021-09-09 13:42:28 UTC
Same here, double F12 brings it to top. First start hidden by the top panel.

Operating System: openSUSE Tumbleweed 20210907
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.0-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-10510U CPU @ 1.80GHz
Memory: 31.0 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics
Comment 24 Eugene 2021-09-11 22:39:10 UTC
On 21.08.1 bug is still present.
Comment 25 Gurenko Alex 2021-09-22 10:46:12 UTC
 Same issue still exists on latest 5.22.5 plasma and 21.08.1 on Manjaro on Pinebook Pro, similar issue but yakuake opens in the middle of the screen on Intel UHD and RX6700 on Fedora 34/35.
Comment 26 Andrey 2021-09-22 12:27:23 UTC
Can it be duplicate of bug 442605?
Comment 27 Andrey 2021-09-22 12:28:38 UTC
(In reply to Andrey from comment #26)
> Can it be duplicate of bug 442605?

Sorry, I meant bug 378694
Comment 28 Gurenko Alex 2021-09-22 13:00:14 UTC
(In reply to Andrey from comment #27)
> (In reply to Andrey from comment #26)
> > Can it be duplicate of bug 442605?
> 
> Sorry, I meant bug 378694

I would assume if that would be the case then it would be already fixed now, but it's still there.
Comment 29 Andrey 2021-09-22 13:07:18 UTC
Oh, wrong bug again.
This one: bug 437139.
Fixed in 5.22.90
Comment 30 Andrey 2021-09-22 14:30:23 UTC
(In reply to Andrey from comment #29)
> This one: bug 437139.

It might be related but still see the first time run issue described with the fix applied.
Comment 31 Eugene 2021-09-22 19:42:48 UTC
It is not fixed still. So, please, do not mislead anyone.
Comment 32 Bug Janitor Service 2021-09-30 08:14:51 UTC
A possibly relevant merge request was started @ https://invent.kde.org/utilities/yakuake/-/merge_requests/49
Comment 33 Dipta Biswas 2021-10-13 04:03:13 UTC
Reproduced using Yakuake 21.08.2-1 on EndeavourOS (Arch based). So it's definitely not fixed.
Operating System: EndeavourOS
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.11-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 2 × AMD E2-9000e RADEON R2, 4 COMPUTE CORES 2C+2G
Memory: 3.3 GiB of RAM
Graphics Processor: AMD STONEY
Comment 34 Eugene 2021-12-20 19:07:23 UTC
Interesting thing: under X Yakuake window first time appears above the kickoff panel overlapping it.
Comment 35 trmdi 2021-12-21 01:18:39 UTC
Can anyone who heavily uses Yakuake test the patch in the comment 32?
Comment 36 Robby Engelmann 2021-12-21 23:09:38 UTC
I am using Yakuake, but do not know, how to test it...
Comment 37 Eugene 2021-12-22 01:12:55 UTC
(In reply to trmdi from comment #35)
> Can anyone who heavily uses Yakuake test the patch in the comment 32?

Recently I tried to compile yakuake with that additional string in patch and it weems it works well.
Comment 38 Eugene 2021-12-22 01:14:49 UTC
Created attachment 144772 [details]
yakuake compiled with patch
Comment 39 Eugene 2021-12-22 01:16:47 UTC
Anyone can test it now fron attachment. Now how can we pull it in main codebase? I don't understand all thouse programming rules.
Comment 40 Janet Blackquill 2021-12-22 17:43:18 UTC
Git commit d18320fd3f153315d5020b29f241bfd0711863f4 by Janet Blackquill, on behalf of Tranter Madi.
Committed on 22/12/2021 at 17:36.
Pushed by cblack into branch 'master'.

Make sure position is always set in wayland

M  +1    -0    app/mainwindow.cpp

https://invent.kde.org/utilities/yakuake/commit/d18320fd3f153315d5020b29f241bfd0711863f4
Comment 41 Robby Engelmann 2021-12-22 21:11:44 UTC
the compiled with patch version worked here too
Comment 42 Eugene 2021-12-22 23:42:44 UTC
At last!
Comment 43 Nate Graham 2021-12-24 00:28:43 UTC
Git commit c92e358784cfc76126d16b0b26d33ddc106ffd92 by Nate Graham, on behalf of Tranter Madi.
Committed on 24/12/2021 at 00:28.
Pushed by ngraham into branch 'cherry-pick-d18320fd'.

Make sure position is always set in wayland


(cherry picked from commit d18320fd3f153315d5020b29f241bfd0711863f4)

M  +1    -0    app/mainwindow.cpp

https://invent.kde.org/utilities/yakuake/commit/c92e358784cfc76126d16b0b26d33ddc106ffd92
Comment 44 cybeatb 2024-04-13 23:46:11 UTC
I'm still experiencing this bug. I've tried to work around it by setting a window rule, but I have to open up the "window rules" settings to force-reapply the rule every time I hide & reopen the window.

1.) Open Yakuake; the window is obscured by the top panel.
2.) Open "Window Rules" settings, and re-apply the rule; the window moves below the panel.
3.) Hide/close the Yakuake window, then unhide/reopen it; the window is obscured by the top panel again.
4.) Repeat.

Operating System: Fedora Linux 39 (Kinoite)
KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12
Kernel Version: 6.8.5-201.fc39.x86_64 (64-bit)
Graphics Platform: Wayland
Yakuake Version: 24.02.2 (Flatpak)