Bug 397704

Summary: KIOExec: A folder named .cache/kioexec/krun/<number>_0/ already exists.
Product: [Frameworks and Libraries] frameworks-kio Reporter: ederag <edera>
Component: generalAssignee: David Faure <faure>
Severity: normal CC: kdelibs-bugs, nate, pbotloh
Priority: NOR    
Version: 5.45.0   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=369122
Latest Commit: Version Fixed In:

Description ederag 2018-08-21 13:00:31 UTC
This looks like bug #369122, except it occurs for any link,
in kmail, or even a simple url shortcut on the desktop.
This is probably a duplicate of bug #393673,
but easier to find since here the error is in english.

rm -r ~/.cache
does not solve anything, even after a logout.

With a new user, it works.
So something is wrong in my configuration.
But it would be better to diagnose the issue.

inspired by https://bugs.kde.org/show_bug.cgi?id=343329#c4:
/usr/lib64/libexec/kf5/kioexec cat ftp://ftp.gnu.org/README
command= "cat" args= ("cat", "ftp://ftp.gnu.org/README")
Copying QUrl("ftp://ftp.gnu.org/README")  to QUrl("file:///home/ederag/.cache/kioexec/krun/23201_0/README")
<fine README content>

So this is perhaps not a kioexec issue ?

This does not seem related to firefox either, since
/usr/lib64/libexec/kf5/kioexec firefox ftp://ftp.gnu.org/README
opens the README in firefox.
Comment 1 Nate Graham 2018-08-21 21:08:41 UTC
*** Bug 393673 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2018-08-21 21:09:03 UTC
In what apps do you experience this? Everything?
Comment 3 ederag 2018-08-21 23:26:46 UTC
Tested in kmail, dolphin, and a link on the desktop.
Also happens after selecting some text in okular,
and right click>search for ... in duckduckgo.
Comment 4 ederag 2018-08-22 12:19:10 UTC
Another clue: the behavior depends on the  link:
for links like

firefox opens with file:///home/ederag/.cache/kioexec/krun/16436_0/Home
in the url bar.
For https://bitbucket.org/me_ydv_5/octave/wiki
it opens with file:///home/ederag/.cache/kioexec/krun/16471_0/wiki
For https://bitbucket.org/me_ydv_5/octave/wiki/  (mind the ending slash),
error KIOExec: 
"A folder named /home/ederag/.cache/kioexec/krun/16497_0/ already exists."

System Settings>Default applications>Web Browser>open http and https:
changing the existing command: 
firefox "%u"
solved it.

This is definitely not a KIO bug.
Closing as resolved, moved to opensuse
Comment 5 ederag 2018-08-28 12:27:10 UTC
> firefox "%u" solved it.

Not quite: urls are opened twice.
firefox opens a new window, with two tabs holding the same urls.
Removing the "%u" (i.e. back to the previous buggy state),
the urls open normally, just once, in an already existing window.
looks like a [2009 thread](https://forum.kde.org/viewtopic.php?t=39446).
Comment 6 Nate Graham 2018-11-05 21:42:43 UTC
Fixed in Frameworks 5.51 with the fix for 397742.

*** This bug has been marked as a duplicate of bug 397742 ***