Bug 393957

Summary: Horizontal layout option for horizontal panels
Product: [Plasma] plasmashell Reporter: Ivar Erikson <kiwimisc>
Component: Digital ClockAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: wishlist CC: abrouwers, dev-kde, kde, momo.cao, nate, psychonaut
Priority: NOR Keywords: triaged
Version: master   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In: 5.22
Sentry Crash Report:
Attachments: Horizontal-only with really really short panel
Double-line clock with standard-height panel
Screenshot showing digital clock settings

Description Ivar Erikson 2018-05-07 14:22:26 UTC
The Digital Clock widget isn't possible to set to horizontal viewing of [date + time]. Only a vertically stacked view is given, which makes for poor viewing in hortizontal panels.

Current view, just to spell it out if I'm unclear with "vertically stacked":
[13:54]
[26.11.2018]

Instead of e.g. [26.11.2018 13:54]

This was previously available (KDE4?), or at least something which had the same effect. Likely in relation to the previously available formatting options for the panel clock.
Comment 1 David Edmundson 2018-06-20 15:36:43 UTC
>Only a vertically stacked view is given

That's not entirely true. It switches based on available height.

Please can you add a screenshot of your panel.
Comment 2 Nate Graham 2018-06-20 16:20:26 UTC
Created attachment 113469 [details]
Horizontal-only with really really short panel

Can confirm;  in 5.13, when I make my panel really really short, it uses a purely horizontal view.
Comment 3 Nate Graham 2018-06-20 16:20:57 UTC
Created attachment 113470 [details]
Double-line clock with standard-height panel
Comment 4 Nate Graham 2018-06-20 16:24:39 UTC
So I'm not sure what we should do with this. The requested view is already available on-demand for very short horizontal panels, but can't be optionally used when the panel is taller.

Seems like we should WORKSFORME/WONTFIX the bug, or else add an option like so:

Date display: (o) On the same line
              ( ) Depends on panel height

...Or something like that. Your call.
Comment 5 Ivar Erikson 2018-06-20 19:12:29 UTC
True, and I too can confirm that the clock will go single-line if you use a sufficiently narrow panel, but imo that's really not a good solution. In my case (and likely other's) it's either "have a legible clock/date" or "have a legible panel".

Imho, the clock's lack of formatting is one of the few shortcoming of the default Plasma desktop.

If "inspiration" is needed, have a look at Event Calendar widget (https://store.kde.org/p/998901/)
Comment 6 Andrew Crouthamel 2018-09-28 03:11:22 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Nate Graham 2018-09-28 19:36:08 UTC
Info was previously added.
Comment 8 momo 2020-09-21 07:33:13 UTC
*** Bug 426723 has been marked as a duplicate of this bug. ***
Comment 9 momo 2020-09-21 07:39:32 UTC
I would really love if this was implemented. I think it would be a matter of letting the user toggle the already-existing one-line mode manually.
Comment 10 Nate Graham 2021-02-03 17:40:01 UTC
*** Bug 432472 has been marked as a duplicate of this bug. ***
Comment 11 Frank Steinmetzger 2021-02-18 10:33:44 UTC
*** Bug 422532 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2021-03-26 04:57:10 UTC
Git commit cd68df165a9360e6c0f94b7f7c0c7ebb04df370a by Nate Graham, on behalf of Momo Cao.
Committed on 26/03/2021 at 04:56.
Pushed by ngraham into branch 'master'.

Add a setting to show date and time in one line
FIXED-IN: 5.22

M  +8    -0    applets/digital-clock/package/contents/config/main.xml
M  +7    -13   applets/digital-clock/package/contents/ui/DigitalClock.qml
M  +20   -4    applets/digital-clock/package/contents/ui/configAppearance.qml

https://invent.kde.org/plasma/plasma-workspace/commit/cd68df165a9360e6c0f94b7f7c0c7ebb04df370a
Comment 13 Tristan Miller 2023-01-04 12:37:47 UTC
(In reply to Nate Graham from comment #12)
> Git commit cd68df165a9360e6c0f94b7f7c0c7ebb04df370a by Nate Graham, on
> behalf of Momo Cao.
> Committed on 26/03/2021 at 04:56.
> Pushed by ngraham into branch 'master'.
> 
> Add a setting to show date and time in one line
> FIXED-IN: 5.22
> 
> M  +8    -0    applets/digital-clock/package/contents/config/main.xml
> M  +7    -13   applets/digital-clock/package/contents/ui/DigitalClock.qml
> M  +20   -4    applets/digital-clock/package/contents/ui/configAppearance.qml
> 
> https://invent.kde.org/plasma/plasma-workspace/commit/
> cd68df165a9360e6c0f94b7f7c0c7ebb04df370a

Did this fix ever make it into a stable release?  I'm running Plasma 5.26.4.1 on openSUSE Tumbleweed.  The Digital Clock applet shows a version of 3.0 in the "About" section of the settings.  I see no setting to have the time and date beside vs. on top of one another.
Comment 14 Nate Graham 2023-01-04 13:32:15 UTC
It's the first thing in the settings window:

Information: [x] Show date [adaptive location]
Comment 15 Tristan Miller 2023-01-04 13:49:51 UTC
Created attachment 155024 [details]
Screenshot showing digital clock settings

(In reply to Nate Graham from comment #14)
> It's the first thing in the settings window:
> 
> Information: [x] Show date [adaptive location]

Not on my system -- see the attached screenshot.  Am I missing something here?
Comment 16 Nate Graham 2023-01-04 13:51:33 UTC
Is the clock located on a horizontal panel or a vertical panel?
Comment 17 Tristan Miller 2023-01-04 19:20:46 UTC
(In reply to Nate Graham from comment #16)
> Is the clock located on a horizontal panel or a vertical panel?

It's on a vertical panel, as can be seen in the screenshot.  I want the date and time to appear beside to each other so as to save vertical space.
Comment 18 Nate Graham 2023-01-04 19:28:33 UTC
Well that's the problem. :) This option is only present on horizontal panels, because generally vertical panels are too narrow to be able to show the time and date on the same line without the text becoming unreadably small. I gather you have an extremely wide panel such that everything might actually fit?
Comment 19 Tristan Miller 2023-01-04 20:03:23 UTC
(In reply to Nate Graham from comment #18)
> Well that's the problem. :) This option is only present on horizontal
> panels, because generally vertical panels are too narrow to be able to show
> the time and date on the same line without the text becoming unreadably
> small. I gather you have an extremely wide panel such that everything might
> actually fit?

Yes, I've got a wide monitor and a correspondingly wide panel.  I wouldn't call it "extremely" wide, but it's certainly wide enough to fit an ISO date and time on one line.
Comment 20 Nate Graham 2023-01-04 20:28:53 UTC
Feel free to file a bug report asking for the feature to be active for vertical panels as well.