Bug 391007

Summary: User Switcher only works on second try
Product: [Plasma] plasmashell Reporter: Fabian Vogt <fabian>
Component: generalAssignee: David Edmundson <kde>
Severity: normal CC: nate, plasma-bugs
Priority: NOR Flags: fabian: X11+
Version: master   
Target Milestone: 1.0   
Platform: openSUSE   
OS: Linux   
URL: https://phabricator.kde.org/D10802
Latest Commit: Version Fixed In: 5.12.3

Description Fabian Vogt 2018-02-24 15:19:59 UTC
ksmserver-switchuser-greeter only reacts on the second click to "Switch".

xorg-session.log contains "lock called" followed by "could not establish screen lock" when it does not work, but only "lock called" when it does work.

This points to the greeter not ungrabbing mouse/keyboard properly before starting the screenlocker.
Comment 1 Fabian Vogt 2018-02-25 20:24:05 UTC
Git commit 1eb9ae7e33e2b0cb14ab10bc81710fa4b8f19ef5 by Fabian Vogt.
Committed on 25/02/2018 at 20:23.
Pushed by fvogt into branch 'Plasma/5.12'.

Fix the userswitcher when using the mouse for switching

Clicking on a button makes Qt grab the pointer, which means the screen can't be
locked. As we wait for the screen to be locked before switching, this never

Test Plan:
Previously the userswitcher only worked on every second try, now it works
always on the first click.

Reviewers: #plasma, broulik

Reviewed By: #plasma, broulik

Subscribers: ngraham, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D10802

M  +2    -0    ksmserver/switchuserdialog.cpp