Bug 385947

Summary: First task's initial tooltip size is broken
Product: plasmashell Reporter: Алексей Шилин <rootlexx>
Component: Task Manager and Icons-Only Task ManagerAssignee: Eike Hein <hein>
Status: RESOLVED FIXED    
Severity: normal CC: bugseforuns, nate, plasma-bugs
Priority: NOR    
Version: 5.11.1   
Target Milestone: 1.0   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Screenshot which illustrates the issue

Description Алексей Шилин 2017-10-19 14:04:30 UTC
Created attachment 108454 [details]
Screenshot which illustrates the issue

Hi,

Initial tooltip size for the first task in the task manager is broken (see the attached screenshot).

Steps to reproduce the issue:

 1. Do a fresh login into Plasma desktop.

 2. Open a few windows *without touching the task manager* i.e. from the main menu or the desktop.

 3. Hover the mouse over the first task in the task manager.

The issue persists until one hovers the mouse over any task other than the first one.

I've also noticed that the incorrect tooltip size corresponds to the overall number of tasks in the task manager, so the bug is probably somewhere in the TasksModel in the org.kde.taskmanager module, which erroneously returns all tasks instead of the selected group's ones; given that it stops doing so after one hovers a different task, the bug is probably caused by an uninialized variable somewhere. It's just a wild guess though.
Comment 1 Nate Graham 2017-12-13 20:24:19 UTC

*** This bug has been marked as a duplicate of bug 382571 ***
Comment 2 Eike Hein 2018-06-19 11:23:19 UTC
Git commit 24803dc9dc4000e06edb60a3a8afe5925f0d72d7 by Eike Hein.
Committed on 19/06/2018 at 11:22.
Pushed by hein into branch 'Plasma/5.12'.

Fix tooltip woes

Summary:
Users have reported a number of bugs against TM tooltips, e.g. initially
coming up with crazy sizes, or showing window duplicates. This all comes
down to a race conditions causing stale data and ugly code that's using
visible props to swap between two alternate UI implementations instead
of doing clean conditional loading.

With this cleanup patch the problems should be gone, as well as various
ReferenceErrors spewed onto the tty.
Related: bug 382571, bug 389469, bug 388749

Reviewers: broulik, davidedmundson, romangg

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D13602

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +27   -11   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/24803dc9dc4000e06edb60a3a8afe5925f0d72d7
Comment 3 Patrick Silva 2018-06-19 15:00:12 UTC
*** Bug 391227 has been marked as a duplicate of this bug. ***
Comment 4 David Edmundson 2018-06-20 07:26:02 UTC
Git commit 1ab6ae9a8a36068294c487896dd512c693332b08 by David Edmundson.
Committed on 20/06/2018 at 07:16.
Pushed by davidedmundson into branch 'Plasma/5.12'.

Revert "Fix tooltip woes"

This reverts commit 24803dc9dc4000e06edb60a3a8afe5925f0d72d7.

Even though this commit is perfectly sensible it seems to introduce a
crash on startup for Qt 5.10.

Will revert for now, we can revisit later
Related: bug 382571, bug 389469, bug 388749

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +11   -27   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/1ab6ae9a8a36068294c487896dd512c693332b08
Comment 5 Eike Hein 2018-06-22 21:06:46 UTC
Git commit 1e218b405bee4d75a5d26a4c28da2724d967953a by Eike Hein.
Committed on 22/06/2018 at 21:05.
Pushed by hein into branch 'Plasma/5.12'.

Fix tooltip woes

Summary:
Users have reported a number of bugs against TM tooltips, e.g. initially
coming up with crazy sizes, or showing window duplicates. This all comes
down to a race conditions causing stale data and ugly code that's using
visible props to swap between two alternate UI implementations instead
of doing clean conditional loading.

With this cleanup patch the problems should be gone, as well as various
ReferenceErrors spewed onto the tty.
Related: bug 382571, bug 389469, bug 388749

Reviewers: broulik, davidedmundson, romangg

Reviewed By: davidedmundson

Subscribers: rikmills, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D13602

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +33   -18   applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +1    -1    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://commits.kde.org/plasma-desktop/1e218b405bee4d75a5d26a4c28da2724d967953a