Bug 380114

Summary: crash on exit in ~NotifyByAudio()
Product: [Frameworks and Libraries] frameworks-knotifications Reporter: RJVB <rjvbertin>
Component: generalAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED FIXED    
Severity: crash CC: alejandrohp, antoine.viallon, antonioni.rocha, ants.karner, bufalo1973, bugseforuns, christoph, chuck.eastus, dap.darkness, dennis.schridde, derkweijers, elvis.angelaccio, eugenstep27, gplm+kde, houstonjohnr, j.mairboeck, jcarricksmith, juampa2345, kde, kdelibs-bugs, lambdasoftware, liferer, mike, nasus.maximos, nick.haflinger, opensuse.lietuviu.kalba, parajulidarshan2, piotr.mierzwinski, rdieter, reinhardauner, s.foschi, simonandric5, stakanov.s, stefanolessismc, stephan.peichl, thesirdmz, umvmac, vikigoyal, wbarker, Wolfgang.Reh, xavier.besnard, zwo
Priority: NOR Keywords: drkonqi
Version: 5.32.0   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In: 5.47
Sentry Crash Report:

Description RJVB 2017-05-23 09:48:15 UTC
Application: rkward (0.6.9z+0.7.0+devel1)
 (Compiled from sources)
Qt Version: 5.8.0
Frameworks Version: 5.32.0
Operating System: Linux 4.9.8-ck1-mainline-core2-rjvb x86_64
Distribution: Ubuntu 14.04.5 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I had started rkward/kf5 and then quit it (its R backed currently fails for me, a priori for unrelated reasons).

This may be related to ticket #348414

-- Backtrace:
Application: RKWard (rkward), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fabd98ec780 (LWP 31728))]

Thread 2 (Thread 0x7fabb69b0700 (LWP 31730)):
#0  0x00007ffc1a755b6b in ?? ()
#1  0x00007fabb0007ed0 in ?? ()
#2  0x00000000d1bf6700 in ?? ()
#3  0x00007fabb0002ed0 in ?? ()
#4  0x00007fabb0002ed0 in ?? ()
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fabd98ec780 (LWP 31728)):
[KCrash Handler]
#6  0x00000000028c3780 in ?? ()
#7  0x00007fabbd75a4f6 in qDeleteAll<QList<Phonon::MediaObject*>::const_iterator> (end=..., begin=...) at /opt/local/include/qt5/QtCore/qalgorithms.h:320
#8  qDeleteAll<QList<Phonon::MediaObject*> > (c=...) at /opt/local/include/qt5/QtCore/qalgorithms.h:328
#9  NotifyByAudio::~NotifyByAudio (this=0x24ee390, __in_chrg=<optimized out>) at /opt/local/var/lnxports/build/_opt_local_site-ports_kf5_KF5-Frameworks/kf5-knotifications/work/knotifications-5.32.0/src/notifybyaudio.cpp:47
#10 0x00007fabbd75a589 in NotifyByAudio::~NotifyByAudio (this=0x24ee390, __in_chrg=<optimized out>) at /opt/local/var/lnxports/build/_opt_local_site-ports_kf5_KF5-Frameworks/kf5-knotifications/work/knotifications-5.32.0/src/notifybyaudio.cpp:49
#11 0x00007fabd1bcccb1 in QObjectPrivate::deleteChildren (this=this@entry=0x24da050) at /opt/local/var/lnxports/build/_opt_local_site-ports_aqua_qt5-kde-devel/qt5-kde-devel/work/qt-everywhere-opensource-src-5.8.0/qtbase/src/corelib/kernel/qobject.cpp:1970
#12 0x00007fabd1bd692f in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at /opt/local/var/lnxports/build/_opt_local_site-ports_aqua_qt5-kde-devel/qt5-kde-devel/work/qt-everywhere-opensource-src-5.8.0/qtbase/src/corelib/kernel/qobject.cpp:1041
#13 0x00007fabbd72dcf9 in ~KNotificationManagerSingleton (this=<optimized out>, __in_chrg=<optimized out>) at /opt/local/var/lnxports/build/_opt_local_site-ports_kf5_KF5-Frameworks/kf5-knotifications/work/knotifications-5.32.0/src/knotificationmanager.cpp:61
#14 (anonymous namespace)::Q_QGS_s_self::Holder::~Holder (this=<optimized out>, __in_chrg=<optimized out>) at /opt/local/var/lnxports/build/_opt_local_site-ports_kf5_KF5-Frameworks/kf5-knotifications/work/knotifications-5.32.0/src/knotificationmanager.cpp:67
#15 0x00007fabbd72dcf9 in operator() (this=<optimized out>) from /opt/local/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#16 KNotificationManager::self () at /opt/local/var/lnxports/build/_opt_local_site-ports_kf5_KF5-Frameworks/kf5-knotifications/work/knotifications-5.32.0/src/knotificationmanager.cpp:71
#17 0x00007fabd0f6e1a9 in __run_exit_handlers (status=0, listp=0x7fabd12f36c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#18 0x00007fabd0f6e1f5 in __GI_exit (status=<optimized out>) at exit.c:104
#19 0x00007fabd0f53f4c in __libc_start_main (main=0x4caa50 <main(int, char**)>, argc=3, argv=0x7ffc1a6bea28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc1a6bea18) at libc-start.c:321
#20 0x00000000004cdadd in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2017-05-29 23:12:55 UTC
*** Bug 379786 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2017-05-29 23:14:12 UTC
*** Bug 377278 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2017-05-29 23:14:41 UTC
*** Bug 370311 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2017-05-29 23:15:05 UTC
*** Bug 373882 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2017-05-29 23:15:35 UTC
*** Bug 346621 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2017-05-29 23:15:58 UTC
*** Bug 366482 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2017-06-02 18:01:01 UTC
*** Bug 379724 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2017-06-02 18:02:03 UTC
*** Bug 378920 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Cullmann 2017-06-25 12:22:37 UTC
*** Bug 381371 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Cullmann 2017-06-25 12:31:30 UTC
IMHO double delete, will fix that.
Comment 11 Christoph Cullmann 2017-06-25 12:35:46 UTC
Posted patch:

https://phabricator.kde.org/D6376

Thanks for the report, ugly :/
Comment 12 Christoph Feck 2017-06-27 13:52:37 UTC
*** Bug 381228 has been marked as a duplicate of this bug. ***
Comment 13 Elvis Angelaccio 2017-07-06 09:32:03 UTC
*** Bug 381962 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2017-07-18 04:01:18 UTC
*** Bug 382387 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2017-08-13 11:42:44 UTC
*** Bug 383449 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2017-08-21 15:27:19 UTC
*** Bug 383777 has been marked as a duplicate of this bug. ***
Comment 17 Elvis Angelaccio 2017-08-26 08:43:14 UTC
*** Bug 384017 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Feck 2017-08-29 11:13:11 UTC
*** Bug 384124 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Feck 2017-09-04 15:27:19 UTC
*** Bug 383347 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2017-11-09 00:28:11 UTC
*** Bug 386195 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2017-11-09 00:51:37 UTC
*** Bug 386559 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2017-11-29 19:00:17 UTC
*** Bug 386770 has been marked as a duplicate of this bug. ***
Comment 23 Christoph Feck 2017-11-29 19:00:40 UTC
*** Bug 386184 has been marked as a duplicate of this bug. ***
Comment 24 Christoph Feck 2017-11-29 19:00:59 UTC
*** Bug 386022 has been marked as a duplicate of this bug. ***
Comment 25 Elvis Angelaccio 2017-12-16 12:48:55 UTC
*** Bug 387954 has been marked as a duplicate of this bug. ***
Comment 26 Christoph Feck 2017-12-20 00:50:55 UTC
*** Bug 387237 has been marked as a duplicate of this bug. ***
Comment 27 Christoph Feck 2017-12-31 13:46:17 UTC
*** Bug 387752 has been marked as a duplicate of this bug. ***
Comment 28 Christoph Feck 2018-01-02 00:44:19 UTC
*** Bug 387780 has been marked as a duplicate of this bug. ***
Comment 29 Christoph Feck 2018-01-10 17:02:53 UTC
*** Bug 388052 has been marked as a duplicate of this bug. ***
Comment 30 Christoph Feck 2018-01-31 02:09:23 UTC
*** Bug 388958 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Feck 2018-03-14 00:19:06 UTC
*** Bug 391833 has been marked as a duplicate of this bug. ***
Comment 32 Albert Astals Cid 2018-05-14 17:46:42 UTC
Git commit 59bfcffc43d298d5b123337aa2ae13dbe8dc79d6 by Albert Astals Cid.
Committed on 14/05/2018 at 17:46.
Pushed by aacid into branch 'master'.

Fix crashes in NotifyByAudio when closing applications

Summary:
We have a race between close() and onAudioFinished() that resulted in the same
Phonon::MediaObject being added twice to m_reusablePhonons, which would result in a crash

Reviewers: #frameworks, cullmann, rjvbb, apol

Reviewed By: apol

Subscribers: cfeck, rjvbb, mpyne

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D11891

M  +9    -0    src/notifybyaudio.cpp

https://commits.kde.org/knotifications/59bfcffc43d298d5b123337aa2ae13dbe8dc79d6
Comment 33 Christoph Feck 2018-05-16 22:21:03 UTC
*** Bug 393587 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2018-06-15 00:07:36 UTC
*** Bug 394718 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2018-06-20 19:04:39 UTC
*** Bug 395663 has been marked as a duplicate of this bug. ***
Comment 36 Christoph Feck 2018-07-19 12:46:10 UTC
*** Bug 395999 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Feck 2018-08-02 18:47:48 UTC
*** Bug 396545 has been marked as a duplicate of this bug. ***
Comment 38 Christoph Feck 2018-11-01 22:06:09 UTC
*** Bug 400426 has been marked as a duplicate of this bug. ***
Comment 39 Elvis Angelaccio 2019-06-02 08:32:16 UTC
*** Bug 408185 has been marked as a duplicate of this bug. ***
Comment 40 Christoph Feck 2019-10-24 08:21:41 UTC
*** Bug 393772 has been marked as a duplicate of this bug. ***