Bug 373969

Summary: Delete action does not work with keyboard shortcut
Product: [Applications] kmail2 Reporter: Samuel Gilbert <samuel.gilbert>
Component: message listAssignee: kdepim bugs <kdepim-bugs>
Status: NEEDSINFO WAITINGFORINFO    
Severity: normal CC: arpad.kunszt, marc-schmitzer
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Samuel Gilbert 2016-12-20 18:24:10 UTC
The delete message action no longer works with the SHIFT-DEL keyboard shortcut.  Setting the shortcut to something else (I tested with SHIFT-P) or adding an delete icon in the toolbar does work.

This is in Version 5.4.0 Using :
KDE Frameworks 5.29.0
Qt 5.7.1 (built against 5.7.1)
The xcb windowing system


Expected behaviour :

When viewing the message list, pressing SHIFT-DEL should delete the selected messages.


Current behaviour :

In the message list, when one or more messages are selected pressing SHIFT-DEL does nothing.
Comment 1 Marc Schmitzer 2017-01-15 14:39:45 UTC
I think I'm experiencing the same issue. Specifically, changing the selection in the message list sets focus to the message preview pane. There, Shift-Del does not work (but e.g. Del alone for "move to trash" works). On the message list itself, Shift+Del does work (if you manage to get focus there).

I don't know which of the two (focus change or no shift+del on preview pane) is new, but it's quite aggravating in combination.

Version: kmail-16.08.3 on Fedora 25
Comment 2 Kunszt Arpad 2017-08-21 06:37:15 UTC
I also suffer from this bug. I can delete only once after the KMail started but then nothing happens. If I change the shortcut to something else I can delete once more again but then it doesn't work again.

It's also working when I select the message again, so it could be a focus issue.

It's very annoying as I used to use Shift+Del since KMail 1.x era.

Currently I'm using KMail 5.5.3.
Comment 3 Justin Zobel 2022-11-08 06:50:08 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 4 Kunszt Arpad 2022-11-08 08:24:22 UTC
It is working for me in KMail 5.20.3 (22.04.3).
Comment 5 Bug Janitor Service 2022-11-23 05:14:19 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!