Bug 365358

Summary: Dolphin crashed after UI freeze after trying to send an email via Kmail
Product: dolphin Reporter: Gijsbertus <gijsbert>
Component: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: elvis.angelaccio, joelsymon
Priority: NOR Keywords: drkonqi
Version: 15.12.3   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Gijsbertus 2016-07-11 14:14:24 UTC
Application: dolphin (15.12.3)

Qt Version: 5.5.1
Frameworks Version: 5.23.0
Operating System: Linux 4.4.0-28-generic x86_64
Distribution: Ubuntu 16.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: Just finished the spell check for a mail to be sent and had hid the send button (or at least I think I did, could not check because the whole UI froze)

- Unusual behavior I noticed: UI freeze

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff630c778c0 (LWP 14305))]

Thread 3 (Thread 0x7ff624249700 (LWP 14395)):
#0  0x00007ff643acde8d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007ff63a29739c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff63a2974ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff63e8b7a9b in QEventDispatcherGlib::processEvents (this=0x7ff61c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007ff63e85edea in QEventLoop::exec (this=this@entry=0x7ff624248d00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ff63e67b8a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ff63e68084e in QThreadPrivate::start (arg=0x1e45b90) at thread/qthread_unix.cpp:331
#7  0x00007ff63ae226fa in start_thread (arg=0x7ff624249700) at pthread_create.c:333
#8  0x00007ff643ad9b5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7ff62e3db700 (LWP 14306)):
#0  0x00007ff643acde8d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007ff63822ec62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007ff6382308d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007ff63072d629 in QXcbEventReader::run (this=0x18e1800) at qxcbconnection.cpp:1253
#4  0x00007ff63e68084e in QThreadPrivate::start (arg=0x18e1800) at thread/qthread_unix.cpp:331
#5  0x00007ff63ae226fa in start_thread (arg=0x7ff62e3db700) at pthread_create.c:333
#6  0x00007ff643ad9b5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7ff630c778c0 (LWP 14305)):
[KCrash Handler]
#6  0x00007ff63ae2d960 in _xend () at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:33
#7  __lll_unlock_elision (lock=0x7ff62c6f0008, private=128) at ../sysdeps/unix/sysv/linux/x86/elision-unlock.c:29
#8  0x00007ff63fdcb47a in KSharedDataCache::insert(QString const&, QByteArray const&) () from /usr/lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#9  0x00007ff64112b588 in ?? () from /usr/lib/x86_64-linux-gnu/libKF5IconThemes.so.5
#10 0x00007ff64112cbe9 in KIconLoader::loadIcon(QString const&, KIconLoader::Group, int, int, QStringList const&, QString*, bool) const () from /usr/lib/x86_64-linux-gnu/libKF5IconThemes.so.5
#11 0x00007ff641121d1f in KIconEngine::pixmap(QSize const&, QIcon::Mode, QIcon::State) () from /usr/lib/x86_64-linux-gnu/libKF5IconThemes.so.5
#12 0x00007ff63ee354f0 in QIcon::pixmap (this=0x7ffeede4a2d0, window=window@entry=0x0, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:842
#13 0x00007ff63ee3563e in QIcon::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at image/qicon.cpp:775
#14 0x00007ff643751194 in KStandardItemListWidget::pixmapForIcon(QString const&, QStringList const&, int) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#15 0x00007ff643751ef9 in KStandardItemListWidget::updatePixmapCache() () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#16 0x00007ff643752c52 in KStandardItemListWidget::triggerCacheRefreshing() () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#17 0x00007ff643752e45 in KStandardItemListWidget::paint(QPainter*, QStyleOptionGraphicsItem const*, QWidget*) () from /usr/lib/x86_64-linux-gnu/libdolphinprivate.so.5
#18 0x00007ff63f6834e5 in _q_paintItem (item=item@entry=0x2461c90, painter=painter@entry=0x7ffeede4b280, option=option@entry=0x24862f8, widget=widget@entry=0x243b330, useWindowOpacity=useWindowOpacity@entry=true, painterStateProtection=<optimized out>) at graphicsview/qgraphicsscene.cpp:4286
#19 0x00007ff63f6943f2 in QGraphicsScenePrivate::drawItemHelper (this=this@entry=0x24860e0, item=item@entry=0x2461c90, painter=painter@entry=0x7ffeede4b280, option=option@entry=0x24862f8, widget=widget@entry=0x243b330, painterStateProtection=<optimized out>) at graphicsview/qgraphicsscene.cpp:4382
#20 0x00007ff63f6969c4 in QGraphicsScenePrivate::draw (this=this@entry=0x24860e0, item=item@entry=0x2461c90, painter=painter@entry=0x7ffeede4b280, viewTransform=viewTransform@entry=0x0, transformPtr=transformPtr@entry=0x2461f90, exposedRegion=<optimized out>, widget=0x243b330, opacity=opacity@entry=1, effectTransform=0x0, wasDirtyParentSceneTransform=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4938
#21 0x00007ff63f697928 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x24860e0, item=0x2461c90, painter=painter@entry=0x7ffeede4b280, viewTransform=viewTransform@entry=0x0, exposedRegion=exposedRegion@entry=0x25f7730, widget=widget@entry=0x243b330, parentOpacity=parentOpacity@entry=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4829
#22 0x00007ff63f69668a in QGraphicsScenePrivate::draw (this=this@entry=0x24860e0, item=item@entry=0x25f3bb0, painter=painter@entry=0x7ffeede4b280, viewTransform=viewTransform@entry=0x0, transformPtr=transformPtr@entry=0x2468360, exposedRegion=<optimized out>, widget=0x243b330, opacity=opacity@entry=1, effectTransform=0x0, wasDirtyParentSceneTransform=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4891
#23 0x00007ff63f697928 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x24860e0, item=0x25f3bb0, painter=painter@entry=0x7ffeede4b280, viewTransform=viewTransform@entry=0x0, exposedRegion=exposedRegion@entry=0x25f7730, widget=widget@entry=0x243b330, parentOpacity=parentOpacity@entry=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4829
#24 0x00007ff63f697e8a in QGraphicsScenePrivate::drawItems (this=0x24860e0, painter=painter@entry=0x7ffeede4b280, viewTransform=viewTransform@entry=0x0, exposedRegion=exposedRegion@entry=0x25f7730, widget=0x243b330) at graphicsview/qgraphicsscene.cpp:4690
#25 0x00007ff63f6b9327 in QGraphicsView::paintEvent (this=0x2612a50, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3539
#26 0x00007ff63f3a8f88 in QWidget::event (this=this@entry=0x2612a50, event=event@entry=0x7ffeede4b810) at kernel/qwidget.cpp:9044
#27 0x00007ff63f4a7b5e in QFrame::event (this=0x2612a50, e=0x7ffeede4b810) at widgets/qframe.cpp:540
#28 0x00007ff63f6b7eb3 in QGraphicsView::viewportEvent (this=0x2612a50, event=0x7ffeede4b810) at graphicsview/qgraphicsview.cpp:2962
#29 0x00007ff63e861412 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=this@entry=0x18c63e0, receiver=receiver@entry=0x243b330, event=event@entry=0x7ffeede4b810) at kernel/qcoreapplication.cpp:1072
#30 0x00007ff63f36603c in QApplicationPrivate::notify_helper (this=this@entry=0x18c63e0, receiver=receiver@entry=0x243b330, e=e@entry=0x7ffeede4b810) at kernel/qapplication.cpp:3712
#31 0x00007ff63f36b516 in QApplication::notify (this=0x7ffeede4d480, receiver=0x243b330, e=0x7ffeede4b810) at kernel/qapplication.cpp:3499
#32 0x00007ff63e86162b in QCoreApplication::notifyInternal (this=0x7ffeede4d480, receiver=receiver@entry=0x243b330, event=event@entry=0x7ffeede4b810) at kernel/qcoreapplication.cpp:965
#33 0x00007ff63f3a1a79 in QCoreApplication::sendSpontaneousEvent (event=0x7ffeede4b810, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:227
#34 QWidgetPrivate::sendPaintEvent (this=this@entry=0x25f4080, toBePainted=...) at kernel/qwidget.cpp:5625
#35 0x00007ff63f3a20c1 in QWidgetPrivate::drawWidget (this=this@entry=0x25f4080, pdev=pdev@entry=0x243c0b0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5565
#36 0x00007ff63f3a2d6c in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x25f7260, pdev=pdev@entry=0x243c0b0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5760
#37 0x00007ff63f3a1c31 in QWidgetPrivate::drawWidget (this=this@entry=0x25f7260, pdev=pdev@entry=0x243c0b0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5617
#38 0x00007ff63f3a2d6c in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x20924e0, pdev=pdev@entry=0x243c0b0, siblings=..., index=<optimized out>, index@entry=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5760
#39 0x00007ff63f3a2c59 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x20924e0, pdev=pdev@entry=0x243c0b0, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5747
#40 0x00007ff63f3a1c31 in QWidgetPrivate::drawWidget (this=this@entry=0x20924e0, pdev=pdev@entry=0x243c0b0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5617
#41 0x00007ff63f3a2d6c in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x1aabd40, pdev=pdev@entry=0x243c0b0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5760
#42 0x00007ff63f3a1c31 in QWidgetPrivate::drawWidget (this=this@entry=0x1aabd40, pdev=pdev@entry=0x243c0b0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5617
#43 0x00007ff63f3a2d6c in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x19e69f0, pdev=pdev@entry=0x243c0b0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5760
#44 0x00007ff63f3a1c31 in QWidgetPrivate::drawWidget (this=this@entry=0x19e69f0, pdev=pdev@entry=0x243c0b0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5617
#45 0x00007ff63f3a2d6c in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x19adb80, pdev=pdev@entry=0x243c0b0, siblings=..., index=<optimized out>, index@entry=16, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5760
#46 0x00007ff63f3a2c59 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x19adb80, pdev=pdev@entry=0x243c0b0, siblings=..., index=16, index@entry=26, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5747
#47 0x00007ff63f3a2c59 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x19adb80, pdev=pdev@entry=0x243c0b0, siblings=..., index=26, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5747
#48 0x00007ff63f3a1c31 in QWidgetPrivate::drawWidget (this=0x19adb80, pdev=0x243c0b0, rgn=..., offset=..., flags=flags@entry=5, sharedPainter=sharedPainter@entry=0x0, backingStore=0x1c5f430) at kernel/qwidget.cpp:5617
#49 0x00007ff63f3738aa in QWidgetBackingStore::doSync (this=this@entry=0x1c5f430) at kernel/qwidgetbackingstore.cpp:1226
#50 0x00007ff63f3740a2 in QWidgetBackingStore::sync (this=0x1c5f430, exposedWidget=0x198c8d0, exposedRegion=...) at kernel/qwidgetbackingstore.cpp:954
#51 0x00007ff63f3c5a43 in QWidgetWindow::event (this=0x1ae84e0, event=0x7ffeede4d090) at kernel/qwidgetwindow.cpp:255
#52 0x00007ff63f36605c in QApplicationPrivate::notify_helper (this=this@entry=0x18c63e0, receiver=receiver@entry=0x1ae84e0, e=e@entry=0x7ffeede4d090) at kernel/qapplication.cpp:3716
#53 0x00007ff63f36b516 in QApplication::notify (this=0x7ffeede4d480, receiver=0x1ae84e0, e=0x7ffeede4d090) at kernel/qapplication.cpp:3499
#54 0x00007ff63e86162b in QCoreApplication::notifyInternal (this=0x7ffeede4d480, receiver=receiver@entry=0x1ae84e0, event=event@entry=0x7ffeede4d090) at kernel/qcoreapplication.cpp:965
#55 0x00007ff63edb64ec in QCoreApplication::sendSpontaneousEvent (event=0x7ffeede4d090, receiver=0x1ae84e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:227
#56 QGuiApplicationPrivate::processExposeEvent (e=0x18f8630) at kernel/qguiapplication.cpp:2663
#57 0x00007ff63edb725d in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x18f8630) at kernel/qguiapplication.cpp:1658
#58 0x00007ff63ed9af38 in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:625
#59 0x00007ff63075f070 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#60 0x00007ff63a2971a7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007ff63a297400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#62 0x00007ff63a2974ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007ff63e8b7a7f in QEventDispatcherGlib::processEvents (this=0x1921020, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#64 0x00007ff63e85edea in QEventLoop::exec (this=this@entry=0x7ffeede4d350, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#65 0x00007ff63e866e8c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#66 0x00007ff643df9e2b in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#67 0x00007ff6439f3830 in __libc_start_main (main=0x400710 <main>, argc=3, argv=0x7ffeede4d608, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffeede4d5f8) at ../csu/libc-start.c:291
#68 0x0000000000400749 in _start ()

Possible duplicates by query: bug 334674, bug 334640.

Reported using DrKonqi
Comment 1 Joel Koreth 2016-12-03 05:44:33 UTC
I can't reproduce this on my end.

Enviroment info-
 Version 16.08.3
 KDE Frameworks 5.28.0
 Qt 5.7.0 (built against 5.7.0)
 Distro : openSUSE Tumbleweed 20161128 Snapshot

A UI freeze may indicate a more widespread problem in your system (especially with 2 unrelated products), is this constantly reproducible for you?
Comment 2 Joel Koreth 2016-12-04 06:23:23 UTC
Duplicate of https://bugs.kde.org/show_bug.cgi?id=334640
Comment 3 Elvis Angelaccio 2016-12-24 16:02:31 UTC

*** This bug has been marked as a duplicate of bug 334640 ***