Bug 362961

Summary: In "Switch Application Language..." do not reset items to default values if already reset
Product: krita Reporter: mvowada <freebox64>
Component: UsabilityAssignee: Krita Bugs <krita-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: halla
Priority: NOR    
Version: 2.9   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Video example.
Video example with Krita version 2.9.6.

Description mvowada 2016-05-11 22:10:21 UTC
(Krita 3.0 Beta 1 on Ubuntu Unity 14.04).
The "Application Language Changed" dialog pops up even if the item values are, in fact, already reset (please, see video below).

Reproducible: Always

Steps to Reproduce:
1. Start Krita
2. (menu) > "Switch Application Language..."
3. click "Defaults"
4. once again, go to (menu) > "Switch Application Language..."
5. click "Defaults"

Actual Results:  
The "Application Language Changed" dialog pops up.

Expected Results:  
Nothing.

(Bug 362489 seems somewhat related)
Comment 1 mvowada 2016-05-11 22:11:27 UTC
Created attachment 98923 [details]
Video example.
Comment 2 Halla Rempt 2016-05-14 10:39:53 UTC
Hm, I cannot reproduce that, but I guess that's because my system language is US English. What is yours?
Comment 3 Halla Rempt 2016-05-14 10:41:01 UTC
Aw, I can see that from the vid, sorry.
Comment 4 Halla Rempt 2016-05-14 10:42:36 UTC
I think it's the same in 2.9, actually -- but we forked the code so it's now our bug.
Comment 5 mvowada 2016-05-14 13:23:24 UTC
Created attachment 98959 [details]
Video example with Krita version 2.9.6.

Hi Boudewijn, thanks. It's fine with an old Krita Version: 2.9.6 (git edd766e) (see video).
Comment 6 mvowada 2016-05-19 08:39:14 UTC
Double checked with Krita Version 3.0 RC1.
It seems that the issue is solved, as far as it concerns "American English". But there's still a problem with other languages.

Steps to Reproduce:
1. Switch to Italian language
2. Restart Krita
3. (menu) > "Switch Application Language..."
4. click "Defaults"

Actual Results:
The "Application Language Changed" dialog pops up.

Expected Results:
Nothing.
Comment 7 Halla Rempt 2019-05-03 09:23:31 UTC
Git commit d17c20d2e48bae14ebc718c84c286eb16524dc30 by Boudewijn Rempt.
Committed on 03/05/2019 at 09:22.
Pushed by rempt into branch 'master'.

Do not show the language switch warning when going back to the default

M  +0    -16   libs/widgetutils/xmlgui/kswitchlanguagedialog_p.cpp

https://invent.kde.org/kde/krita/commit/d17c20d2e48bae14ebc718c84c286eb16524dc30