Bug 357991

Summary: Unable to rotate video negative amount when not using standard locale for numbers
Product: kdenlive Reporter: Rune <post>
Component: User InterfaceAssignee: Jean-Baptiste Mardelle <jb>
Status: RESOLVED FIXED    
Severity: normal CC: fritzibaby, maxime.haselbauer, sundman, wegwerf-1-2-3
Priority: NOR Flags: fritzibaby: Brainstorm+
fritzibaby: low_hanging+
Version: 16.08.0   
Target Milestone: ---   
Platform: Kubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 20.08.0
Attachments: Rotate (keyframable)_negative
Negative rotate does NOT work

Description Rune 2016-01-14 18:19:36 UTC
I had the Norsk Bokmål, nb_no, locale for regional settings. When entering negative amount for rotation video did not rotate when I entered, e.g. -900.

When changing regional settings for numbers to C, standard, the video rotated anti-clockwise 90 degrees when entering -900; as expected

Reproducible: Always
Comment 1 Jean-Baptiste Mardelle 2016-01-14 23:14:11 UTC
Hi,

Thanks for your report. I cannot reproduce, can you tell us which Kdenlive version you are using and which video effect you are using to rotate (a screenshot of the effect parameters might help)
Comment 2 Wegwerf 2016-08-02 10:43:45 UTC
Rune, can you please test if this bug is still present or has been fixed as part of other locale-related bug fixes in the recent stable 16.04 or recent beta 16.07.xx? How are you doing the rotation, using an effect or a transition? Which one?

If the bug has been fixed I would like to ask you to be so kind as to close this bug as resolved. Thank you very much for your cooperation!
Comment 3 Rune 2016-08-24 07:03:10 UTC
I've now tested with version 16.08.00 and Kubuntu 16.04: Still doesn't work. I use "Rotate [Keyframeable]" and enter -900 for rotate X: It does not rotate. I enter 900 and it rotates as expected.

My locale is set to nb_NO.UTF8
Comment 4 Wegwerf 2016-09-01 19:00:55 UTC
Can you please run the "locale" command in a terminal and report back its output?
Comment 5 Wegwerf 2016-09-01 19:03:28 UTC
Jean-Baptiste, I can reproduce this now, by temporarily switching the locale in a terminal session as follows:
$export LANGUAGE=nb_NO.UTF-8
$export LANG=nb_NO.UTF-8
$export LC_NUMERIC=nb_NO.UTF-8
Comment 6 Marcus Sundman 2017-06-24 06:35:34 UTC
I have the same bug with sv_FI.UTF-8 and the new kdenlive. This was driving me absolutely nuts!
Comment 7 emohr 2018-10-12 18:22:52 UTC
Please try with the actual Kdenlive version 18.08.2
Comment 8 Marcus Sundman 2018-10-14 10:12:08 UTC
Yes, this problem still exists in 18.08.2. Adding the "Rotate (keyframable)" effect and entering a positive rotation works, but a negative rotation does not work.
Comment 9 emohr 2018-10-14 10:47:05 UTC
Created attachment 115635 [details]
Rotate (keyframable)_negative

Tested on Kdenlive Windows 18.08.2 -> it works even with negative value (rotate forewards and backwards).
If not done, download the AppImage of 18.08.02
Run the Appimage from the terminal (press CTRL + ALT + T). Move to the AppImage folder and run the .AppImage: ./Kdenlive*.AppImage
Comment 10 Marcus Sundman 2018-10-14 10:54:28 UTC
Created attachment 115636 [details]
Negative rotate does NOT work

Negative rotation does not work (unless I set LC_NUMERIC to C). This issue most likely won't affect windows, since I think it doesn't have any LC_NUMERIC environment variable at all.
Comment 11 emohr 2018-10-14 12:01:57 UTC
*** Bug 397780 has been marked as a duplicate of this bug. ***
Comment 12 emohr 2019-08-25 12:20:41 UTC
added in issue: https://invent.kde.org/kde/kdenlive/issues/78
Comment 13 emohr 2020-07-14 17:54:59 UTC
Comma point issue is fixed with version 20.08.0.