Bug 356835

Summary: System settings crash after changing style to Oxygen
Product: [Applications] systemsettings Reporter: opensuse.lietuviu.kalba
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 5.5.1   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description opensuse.lietuviu.kalba 2015-12-17 15:00:55 UTC
Application: systemsettings5 (5.5.1)

Qt Version: 5.5.0
Operating System: Linux 4.1.13-5-default x86_64
Distribution (Platform): openSUSE RPMs

-- Information about the crash:
- What I was doing when the application crashed:

System settings crash after changing style to Oxygen. But before that I did various other changes in appearence in System settings

-- Backtrace:
Application: Sistemos nustatymai (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb917873780 (LWP 3367))]

Thread 5 (Thread 0x7fb8ea910700 (LWP 3472)):
#0  0x00007fb90f5f11c5 in g_source_iter_next (iter=iter@entry=0x7fb8ea90fdd0, source=source@entry=0x7fb8ea90fdc8) at gmain.c:894
#1  0x00007fb90f5f383f in g_main_context_check (context=context@entry=0x3c00750, max_priority=2147483647, fds=fds@entry=0x7fb8e40010c0, n_fds=n_fds@entry=1) at gmain.c:3629
#2  0x00007fb90f5f3df8 in g_main_context_iterate (context=0x3c00750, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3805
#3  0x00007fb90f5f419a in g_main_loop_run (loop=0x3c006e0) at gmain.c:4002
#4  0x00007fb8eb44c426 in gdbus_shared_thread_func (user_data=0x3c00720) at gdbusprivate.c:274
#5  0x00007fb90f618f65 in g_thread_proxy (data=0x3c01c50) at gthread.c:764
#6  0x00007fb90fb100a4 in start_thread () from /lib64/libpthread.so.0
#7  0x00007fb9135b504d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fb8e95ff700 (LWP 3769)):
#0  g_mutex_unlock (mutex=0x7fb8dc000990) at gthread-posix.c:1348
#1  0x00007fb90f5f3d1d in g_main_context_iterate (context=context@entry=0x7fb8dc000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3756
#2  0x00007fb90f5f3f7c in g_main_context_iteration (context=0x7fb8dc000990, may_block=1) at gmain.c:3869
#3  0x00007fb913ed4a5b in QEventDispatcherGlib::processEvents (this=0x7fb8dc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#4  0x00007fb913e7ba63 in QEventLoop::exec (this=this@entry=0x7fb8e95fee30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fb913c9e84a in QThread::exec (this=this@entry=0x3d087a0) at thread/qthread.cpp:503
#6  0x00007fb9122295f8 in QQmlThreadPrivate::run (this=0x3d087a0) at /usr/src/debug/qtdeclarative-opensource-src-5.5.0/src/qml/qml/ftw/qqmlthread.cpp:141
#7  0x00007fb913ca355f in QThreadPrivate::start (arg=0x3d087a0) at thread/qthread_unix.cpp:331
#8  0x00007fb90fb100a4 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fb9135b504d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fb8e0f77700 (LWP 3787)):
#0  g_wakeup_acknowledge (wakeup=0x7fb8dc002780) at gwakeup.c:211
#1  0x00007fb90f5f3999 in g_main_context_check (context=context@entry=0x7fb8d8000990, max_priority=2147483647, fds=fds@entry=0x7fb8d8003270, n_fds=n_fds@entry=1) at gmain.c:3600
#2  0x00007fb90f5f3df8 in g_main_context_iterate (context=context@entry=0x7fb8d8000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3805
#3  0x00007fb90f5f3f7c in g_main_context_iteration (context=0x7fb8d8000990, may_block=1) at gmain.c:3869
#4  0x00007fb913ed4a5b in QEventDispatcherGlib::processEvents (this=0x7fb8d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0x00007fb913e7ba63 in QEventLoop::exec (this=this@entry=0x7fb8e0f76e30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fb913c9e84a in QThread::exec (this=this@entry=0x4fc3c80) at thread/qthread.cpp:503
#7  0x00007fb9122295f8 in QQmlThreadPrivate::run (this=0x4fc3c80) at /usr/src/debug/qtdeclarative-opensource-src-5.5.0/src/qml/qml/ftw/qqmlthread.cpp:141
#8  0x00007fb913ca355f in QThreadPrivate::start (arg=0x4fc3c80) at thread/qthread_unix.cpp:331
#9  0x00007fb90fb100a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fb9135b504d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fb8d77ff700 (LWP 3796)):
#0  0x00007fb9135acc1d in poll () from /lib64/libc.so.6
#1  0x00007fb90f5f3e64 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7fb8d0002c70, timeout=-1, context=0x7fb8d0000990) at gmain.c:4103
#2  g_main_context_iterate (context=context@entry=0x7fb8d0000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3803
#3  0x00007fb90f5f3f7c in g_main_context_iteration (context=0x7fb8d0000990, may_block=1) at gmain.c:3869
#4  0x00007fb913ed4a5b in QEventDispatcherGlib::processEvents (this=0x7fb8d00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0x00007fb913e7ba63 in QEventLoop::exec (this=this@entry=0x7fb8d77fee30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fb913c9e84a in QThread::exec (this=this@entry=0x4e54810) at thread/qthread.cpp:503
#7  0x00007fb9122295f8 in QQmlThreadPrivate::run (this=0x4e54810) at /usr/src/debug/qtdeclarative-opensource-src-5.5.0/src/qml/qml/ftw/qqmlthread.cpp:141
#8  0x00007fb913ca355f in QThreadPrivate::start (arg=0x4e54810) at thread/qthread_unix.cpp:331
#9  0x00007fb90fb100a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fb9135b504d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fb917873780 (LWP 3367)):
[KCrash Handler]
#6  0x0000000000000030 in ?? ()
#7  0x00007fb913eb001b in QObject::disconnect (sender=0xb234a0, signal=0xd9cc29 "destroyed()", signal@entry=0x7fb8ef0efc72 "2destroyed()", receiver=receiver@entry=0xe16ff0, method=0xdd9559 "slotManagedTopLevelWidgetDestroyed()", method@entry=0x7fb8ef0f0af0 "1slotManagedTopLevelWidgetDestroyed()") at kernel/qobject.cpp:2937
#8  0x00007fb8ef0d5485 in KParts::PartManager::~PartManager (this=0xe16ff0, __in_chrg=<optimized out>) at /usr/src/debug/kparts-5.17.0/src/partmanager.cpp:136
#9  0x00007fb8ef0d5629 in KParts::PartManager::~PartManager (this=0xe16ff0, __in_chrg=<optimized out>) at /usr/src/debug/kparts-5.17.0/src/partmanager.cpp:146
#10 0x00007fb913eac31c in QObjectPrivate::deleteChildren (this=this@entry=0xd835f0) at kernel/qobject.cpp:1951
#11 0x00007fb913eb5f6c in QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1031
#12 0x00007fb8ef8154a6 in KHTMLPart::~KHTMLPart (this=this@entry=0xd837b0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/khtml-5.17.0/src/khtml_part.cpp:559
#13 0x00007fb8ef815659 in KHTMLPart::~KHTMLPart (this=0xd837b0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/khtml-5.17.0/src/khtml_part.cpp:607
#14 0x00007fb913eae7e8 in QObject::event (this=0xd837b0, e=<optimized out>) at kernel/qobject.cpp:1237
#15 0x00007fb9159bfe8c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#16 0x00007fb9159c4cd8 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#17 0x00007fb913e7dba5 in QCoreApplication::notifyInternal (this=0x7ffedc95b7b0, receiver=0xd837b0, event=event@entry=0xe4ab00) at kernel/qcoreapplication.cpp:965
#18 0x00007fb913e7fd67 in sendEvent (event=0xe4ab00, receiver=<optimized out>) at kernel/qcoreapplication.h:224
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x8f0010) at kernel/qcoreapplication.cpp:1593
#20 0x00007fb913e80318 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1451
#21 0x00007fb913ed55c3 in postEventSourceDispatch (s=0x943ff0) at kernel/qeventdispatcher_glib.cpp:271
#22 0x00007fb90f5f3c84 in g_main_dispatch (context=0x7fb9000016f0) at gmain.c:3122
#23 g_main_context_dispatch (context=context@entry=0x7fb9000016f0) at gmain.c:3737
#24 0x00007fb90f5f3ed8 in g_main_context_iterate (context=context@entry=0x7fb9000016f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3808
#25 0x00007fb90f5f3f7c in g_main_context_iteration (context=0x7fb9000016f0, may_block=1) at gmain.c:3869
#26 0x00007fb913ed4a3c in QEventDispatcherGlib::processEvents (this=0x941b40, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#27 0x00007fb913e7ba63 in QEventLoop::exec (this=this@entry=0x7ffedc95b680, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#28 0x00007fb913e835d6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#29 0x00000000004109af in main (argc=1, argv=<optimized out>) at /usr/src/debug/systemsettings-5.5.1/app/main.cpp:55

Possible duplicates by query: bug 356771, bug 356487, bug 356465, bug 356364, bug 355915.

Reported using DrKonqi
Comment 1 Christoph Feck 2016-01-24 13:21:28 UTC

*** This bug has been marked as a duplicate of bug 355711 ***