Bug 356283

Summary: Any message contents that shows in the message preview bottom pane shows <<< Grantlee theme "" is not valid >>> prefixed to the actual msg body
Product: [Applications] kmail2 Reporter: smihaila <smihaila>
Component: message listAssignee: kdepim bugs <kdepim-bugs>
Status: NEEDSINFO WAITINGFORINFO    
Severity: major CC: kdenis, montel, olaf.the.lost.viking, xavier.corredor.llano
Priority: NOR    
Version: 5.2.2   
Target Milestone: ---   
Platform: Kubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description smihaila 2015-12-04 16:15:01 UTC
For any message that is currently selected in the message view pane, the message preview/reader pane will always show this text affixed BEFORE the actual message body:

Grantlee theme "" is not valid

The same thing happens whenever I double click on the message to open the composer in "E-mail Forward" mode.

When I hit reply/reply all though, the odd Grantlee theme bogus text does NOT show up.

Please advise smihaila@gmail.com when this is fixed - it's unbearable and it makes me downgrade back to what i was having before - K/Ubuntu 10.x WAS P-E-R-F-E-C-T.

Reproducible: Always
Comment 1 Laurent Montel 2015-12-04 16:52:24 UTC
Version ?
Change your theme in view -> headers
Comment 2 smihaila 2015-12-05 02:04:43 UTC
I thought I've provided the version info in the bug ticket.  I'm not in front of PC right now, but it was the kmail2 that came with KUbuntu x86_64 15.10 (upgraded from 14.x).

I've tried switching between those 3 themes (Classic, Smart, Smart with click) but to no avail. The odd and annoying message shows up in any of those themes.

Thanks for following up.
Comment 3 Laurent Montel 2015-12-05 15:38:28 UTC
ok but which is kmail version ?
I don't know kubuntu :)
So kmail -> help -> about kmail
Comment 4 smihaila 2015-12-07 16:19:10 UTC
Sorry for the late reply. Now I understand why I wasn't able to provide the kmail2 version info itself - it's because the bug ticket's version drop-down has 4.14.7 as highest version for product = kmail2.

The KDE Mail version I'm using is 5.0.2

Thank you.
Comment 5 smihaila 2015-12-09 15:44:45 UTC
I think have a better understanding on what's causing that.
After going to Main Menu->View->Headers->Download New Themes... and making sure to download the "Modern Headers" (by Tovok7), the issue disappeared.

It's good that I have remembered the Header theme which I was using in the former KUbuntu 14.10.

Hope this is helpful. Could someone take a look into the code which retrieves the KDE Mail user settings and tries to unconditionally apply them even if runtime conditions are not met (i.e. the specific Header theme not actually being available)?

Thank you.
Comment 6 OlafLostViking 2016-07-11 16:12:24 UTC
Using KMail 5.2.2 within Kontact.

Switching from an additionally installed theme to a default one is not saved by KMail. The formerly selected one is preferred on every start. After uninstalling this additional theme, the error message of the OP is shown and even now persistently selecting a default theme is not possible.

But it seems that switching the theme in a stand-alone KMail, the settings are saved and after that even the embedded KMail within Kontact seems to use the correct theme.
Comment 7 Xavier Corredor Llano 2016-08-31 19:01:41 UTC
Maybe is a different bug, but I can confirm that Kmail inside Kontact suite not saved the theme. 

Steps: 
1. Open kontact and go to kmail
2. Change your theme in view -> headers
3. Restart Kontact, 

Result: The theme switched not saved

Only work if open Kmail without Kontact

Kontact/kmail version: 5.3.0
Comment 8 Justin Zobel 2022-11-04 03:10:12 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 9 Bug Janitor Service 2022-11-19 05:13:16 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!