Bug 349313

Summary: Wikipedia redirects not handled correctly when SSL is disabled for the widget
Product: amarok Reporter: danteshanketsu
Component: Context View/WikipediaAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED FIXED    
Severity: normal CC: b3nmore, freddie_chopin, get.sonic, gisela_soenke_jensen, joseph.oconnor.lincoln, mfraz74+kde, olivier, rdieter, stemy
Priority: NOR Keywords: release_blocker
Version: 2.8.0   
Target Milestone: 2.9   
Platform: Debian stable   
OS: Linux   
Latest Commit: Version Fixed In: 2.9
Attachments: attachment-20586-0.html

Description danteshanketsu 2015-06-17 23:43:59 UTC
The Wikipedia tab shows nothing when playing a song. Lyrics are shown.
Don't know if it helps, but files are located on a remote folder mounted on NFS (Synology NAS).

Reproducible: Always
Comment 1 Myriam Schweingruber 2015-06-18 09:54:14 UTC
Well, not all tracks/artist/albums have a wikipedia entry. The location of the track is rather irrelevant, what matters is that the ID3 tags are set correctly.
Can you please check whether you find at least an artist entry in wikipedia? You might have set the wikipedia applet to only show track information, that is usually insufficient but for very well known songs.

FWIW: I see no problems with the wikipedia applet in current git, to be released in a day or two as Amarok 2.8.90 aka 2.9 beta
Comment 2 danteshanketsu 2015-06-18 16:07:39 UTC
Created attachment 93225 [details]
attachment-20586-0.html

Hello,

Tags are correctly defined, applet is configured to show artist, and the
entry exists on Wikipedia (The artist is Black Sabbath).

Thanks a lot,

Regards

2015-06-18 11:54 GMT+02:00 Myriam Schweingruber <myriam@kde.org>:

> https://bugs.kde.org/show_bug.cgi?id=349313
>
> Myriam Schweingruber <myriam@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>          Resolution|---                         |WORKSFORME
>              Status|UNCONFIRMED                 |NEEDSINFO
>
> --- Comment #1 from Myriam Schweingruber <myriam@kde.org> ---
> Well, not all tracks/artist/albums have a wikipedia entry. The location of
> the
> track is rather irrelevant, what matters is that the ID3 tags are set
> correctly.
> Can you please check whether you find at least an artist entry in
> wikipedia?
> You might have set the wikipedia applet to only show track information,
> that is
> usually insufficient but for very well known songs.
>
> FWIW: I see no problems with the wikipedia applet in current git, to be
> released in a day or two as Amarok 2.8.90 aka 2.9 beta
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 3 Sönke Jensen 2015-06-18 18:19:28 UTC
I'm affected too with the same effect: "In Amarok 2.8 wikipedia page no content when playing a song" since some days, using multiple systems Kubuntu 12.04, 14.04, 15.04 and addition Xubuntu 14.04, on all systems same: No content in Amarok 2.8 wikipedia applet. - worked before a couple of days wo problems.
Comment 4 Myriam Schweingruber 2015-06-18 18:41:55 UTC
Funny, it does work quite fine here on current git...
Please check with amarok 2.9 beta which will be released in a few hours.
Comment 5 Mark Fraser 2015-06-27 15:49:14 UTC
Stopped working here too on Kubuntu 14.10 with Amarok 2.8 and KDE 4.14.2.
Comment 6 Syam 2015-06-28 13:19:15 UTC
I too have the same problem with Amarok 2.8.0 (Fedora 22, x86_64)

When started from a terminal as "amarok --debug", clicking on the 'Artist' button on the Wikipedia applet produces this in the terminal (the track is from Eminem):

amarok: BEGIN: void WikipediaEnginePrivate::_dataContainerUpdated(const QString&, const Data&) 
amarok:   [WikipediaEngine] goto: "artist" 
amarok:   [WikipediaEngine] Fetching langlinks: KUrl("http://en.wikipedia.org/w/api.php?action=query&prop=langlinks&titles=Eminem&format=xml&lllimit=100&redirects=1") 
amarok: END__: void WikipediaEnginePrivate::_dataContainerUpdated(const QString&, const Data&) [Took: 0s] 
amarok: BEGIN: void WikipediaApplet::dataUpdated(const QString&, const Data&) 
amarok: END__: void WikipediaApplet::dataUpdated(const QString&, const Data&) [Took: 0s] 
amarok: [NetworkAccessManagerProxy] the server is redirecting the request to:  KUrl("https://en.wikipedia.org/w/api.php?action=query&prop=langlinks&titles=Eminem&format=xml&lllimit=100&redirects=1")
Comment 7 Myriam Schweingruber 2015-06-28 13:58:37 UTC
What you all have in common is that you updated something, while Amarok 2.8 hasn't seen any updates recently. You really should check what you changed in your updates, something must have been removed or modified causing this.

In particular, please check your internet connection, firewall settings and package dependencies.

FWIW: I use Amarok from current git master on Kubuntu 14.10, KDE release 4.14.2, updates and backports PPA activated, and I have no such problem.
Comment 8 Syam 2015-06-28 14:48:24 UTC
(In reply to Myriam Schweingruber from comment #7)
> What you all have in common is that you updated something, while Amarok 2.8
> hasn't seen any updates recently. You really should check what you changed
> in your updates, something must have been removed or modified causing this.

I recently installed Fedora 22 fresh. I don't remember seeing the Wikipedia applet ever working correctly on this installation. But then again, I have kept the machine updated always. So it is not possible to trace back which update 'broke' the applet.

> 
> In particular, please check your internet connection, firewall settings and
> package dependencies.

Internet works. Konqueror, Opera & Firefox work fine. Any package in particular to watch out for?

> 
> FWIW: I use Amarok from current git master on Kubuntu 14.10, KDE release
> 4.14.2, updates and backports PPA activated, and I have no such problem.

Will have to wait till Amarok 2.9 hits Fedora updates :-(
Currently running Amarok 2.8.0 on KDE 4.14.9,
Comment 9 Rex Dieter 2015-06-28 16:02:52 UTC
running amarok --debug, I get this (playing a Duran Duran tune):

amarok:   [WikipediaEngine] goto: "artist" 
amarok:   [WikipediaEngine] Fetching langlinks: KUrl("http://en.wikipedia.org/w/api.php?action=query&prop=langlinks&titles=Duran%20Duran&format=xml&lllimit=100&redirects=1") 
amarok: END__: void WikipediaEnginePrivate::_dataContainerUpdated(const QString&, const Data&) [Took: 0s] 
amarok: BEGIN: void WikipediaApplet::dataUpdated(const QString&, const Data&) 
amarok: END__: void WikipediaApplet::dataUpdated(const QString&, const Data&) [Took: 0s] 
amarok: [NetworkAccessManagerProxy] the server is redirecting the request to:  KUrl("https://en.wikipedia.org/w/api.php?action=query&prop=langlinks&titles=Duran%20Duran&format=xml&lllimit=100&redirects=1") 

The resulting redirect page, just lists a bunch of languages with little to no actual content.  I'm looking now for any relevant post 2.8 commits to the wikipedia plugin.
Comment 10 Rex Dieter 2015-06-28 16:08:53 UTC
Testing now if fix for bug #322249 (to use ssl by default), to avoid the redirect... helps any here.
Comment 11 Rex Dieter 2015-06-28 16:17:40 UTC
And... now it works, marking fixed by the same commit:

http://commits.kde.org/amarok/284342b48dc32341c3553fd2b0ee5069d75b58f9

Will pull this into fedora's packaging in the meantime.
Comment 12 Rex Dieter 2015-06-28 16:30:35 UTC
That said, it does appear that redirects are not hanlded properly (why this bug was filed).

I'll re-open it and adjust summary accordingly.
Comment 13 Myriam Schweingruber 2015-06-30 22:13:00 UTC
Rex: I use current git and can't reproduce this at all, are you sure this bug should be reopened? It certainly is fixed for me in master
Comment 14 Rex Dieter 2015-07-02 20:10:24 UTC
Did you try setting the newly instroduced useSSL wikipedia option off, and it still works?  If so, then yes, you can close this bug.
Comment 15 Sönke Jensen 2015-07-02 22:33:09 UTC
Dear all,

I don't know how to find and don't know where is to find that option 
"use SSL wikipedia option off" in Amarok 2.8.0, KDE 4.14.2, Kubuntu 
12.04, 64 Bit, Kernel 3.2.0-60-generic,

sorry,,,my age is 58 years.

Kindly Regards,

Sönke Jensen

Am 02.07.2015 um 22:10 schrieb Rex Dieter:
> https://bugs.kde.org/show_bug.cgi?id=349313
>
> --- Comment #14 from Rex Dieter <rdieter@math.unl.edu> ---
> Did you try setting the newly instroduced useSSL wikipedia option off, and it
> still works?  If so, then yes, you can close this bug.
>
Comment 16 Rex Dieter 2015-07-03 00:37:09 UTC
It was a feature introduced after 2.8.0 release, referenced in comment #11
Comment 17 Myriam Schweingruber 2015-07-03 21:15:14 UTC
(In reply to Rex Dieter from comment #14)
> Did you try setting the newly instroduced useSSL wikipedia option off, and
> it still works?  If so, then yes, you can close this bug.

Right, but that was so far not clear to me from the bug report, changed the description accordingly.
Comment 18 Myriam Schweingruber 2015-07-11 09:46:32 UTC
Apparently something has change in wikipedia, because since a few days the images don't load anymore in any wikipedia article.
Comment 19 Freddie Chopin 2015-11-14 19:33:06 UTC
I feel that it is important to note that in "stable" released Amarok version I didn't see Wikipedia working for some time (at least half a year), but today I compiled the most recent version from git and Wikipedia is working fine (;

I'm on Arch Linux - all system packages are up-to-date.
Comment 20 b3nmore 2016-04-05 17:51:51 UTC
Wikipedia now uses  a permanent TLS redirect (301), when querying via http (and not https). Imo this makes the option to disable SSL obsolete (cf. commit http://commits.kde.org/amarok/284342b48dc32341c3553fd2b0ee5069d75b58f9) .

So I would suggest to remove that options. Then we don't have to care about the redirection issue and can close this bug (one release blocker less!).
Comment 21 Olivier Churlaud 2016-06-20 22:31:23 UTC
Fixed here: http://commits.kde.org/amarok/8c15258b28870b6d9990b24f87ce913e2049bac8
Comment 22 joseph.oconnor.lincoln 2017-05-31 17:58:24 UTC
Hi guys,
I'm hoping to fix the Wikipedia problem. I see there is a patch, how to I add the patch to Amarok? I know I have to edit a text file. I've never done that before however I'm guessing it wouldn't actually be that difficult. Do i replace anything in the script or just add the patch to the end of it? Would be great to have this problem fixed, any help would be much appreciated!
Comment 23 Myriam Schweingruber 2017-06-01 11:28:39 UTC
You do realize this is already fixed, don't you? The bug is closed as the fix is applied in the current git version already, the Amarok 2.9 beta also has the fix. If you want to backport a fix, you might want to talk to your distribution, though.
Comment 24 Myriam Schweingruber 2017-09-21 10:49:29 UTC
*** Bug 379775 has been marked as a duplicate of this bug. ***