Bug 334145

Summary: Kontact doesn't show events of days following today with the default iCal calendar in Summary view.
Product: [Applications] kontact Reporter: vivrecoeur
Component: summaryAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: okaraman2012, wbauer
Priority: NOR    
Version: 4.13   
Target Milestone: ---   
Platform: Kubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: attachment-13989-0.html
attachment-13433-0.html

Description vivrecoeur 2014-04-30 17:01:32 UTC
In Summary view of Kontact, it should show events that starts in the next 7 days (configured), but it only show events that start today. It works with birthday calendars, but not with the default iCal calendar.

Reproducible: Always

Steps to Reproduce:
1. Set up Kontact to show the events (for example) of the next 7 days. 
2. Set up an iCal calendar in korganizer.
3. Create an event in a day posterior than today in the next 7 days.

Actual Results:  
Kontact not showing the event in Summary view.

Expected Results:  
Kontact should show the event in the next 7 days Summary view.
Comment 1 okaraman2012 2014-06-17 03:13:11 UTC
Same here. It only shows recurrent appointments.
I am using Kontact 4.13 on Kubuntu 14.04.
Comment 2 okaraman2012 2014-06-27 22:29:03 UTC
Ok, how many more messages do you need to mark this annoying bug as "confirmed"?
Comment 3 Wolfgang Bauer 2014-08-05 09:38:44 UTC
This sounds like a duplicate of bug#327256.

Please reopen if you disagree.

*** This bug has been marked as a duplicate of bug 327256 ***
Comment 4 okaraman2012 2014-08-08 03:31:58 UTC
Created attachment 88157 [details]
attachment-13989-0.html

Ok. Any fix for the bug please?


On Tue, Aug 5, 2014 at 2:38 AM, Wolfgang Bauer <wbauer@tmo.at> wrote:

> https://bugs.kde.org/show_bug.cgi?id=334145
>
> Wolfgang Bauer <wbauer@tmo.at> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |wbauer@tmo.at
>              Status|UNCONFIRMED                 |RESOLVED
>          Resolution|---                         |DUPLICATE
>
> --- Comment #3 from Wolfgang Bauer <wbauer@tmo.at> ---
> This sounds like a duplicate of bug#327256.
>
> Please reopen if you disagree.
>
> *** This bug has been marked as a duplicate of bug 327256 ***
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 5 Wolfgang Bauer 2014-08-08 07:45:53 UTC
(In reply to okaraman2012 from comment #4)
> Created attachment 88157 [details]
> attachment-13989-0.html

What's the point of this attachment?

> Ok. Any fix for the bug please?

As you can read in the bug report, I proposed a fix here:
https://git.reviewboard.kde.org/r/119614/

This has yet to be accepted though...
Comment 6 okaraman2012 2014-08-12 20:33:09 UTC
Created attachment 88240 [details]
attachment-13433-0.html

Thanks for the patch.


On Fri, Aug 8, 2014 at 12:45 AM, Wolfgang Bauer <wbauer@tmo.at> wrote:

> https://bugs.kde.org/show_bug.cgi?id=334145
>
> --- Comment #5 from Wolfgang Bauer <wbauer@tmo.at> ---
> (In reply to okaraman2012 from comment #4)
> > Created attachment 88157 [details]
> > attachment-13989-0.html
>
> What's the point of this attachment?
>
> > Ok. Any fix for the bug please?
>
> As you can read in the bug report, I proposed a fix here:
> https://git.reviewboard.kde.org/r/119614/
>
> This has yet to be accepted though...
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>