Bug 331031

Summary: WIne crashes starting Path Of Exile
Product: [Plasma] kwin Reporter: jonathon.l.walker
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 4.11.5   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description jonathon.l.walker 2014-02-12 04:31:32 UTC
Application: kwin (4.11.5)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.11.10-200.fc19.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

launching ath of exile (using primusrun)
This was immediately after a rpm updates for primus which supposedly improved performance of offloading.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f6e4090e8c0 (LWP 5994))]

Thread 2 (Thread 0x7f6e23fff700 (LWP 6002)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00000039b118614b in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /lib64/libQtScript.so.4
#2  0x00000039b1186189 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib64/libQtScript.so.4
#3  0x000000398fc07c53 in start_thread (arg=0x7f6e23fff700) at pthread_create.c:308
#4  0x000000398f4f5dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f6e4090e8c0 (LWP 5994)):
[KCrash Handler]
#5  gen7_update_renderbuffer_surface (brw=0xef8ed0, rb=0xea9130, layered=false, unit=0) at gen7_wm_surface_state.c:509
#6  0x00007f6e3230466c in brw_update_renderbuffer_surfaces (brw=<optimized out>) at brw_wm_surface_state.c:717
#7  0x00007f6e322daf2a in brw_upload_state (brw=brw@entry=0xef8ed0) at brw_state_upload.c:513
#8  0x00007f6e322984a6 in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=<optimized out>, nr_prims=<optimized out>, prim=<optimized out>, arrays=<optimized out>, ctx=0xef8ed0) at brw_draw.c:445
#9  brw_draw_prims (ctx=0xef8ed0, prim=<optimized out>, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=23, tfb_vertcount=0x0) at brw_draw.c:530
#10 0x00007f6e31dc0944 in vbo_draw_arrays (ctx=0xef8ed0, mode=4, start=0, count=24, numInstances=1, baseInstance=0) at ../../../src/mesa/vbo/vbo_exec_array.c:660
#11 0x000000368041214e in KWin::GLVertexBuffer::draw(QRegion const&, unsigned int, int, int, bool) () from /lib64/libkwinglutils.so.1
#12 0x0000003680415129 in KWin::GLVertexBuffer::render(QRegion const&, unsigned int, bool) () from /lib64/libkwinglutils.so.1
#13 0x000000368041518d in KWin::GLVertexBuffer::render(unsigned int) () from /lib64/libkwinglutils.so.1
#14 0x00000036800d573a in KWin::SceneOpenGL2::doPaintBackground(QVector<float> const&) () from /lib64/libkdeinit4_kwin.so
#15 0x00000036800d8dd5 in KWin::SceneOpenGL::paintBackground(QRegion) () from /lib64/libkdeinit4_kwin.so
#16 0x00000036800c906e in KWin::Scene::paintSimpleScreen(int, QRegion) () from /lib64/libkdeinit4_kwin.so
#17 0x00000036800c6d95 in KWin::Scene::finalPaintScreen(int, QRegion, KWin::ScreenPaintData&) () from /lib64/libkdeinit4_kwin.so
#18 0x00000036800e919d in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /lib64/libkdeinit4_kwin.so
#19 0x000000367f6119df in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /lib64/libkwineffects.so.1
#20 0x00000036800e915a in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /lib64/libkdeinit4_kwin.so
#21 0x000000367f6119df in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /lib64/libkwineffects.so.1
#22 0x00000036800e915a in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /lib64/libkdeinit4_kwin.so
#23 0x00000036800c9253 in KWin::Scene::paintScreen(int*, QRegion const&, QRegion const&, QRegion*, QRegion*) () from /lib64/libkdeinit4_kwin.so
#24 0x00000036800dc01e in KWin::SceneOpenGL::paint(QRegion, QList<KWin::Toplevel*>) () from /lib64/libkdeinit4_kwin.so
#25 0x00000036800c1163 in KWin::Compositor::performCompositing() () from /lib64/libkdeinit4_kwin.so
#26 0x000000399ad91d51 in QObject::event(QEvent*) () from /lib64/libQtCore.so.4
#27 0x000000399fdc84dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#28 0x000000399fdceaa0 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQtGui.so.4
#29 0x000000367a23fd5a in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#30 0x000000399ad79ecd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQtCore.so.4
#31 0x000000399ada9803 in QTimerInfoList::activateTimers() () from /lib64/libQtCore.so.4
#32 0x000000399adaa200 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#33 0x000000399fe657c6 in QEventDispatcherX11::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
#34 0x000000399ad78b2f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#35 0x000000399ad78e25 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#36 0x000000399ad7e0a9 in QCoreApplication::exec() () from /lib64/libQtCore.so.4
#37 0x000000368007b866 in kdemain () from /lib64/libkdeinit4_kwin.so
#38 0x000000398f421b45 in __libc_start_main (main=0x4009d0 <main>, argc=1, ubp_av=0x7fffa21dc6a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa21dc698) at libc-start.c:274
#39 0x0000000000400a01 in _start ()

Possible duplicates by query: bug 323303, bug 321352, bug 319758, bug 317796.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2014-02-12 06:27:01 UTC
FYI: you did *not* report a bug against wine!
This is a crash of the Compositor (shadows, translucent windows etc.) which occured in the graphics driver.

You may have similar issues in OpenGL games/wine, though and the driver bug may be exposed through concurrent usage.

Try to suspend the compositor before starting the game (Shift+Alt+F12)

*** This bug has been marked as a duplicate of bug 299333 ***