Bug 330644

Summary: Sometime crash when select a tool in the left tools-bar.
Product: digikam Reporter: giggi1999
Component: Database-SqliteAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles
Priority: NOR    
Version: 3.5.0   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In: 7.5.0

Description giggi1999 2014-02-01 20:02:36 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.12.1
Qt Version: 4.8.5
Operating System: Linux 3.12.9-2-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
Sometime during the navigation it crashes if I select a tool in the left tool-bar (like album, similar photos, tags .... )

The crash can be reproduced sometimes.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5fd5e499c0 (LWP 30711))]

Thread 14 (Thread 0x7f5fae4b7700 (LWP 30712)):
#0  0x00007f5fcf83687d in poll () from /usr/lib/libc.so.6
#1  0x00007f5fb4391908 in ?? () from /usr/lib/libusb-1.0.so.0
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 13 (Thread 0x7f5fa3b74700 (LWP 30713)):
#0  0x00007f5fcd57a03f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f5fd0314266 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00000000005a139c in Digikam::ScanController::run (this=0x2037830) at /home/sim/packages/digikam/src/digikam-3.5.0/core/digikam/database/scancontroller.cpp:725
#3  0x00007f5fd0313d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 12 (Thread 0x7f5fa3373700 (LWP 30714)):
#0  0x00007f5fc7f2d9ee in ?? () from /usr/lib/libglib-2.0.so.0
#1  0x00007f5fc7f2ff63 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#2  0x00007f5fc7f3051b in ?? () from /usr/lib/libglib-2.0.so.0
#3  0x00007f5fc7f3068c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0x00007f5fd0440b46 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f5fd0412b1f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f5fd0412e15 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f5fd03116ef in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x00007f5fd03f42c3 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f5fd0313d8f in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 11 (Thread 0x7f5fa2b6a700 (LWP 30716)):
#0  0x00007f5fcd57a03f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f5fd0314266 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f5fd34b01b1 in Digikam::ParkingThread::run (this=0x208ae10) at /home/sim/packages/digikam/src/digikam-3.5.0/core/libs/threads/threadmanager.cpp:119
#3  0x00007f5fd0313d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 10 (Thread 0x7f5e9ffff700 (LWP 30820)):
#0  0x00007f5fcd57a3e8 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f5fd0314244 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f5fd0307945 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f5fd0313d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 9 (Thread 0x7f5eb17fa700 (LWP 30821)):
#0  0x00007f5fcd57a3e8 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f5fd0314244 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f5fd0307945 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f5fd0313d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 8 (Thread 0x7f5e9f7fe700 (LWP 30822)):
#0  0x00007f5fca4d3b02 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f5fca4d236e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 7 (Thread 0x7f5e9effd700 (LWP 30823)):
#0  0x00007f5fca4d3b02 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f5fca4d236e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 6 (Thread 0x7f5f83426700 (LWP 30824)):
#0  0x00007f5fca4d3b02 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f5fca4d236e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f5f82c25700 (LWP 30825)):
#0  0x00007f5fca4d3b02 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f5fca4d236e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f5f82424700 (LWP 30826)):
#0  0x00007f5fca4d3b02 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f5fca4d236e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f5f81c23700 (LWP 30827)):
#0  0x00007f5fca4d3b02 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f5fca4d236e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f5f81422700 (LWP 30828)):
#0  0x00007f5fca4d3b02 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f5fca4d236e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f5fcd5760a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f5fcf83f32d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f5fd5e499c0 (LWP 30711)):
[KCrash Handler]
#5  0x00007f5fb8f8b4c9 in ?? () from /usr/lib/libsqlite3.so.0
#6  0x00007f5fb8f8b683 in ?? () from /usr/lib/libsqlite3.so.0
#7  0x00007f5fb8f9fba9 in ?? () from /usr/lib/libsqlite3.so.0
#8  0x00007f5fb8fc7f42 in ?? () from /usr/lib/libsqlite3.so.0
#9  0x00007f5fb8fd0487 in sqlite3_step () from /usr/lib/libsqlite3.so.0
#10 0x00007f5fa215d11c in ?? () from /usr/lib/qt4/plugins/sqldrivers/libqsqlite.so
#11 0x00007f5fa215de48 in ?? () from /usr/lib/qt4/plugins/sqldrivers/libqsqlite.so
#12 0x00007f5fd5a8abad in QSqlQuery::exec() () from /usr/lib/libQtSql.so.4
#13 0x00007f5fd3474ae8 in Digikam::DatabaseCoreBackend::exec (this=this@entry=0x2045510, query=...) at /home/sim/packages/digikam/src/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1414
#14 0x00007f5fd3474b9c in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x2045510, query=..., boundValue1=...) at /home/sim/packages/digikam/src/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1056
#15 0x00007f5fd3475340 in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x2045510, sql=..., boundValue1=...) at /home/sim/packages/digikam/src/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:1005
#16 0x00007f5fd3475389 in Digikam::DatabaseCoreBackend::execSql (this=0x2045510, sql=..., boundValue1=..., values=values@entry=0x7fffbe9e3490, lastInsertId=lastInsertId@entry=0x0) at /home/sim/packages/digikam/src/digikam-3.5.0/core/libs/database/core/databasecorebackend.cpp:902
#17 0x00007f5fd2e50d5b in Digikam::AlbumDB::getSetting (this=this@entry=0x2045230, keyword=...) at /home/sim/packages/digikam/src/digikam-3.5.0/core/libs/database/albumdb.cpp:972
#18 0x00007f5fd2e5bf6d in Digikam::AlbumDB::getFilterSettings (this=0x2045230, imageFilter=imageFilter@entry=0x7fffbe9e36d0, videoFilter=videoFilter@entry=0x0, audioFilter=audioFilter@entry=0x0) at /home/sim/packages/digikam/src/digikam-3.5.0/core/libs/database/albumdb.cpp:1017
#19 0x00000000005f88e7 in Digikam::AlbumSettings::getRawFileFilter (this=this@entry=0x2041320) at /home/sim/packages/digikam/src/digikam-3.5.0/core/digikam/utils/albumsettings.cpp:958
#20 0x0000000000515c47 in Digikam::KipiInterface::hostSetting (this=this@entry=0x638a100, settingName=...) at /home/sim/packages/digikam/src/digikam-3.5.0/core/utilities/kipiiface/kipiinterface.cpp:363
#21 0x0000000000514b2e in Digikam::KipiInterface::currentAlbum (this=0x638a100) at /home/sim/packages/digikam/src/digikam-3.5.0/core/utilities/kipiiface/kipiinterface.cpp:110
#22 0x00007f5f3e174d94 in ?? () from /usr/lib/kde4/kipiplugin_advancedslideshow.so
#23 0x00007f5fd0427b48 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#24 0x00007f5fd3dd43c2 in KIPI::Interface::currentAlbumChanged(bool) () from /usr/lib/libkipi.so.11
#25 0x00007f5fd0427b48 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#26 0x0000000000573d20 in Digikam::AlbumManager::signalAlbumCurrentChanged (this=<optimized out>, _t1=_t1@entry=0x9afd480) at /home/sim/packages/digikam/src/build/core/digikam/albummanager.moc:267
#27 0x0000000000574679 in Digikam::AlbumManager::setCurrentAlbum (this=<optimized out>, album=album@entry=0x9afd480) at /home/sim/packages/digikam/src/digikam-3.5.0/core/digikam/album/albummanager.cpp:1846
#28 0x000000000053adca in Digikam::FuzzySearchView::slotTabChanged (this=0x61b4ee0, tab=<optimized out>) at /home/sim/packages/digikam/src/digikam-3.5.0/core/utilities/fuzzysearch/fuzzysearchview.cpp:652
#29 0x000000000053af3d in Digikam::FuzzySearchView::setActive (this=0x61b4ee0, val=<optimized out>) at /home/sim/packages/digikam/src/digikam-3.5.0/core/utilities/fuzzysearch/fuzzysearchview.cpp:628
#30 0x0000000000639a2b in Digikam::FuzzySearchSideBarWidget::setActive (this=0x61b4ac0, active=<optimized out>) at /home/sim/packages/digikam/src/digikam-3.5.0/core/digikam/views/leftsidebarwidgets.cpp:970
#31 0x000000000061195d in Digikam::DigikamView::slotLeftSidebarChangedTab (this=<optimized out>, w=<optimized out>) at /home/sim/packages/digikam/src/digikam-3.5.0/core/digikam/views/digikamview.cpp:1874
#32 0x00007f5fd0427b48 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#33 0x00007f5fd34cf6ff in Digikam::Sidebar::signalChangedTab (this=<optimized out>, _t1=0x61b4ac0) at /home/sim/packages/digikam/src/build/core/digikam/sidebar.moc:111
#34 0x00007f5fd0427b48 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#35 0x00007f5fd1bec3fe in KMultiTabBarButton::clicked(int) () from /usr/lib/libkdeui.so.5
#36 0x00007f5fd0427b48 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#37 0x00007f5fd145ba82 in QAbstractButton::clicked(bool) () from /usr/lib/libQtGui.so.4
#38 0x00007f5fd11c0243 in ?? () from /usr/lib/libQtGui.so.4
#39 0x00007f5fd11c13b3 in ?? () from /usr/lib/libQtGui.so.4
#40 0x00007f5fd11c149c in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#41 0x00007f5fd0e6262e in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#42 0x00007f5fd0e130dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#43 0x00007f5fd0e197dd in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#44 0x00007f5fd1b3277a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#45 0x00007f5fd0413ebd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#46 0x00007f5fd0e18f93 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#47 0x00007f5fd0e8abab in ?? () from /usr/lib/libQtGui.so.4
#48 0x00007f5fd0e8961c in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#49 0x00007f5fd0eb0162 in ?? () from /usr/lib/libQtGui.so.4
#50 0x00007f5fc7f30296 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#51 0x00007f5fc7f305e8 in ?? () from /usr/lib/libglib-2.0.so.0
#52 0x00007f5fc7f3068c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#53 0x00007f5fd0440b46 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#54 0x00007f5fd0eb0216 in ?? () from /usr/lib/libQtGui.so.4
#55 0x00007f5fd0412b1f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#56 0x00007f5fd0412e15 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#57 0x00007f5fd0417f4b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#58 0x0000000000496386 in main (argc=<optimized out>, argv=<optimized out>) at /home/sim/packages/digikam/src/digikam-3.5.0/core/digikam/main/main.cpp:235


Reproducible: Sometimes

Steps to Reproduce:
1. Open digikam 
2. Navigate in the album, and change to 'find similar' 'album' 'tags' ... in the left tools bar
3. Sometime it crash.
Comment 1 caulier.gilles 2014-02-01 21:41:51 UTC

*** This bug has been marked as a duplicate of bug 329697 ***
Comment 2 caulier.gilles 2021-12-17 11:48:56 UTC
Fixed with #329697