Bug 325776

Summary: Kwin crashed when I set orientation of display to "mirror vertically"
Product: [Plasma] kwin Reporter: headcrabextra
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 4.10.5   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
Latest Commit: Version Fixed In:

Description headcrabextra 2013-10-08 14:10:51 UTC
Application: kwin (4.10.5)
KDE Platform Version: 4.10.5
Qt Version: 4.8.6
Operating System: Linux 3.10-2-amd64 x86_64
Distribution: Debian GNU/Linux testing (jessie)

-- Information about the crash:
- What I was doing when the application crashed:
I was browsing different options in System Settings -> Size and Orientation. I changed "no rotation" to "mirror vertically" and it crashed. After that I tried changing that again for a few times and saw unusual behaviour but no crashes.

- Unusual behavior I noticed:
After I tried changing that again I noticed that even though it didn't crash this time - it didn't work either. The display didn't become vertically mirrored. Also after those few more tries without crashes most of the elements of desktop were initially black and were redrawn only after hovering them with cursor.

The crash does not seem to be reproducible.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2f8d47f780 (LWP 6155))]

Thread 2 (Thread 0x7f2f697e3700 (LWP 6170)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f2f89570a4b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f2f89570a89 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f2f81646e0e in start_thread (arg=0x7f2f697e3700) at pthread_create.c:311
#4  0x00007f2f8cca99ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f2f8d47f780 (LWP 6155)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x23ade50, rb=0x2240920, unit=0) at brw_wm_surface_state.c:1220
#7  0x00007f2f702eff10 in brw_update_renderbuffer_surfaces (brw=0x23ade50) at brw_wm_surface_state.c:1316
#8  0x00007f2f702caa72 in brw_upload_state (brw=brw@entry=0x23ade50) at brw_state_upload.c:500
#9  0x00007f2f7028c793 in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=<optimized out>, nr_prims=<optimized out>, prim=<optimized out>, arrays=<optimized out>, ctx=0x23ade50) at brw_draw.c:500
#10 brw_draw_prims (ctx=0x23ade50, prim=<optimized out>, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:587
#11 0x00007f2f6b381c14 in vbo_draw_arrays (ctx=0x23ade50, mode=4, start=0, count=6, numInstances=1, baseInstance=0) at ../../../../../src/mesa/vbo/vbo_exec_array.c:623
#12 0x00007f2f88fb84a3 in KWin::GLVertexBufferPrivate::corePainting (this=0x1c31380, region=..., primitiveMode=4, hardwareClipping=<optimized out>) at ../../../kwin/libkwineffects/kwinglutils.cpp:1254
#13 0x00007f2f88fb8705 in KWin::GLVertexBuffer::render (this=0x2523b70, region=..., primitiveMode=primitiveMode@entry=4, hardwareClipping=hardwareClipping@entry=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1363
#14 0x00007f2f8d02a613 in KWin::SceneOpenGL::Window::renderQuads (region=..., quads=..., tex=<optimized out>, normalized=normalized@entry=false, hardwareClipping=hardwareClipping@entry=false, this=0x1942600) at ../../kwin/scene_opengl.cpp:1228
#15 0x00007f2f8d02f243 in renderQuads (hardwareClipping=false, normalized=false, tex=<optimized out>, quads=..., region=..., this=0x1942600) at ../../kwin/scene_opengl.cpp:1210
#16 KWin::SceneOpenGL::Window::performPaint (this=this@entry=0x1942600, mask=mask@entry=9, region=..., data=...) at ../../kwin/scene_opengl.cpp:969
#17 0x00007f2f8d030a8b in KWin::SceneOpenGL2::performPaintWindow (this=this@entry=0x24321c0, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../kwin/scene_opengl.cpp:566
#18 0x00007f2f8d030bd9 in KWin::SceneOpenGL2::finalDrawWindow (this=0x24321c0, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../kwin/scene_opengl.cpp:548
#19 0x00007f2f8d03fec7 in KWin::EffectsHandlerImpl::drawWindow (this=0x279e740, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:318
#20 0x00007f2f69853ec6 in KWin::BlurEffect::drawWindow (this=this@entry=0x27d74a0, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:419
#21 0x00007f2f8d03fe71 in KWin::EffectsHandlerImpl::drawWindow (this=0x279e740, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:315
#22 0x00007f2f8d01f6b1 in KWin::Scene::finalPaintWindow (this=<optimized out>, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../kwin/scene.cpp:449
#23 0x00007f2f8d03fdc8 in KWin::EffectsHandlerImpl::paintWindow (this=0x279e740, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:281
#24 0x00007f2f8b461821 in KWin::Effect::paintWindow (this=this@entry=0x27d74a0, w=w@entry=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:504
#25 0x00007f2f8d03fd81 in KWin::EffectsHandlerImpl::paintWindow (this=0x279e740, w=0x193f1c0, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:278
#26 0x00007f2f8d021e4a in KWin::Scene::paintWindow (w=w@entry=0x1942600, mask=mask@entry=9, region=..., quads=..., this=<optimized out>) at ../../kwin/scene.cpp:356
#27 0x00007f2f8d022799 in KWin::Scene::paintWindow (this=<optimized out>, w=0x1942600, mask=9, region=..., quads=...) at ../../kwin/scene.cpp:444
#28 0x00007f2f8d0207e6 in KWin::Scene::paintSimpleScreen (this=this@entry=0x24321c0, orig_mask=orig_mask@entry=8, region=...) at ../../kwin/scene.cpp:342
#29 0x00007f2f8d01f605 in KWin::Scene::finalPaintScreen (this=0x24321c0, mask=mask@entry=8, region=..., data=...) at ../../kwin/scene.cpp:186
#30 0x00007f2f8d03fcd5 in KWin::EffectsHandlerImpl::paintScreen (this=0x279e740, mask=mask@entry=8, region=..., data=...) at ../../kwin/effects.cpp:254
#31 0x00007f2f8b4617af in KWin::Effect::paintScreen (this=this@entry=0x27d74a0, mask=mask@entry=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:489
#32 0x00007f2f8d03fc87 in KWin::EffectsHandlerImpl::paintScreen (this=0x279e740, mask=8, region=..., data=...) at ../../kwin/effects.cpp:251
#33 0x00007f2f8d020b5e in KWin::Scene::paintScreen (this=this@entry=0x24321c0, mask=mask@entry=0x7fffe537e2f0, region=region@entry=0x7fffe537e390) at ../../kwin/scene.cpp:140
#34 0x00007f2f8d02e107 in KWin::SceneOpenGL::paint (this=0x24321c0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:308
#35 0x00007f2f8d01a483 in KWin::Compositor::performCompositing (this=0x15182e0) at ../../kwin/composite.cpp:610
#36 0x00007f2f882a8691 in QObject::event (this=0x15182e0, e=<optimized out>) at kernel/qobject.cpp:1156
#37 0x00007f2f8763075c in QApplicationPrivate::notify_helper (this=this@entry=0x138dc80, receiver=receiver@entry=0x15182e0, e=e@entry=0x7fffe537e780) at kernel/qapplication.cpp:4567
#38 0x00007f2f87636dd0 in QApplication::notify (this=this@entry=0x7fffe537ec50, receiver=receiver@entry=0x15182e0, e=e@entry=0x7fffe537e780) at kernel/qapplication.cpp:4353
#39 0x00007f2f8c794cfa in KApplication::notify (this=0x7fffe537ec50, receiver=0x15182e0, event=0x7fffe537e780) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x00007f2f8829033d in QCoreApplication::notifyInternal (this=0x7fffe537ec50, receiver=0x15182e0, event=0x7fffe537e780) at kernel/qcoreapplication.cpp:949
#41 0x00007f2f882bff83 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#42 QTimerInfoList::activateTimers (this=0x138e738) at kernel/qeventdispatcher_unix.cpp:621
#43 0x00007f2f882c0000 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x1337ad0) at kernel/qeventdispatcher_unix.cpp:878
#44 0x00007f2f882c0970 in QEventDispatcherUNIX::processEvents (this=this@entry=0x1337ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:940
#45 0x00007f2f876cf1b6 in QEventDispatcherX11::processEvents (this=0x1337ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#46 0x00007f2f8828ef9f in QEventLoop::processEvents (this=this@entry=0x7fffe537eac0, flags=...) at kernel/qeventloop.cpp:149
#47 0x00007f2f8828f295 in QEventLoop::exec (this=this@entry=0x7fffe537eac0, flags=...) at kernel/qeventloop.cpp:204
#48 0x00007f2f882948db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#49 0x00007f2f8762ef1c in QApplication::exec () at kernel/qapplication.cpp:3828
#50 0x00007f2f8cfd37ef in kdemain (argc=3, argv=0x7fffe537ed98) at ../../kwin/main.cpp:537
#51 0x00007f2f8cbe2995 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=3, ubp_av=0x7fffe537ed98, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffe537ed88) at libc-start.c:260
#52 0x00000000004006fe in _start ()

Possible duplicates by query: bug 324598, bug 323424, bug 323303, bug 323133, bug 322959.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2013-10-08 16:50:57 UTC
"kcmshell4 kwincompositing", disable "suspend desktop effects on full windows"
Intel chip? (some gma9xx?)

*** This bug has been marked as a duplicate of bug 299333 ***