Bug 325329

Summary: Assert in AbstractGroupingProxyModel::addProxyNode
Product: telepathy Reporter: David Edmundson <kde>
Component: common-internalsAssignee: Telepathy Bugs <kde-telepathy-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: b.buschinski
Priority: NOR    
Version: unspecified   
Target Milestone: Future   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description David Edmundson 2013-09-26 13:58:14 UTC
From afiestas, treat as unreliable :)

Application: KDE Telepathy Contact List (ktp-contactlist), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2a366b6780 (LWP 1741))]
 
Thread 3 (Thread 0x7f2a2005f700 (LWP 1742)):
#0  0x00007f2a30d79e6d in ?? () from /usr/lib/libglib-2.0.so.0
#1  0x00007f2a30d7a149 in g_mutex_unlock () from /usr/lib/libglib-2.0.so.0
#2  0x00007f2a30d3b196 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f2a20066a1d in ?? () from /usr/lib/gio/modules/libdconfsettings.so
#4  0x00007f2a30d5f085 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0x00007f2a32e3b0a2 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f2a312f943d in clone () from /usr/lib/libc.so.6
 
Thread 2 (Thread 0x7f2a1f85e700 (LWP 1743)):
#0  0x00007f2a312f096d in poll () from /usr/lib/libc.so.6
#1  0x00007f2a30d3b084 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f2a30d3b4ea in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#3  0x00007f2a30811346 in ?? () from /usr/lib/libgio-2.0.so.0
#4  0x00007f2a30d5f085 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0x00007f2a32e3b0a2 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f2a312f943d in clone () from /usr/lib/libc.so.6
 
Thread 1 (Thread 0x7f2a366b6780 (LWP 1741)):
[KCrash Handler]
#6  0x00007f2a312493d9 in raise () from /usr/lib/libc.so.6
#7  0x00007f2a3124a7d8 in abort () from /usr/lib/libc.so.6
#8  0x00007f2a340cc1c4 in qt_message_output (msgType=QtFatalMsg, buf=0x1d6ca68 "ASSERT: \"parent.isValid() ? parent.model() == this : true\" in file /home/afiestas/kde/source/qt/src/gui/itemviews/qidentityproxymodel.cpp, line 317") at /home/afiestas/kde/source/qt/src/corelib/global/qglobal.cpp:2325
#9  0x00007f2a340cc343 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f2a342988c8 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fffaddd2868) at /home/afiestas/kde/source/qt/src/corelib/global/qglobal.cpp:2371
#10 0x00007f2a340ccb15 in qFatal (msg=0x7f2a342988c8 "ASSERT: \"%s\" in file %s, line %d") at /home/afiestas/kde/source/qt/src/corelib/global/qglobal.cpp:2554
#11 0x00007f2a340cbd84 in qt_assert (assertion=0x7f2a32936bc8 "parent.isValid() ? parent.model() == this : true", file=0x7f2a32936b80 "/home/afiestas/kde/source/qt/src/gui/itemviews/qidentityproxymodel.cpp", line=317) at /home/afiestas/kde/source/qt/src/corelib/global/qglobal.cpp:2020
#12 0x00007f2a326f1452 in QIdentityProxyModel::rowCount (this=0x1842f30, parent=...) at /home/afiestas/kde/source/qt/src/gui/itemviews/qidentityproxymodel.cpp:317
#13 0x00007f2a36064acd in KTp::AbstractGroupingProxyModel::addProxyNode (this=this@entry=0x1847380, sourceIndex=..., parent=parent@entry=0x1a0a4c0) at /home/afiestas/kde/source/ktp-common-internals/KTp/Models/abstract-grouping-proxy-model.cpp:223
#14 0x00007f2a360659ec in KTp::AbstractGroupingProxyModel::onDataChanged (this=0x1847380, sourceTopLeft=..., sourceBottomRight=...) at /home/afiestas/kde/source/ktp-common-internals/KTp/Models/abstract-grouping-proxy-model.cpp:320
#15 0x00007f2a342325aa in QMetaObject::activate (sender=0x1842f30, m=0x7f2a345d4c20 <QAbstractItemModel::staticMetaObject>, local_signal_index=0, argv=0x7fffaddd2d30) at /home/afiestas/kde/source/qt/src/corelib/kernel/qobject.cpp:3547
#16 0x00007f2a34293175 in QAbstractItemModel::dataChanged (this=0x1842f30, _t1=..., _t2=...) at .moc/debug-shared/moc_qabstractitemmodel.cpp:163
#17 0x00007f2a36075f2e in KTp::TextChannelWatcherProxyModel::onChannelMessagesChanged (this=0x1842f30) at /home/afiestas/kde/source/ktp-common-internals/KTp/Models/text-channel-watcher-proxy-model.cpp:224
#18 0x00007f2a342325aa in QMetaObject::activate (sender=0x19ebd80, m=0x7f2a3628eaa0 <ChannelWatcher::staticMetaObject>, local_signal_index=0, argv=0x0) at /home/afiestas/kde/source/qt/src/corelib/kernel/qobject.cpp:3547
#19 0x00007f2a3422be95 in QMetaCallEvent::placeMetaCall (this=0x1a32d60, object=0x19ebd80) at /home/afiestas/kde/source/qt/src/corelib/kernel/qobject.cpp:524
#20 0x00007f2a3422d119 in QObject::event (this=0x19ebd80, e=0x1a32d60) at /home/afiestas/kde/source/qt/src/corelib/kernel/qobject.cpp:1194
#21 0x00007f2a32022590 in QApplicationPrivate::notify_helper (this=0x12bc880, receiver=0x19ebd80, e=0x1a32d60) at /home/afiestas/kde/source/qt/src/gui/kernel/qapplication.cpp:4562
#22 0x00007f2a3201fb2c in QApplication::notify (this=0x7fffaddd3c10, receiver=0x19ebd80, e=0x1a32d60) at /home/afiestas/kde/source/qt/src/gui/kernel/qapplication.cpp:3944
#23 0x00007f2a3576daa6 in KApplication::notify (this=0x7fffaddd3c10, receiver=0x19ebd80, event=0x1a32d60) at /home/afiestas/kde/source/kdelibs/kdeui/kernel/kapplication.cpp:311
#24 0x00007f2a34213fad in QCoreApplication::notifyInternal (this=0x7fffaddd3c10, receiver=0x19ebd80, event=0x1a32d60) at /home/afiestas/kde/source/qt/src/corelib/kernel/qcoreapplication.cpp:949
#25 0x00007f2a34217be5 in QCoreApplication::sendEvent (receiver=0x19ebd80, event=0x1a32d60) at ../../include/QtCore/../../../../source/qt/src/corelib/kernel/qcoreapplication.h:231
#26 0x00007f2a34214fda in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x11b55b0) at /home/afiestas/kde/source/qt/src/corelib/kernel/qcoreapplication.cpp:1573
#27 0x00007f2a34214bfd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at /home/afiestas/kde/source/qt/src/corelib/kernel/qcoreapplication.cpp:1466
#28 0x00007f2a34250d89 in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../../../source/qt/src/corelib/kernel/qcoreapplication.h:236
#29 0x00007f2a3424fd92 in postEventSourceDispatch (s=0x12ba260) at /home/afiestas/kde/source/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:280
#30 0x00007f2a30d3ad96 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0x00007f2a30d3b0e8 in ?? () from /usr/lib/libglib-2.0.so.0
#32 0x00007f2a30d3b18c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0x00007f2a34250635 in QEventDispatcherGlib::processEvents (this=0x11b6f10, flags=...) at /home/afiestas/kde/source/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:425
#34 0x00007f2a320fbf20 in QGuiEventDispatcherGlib::processEvents (this=0x11b6f10, flags=...) at /home/afiestas/kde/source/qt/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f2a34211307 in QEventLoop::processEvents (this=0x7fffaddd3b00, flags=...) at /home/afiestas/kde/source/qt/src/corelib/kernel/qeventloop.cpp:149
#36 0x00007f2a3421149a in QEventLoop::exec (this=0x7fffaddd3b00, flags=...) at /home/afiestas/kde/source/qt/src/corelib/kernel/qeventloop.cpp:204
#37 0x00007f2a34214640 in QCoreApplication::exec () at /home/afiestas/kde/source/qt/src/corelib/kernel/qcoreapplication.cpp:1221
#38 0x00007f2a3201f716 in QApplication::exec () at /home/afiestas/kde/source/qt/src/gui/kernel/qapplication.cpp:3823
#39 0x000000000041dd00 in main (argc=1, argv=0x7fffaddd3d58) at /home/afiestas/kde/source/ktp-contact-list/main.cpp:63
Comment 1 David Edmundson 2013-10-05 23:36:59 UTC

*** This bug has been marked as a duplicate of bug 325679 ***
Comment 2 David Edmundson 2013-10-09 09:58:03 UTC
*** Bug 325789 has been marked as a duplicate of this bug. ***