Bug 318198

Summary: failed to process item - rw2 to jpeg batch queue manager conversion
Product: digikam Reporter: e3k <erik.dobak>
Component: BatchQueueManager-RAWProcessingAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: caulier.gilles
Priority: NOR    
Version: 3.3.0   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In: 3.4.0

Description e3k 2013-04-11 17:10:08 UTC
i have several rw2 photos. in preview i can see them all converted. but when i try to convert them with batch queue manage the process fails if i use more then 1 photo (usualy from 600 photos one converted successfuly. the others are 0 Byte big). i did try also tiff instead jpeg but it failed also. 

exporting the photos with embedded preview extraction works fine.

Reproducible: Always

Steps to Reproduce:
1. select more than one .rw2 photos
2. open batch queue manager
3. assign tool 'convert to jpeg'
4. run
Actual Results:  
error msg: failed to process item and a 0 Byte .jpg in the export folder

Expected Results:  
a correctly converted .jpg

5 sample photos can be found here:
http://www.uschovna.cz/en/package/M0IT9A2NFthxF4K-58K
replace thx in the url with alphanumeric characters from this string: JX.W//+3
Comment 1 e3k 2013-05-25 11:54:33 UTC
same issue in 3.2.0
Comment 2 caulier.gilles 2013-07-27 09:19:25 UTC
Git commit dd3dc1cdd2292f2c12b2927250619ae4781f3a61 by Gilles Caulier.
Committed on 27/07/2013 at 09:10.
Pushed by cgilles into branch 'master'.

Batch Queue Manager : add new option to turn on/off multi-core support. This option is now turn off by default due to some dysfunctions under Windows, until it will be hack and fixed.
Note that problem are not reproducible under OSX and Linux here. Options is implemnted for digiKam 3.3.0 release.
Related: bug 315025, bug 318577, bug 320358

M  +13   -1    utilities/queuemanager/manager/actionthread.cpp
M  +1    -1    utilities/queuemanager/manager/actionthread.h
M  +4    -1    utilities/queuemanager/manager/queuesettings.h
M  +9    -1    utilities/queuemanager/manager/workflowmanager.cpp
M  +14   -2    utilities/queuemanager/views/queuesettingsview.cpp

http://commits.kde.org/digikam/dd3dc1cdd2292f2c12b2927250619ae4781f3a61
Comment 3 e3k 2013-08-11 13:58:23 UTC
in version 3.3.0 the batch conversion works fine with and without the multicore support.
thanks.