Bug 316866

Summary: KDE crashes
Product: [Plasma] kwin Reporter: Eduardo Ceballos <cebacam>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.9.5   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Eduardo Ceballos 2013-03-16 20:28:33 UTC
Application: kwin (4.9.5)
KDE Platform Version: 4.9.5 (Compiled from sources)
Qt Version: 4.8.3
Operating System: Linux 3.5.0-25-lowlatency x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
KDE crashes every time I put anythiing of the web in fullscreen. Games, videos or whatever, but until y press the ESC key.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f619a79c780 (LWP 3437))]

Thread 3 (Thread 0x7f6192756700 (LWP 3440)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f61aa741cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f61aa741d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f61a2845e9a in start_thread (arg=0x7f6192756700) at pthread_create.c:308
#4  0x00007f61ad818cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6183d97700 (LWP 3446)):
#0  0x00007fff393e1827 in clock_gettime ()
#1  0x00007f61a308615d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f61a93ed9c4 in do_gettime (frac=0x7f6183d96b28, sec=0x7f6183d96b20) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f61a94c341d in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f617c001178) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f61a94c4696 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f617c000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:186
#6  0x00007f61a94c5572 in QEventDispatcherUNIX::processEvents (this=0x7f617c0008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#7  0x00007f61a94932bf in QEventLoop::processEvents (this=this@entry=0x7f6183d96dd0, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f61a9493548 in QEventLoop::exec (this=0x7f6183d96dd0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f61a9394b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x00007f61a94739af in QInotifyFileSystemWatcherEngine::run (this=0xe405a0) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x00007f61a9397aec in QThreadPrivate::start (arg=0xe405a0) at thread/qthread_unix.cpp:338
#12 0x00007f61a2845e9a in start_thread (arg=0x7f6183d97700) at pthread_create.c:308
#13 0x00007f61ad818cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f619a79c780 (LWP 3437)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0xf98120, rb=0x8bad80, unit=0) at brw_wm_surface_state.c:1109
#7  0x00007f6182d0cab0 in brw_update_renderbuffer_surfaces (brw=0xf98120) at brw_wm_surface_state.c:1205
#8  0x00007f6182cf6b02 in brw_upload_state (brw=brw@entry=0xf98120) at brw_state_upload.c:498
#9  0x00007f6182ce41a7 in brw_try_draw_prims (max_index=47, min_index=959832456, ib=<optimized out>, nr_prims=<optimized out>, prim=0x7fff3935e170, arrays=<optimized out>, ctx=0xf98120) at brw_draw.c:493
#10 brw_draw_prims (ctx=0xf98120, prim=0x7fff3935e170, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=47, tfb_vertcount=0x0) at brw_draw.c:589
#11 0x00007f6182860b84 in vbo_draw_arrays (ctx=0xf98120, mode=4, start=0, count=48, numInstances=1, baseInstance=<optimized out>) at ../../../../../src/mesa/vbo/vbo_exec_array.c:645
#12 0x00007f61aa19789e in KWin::GLVertexBufferPrivate::corePainting (this=0xd47ff0, region=..., primitiveMode=4, hardwareClipping=<optimized out>) at ../../../kwin/libkwineffects/kwinglutils.cpp:1218
#13 0x00007f61aa197dbd in KWin::GLVertexBuffer::render (this=this@entry=0xd4dab0, region=..., primitiveMode=primitiveMode@entry=4, hardwareClipping=hardwareClipping@entry=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1341
#14 0x00007f61aa197e41 in KWin::GLVertexBuffer::render (this=0xd4dab0, primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1333
#15 0x00007f61adba47c1 in KWin::SceneOpenGL::paintBackground (this=this@entry=0x8d3710, region=...) at ../../kwin/scene_opengl.cpp:210
#16 0x00007f61adb94300 in KWin::Scene::paintSimpleScreen (this=this@entry=0x8d3710, orig_mask=orig_mask@entry=0, region=...) at ../../kwin/scene.cpp:323
#17 0x00007f61adb91f72 in KWin::Scene::finalPaintScreen (this=0x8d3710, mask=0, region=..., data=...) at ../../kwin/scene.cpp:192
#18 0x00007f61adbb15b3 in KWin::EffectsHandlerImpl::paintScreen (this=0xd7e9a0, mask=mask@entry=0, region=..., data=...) at ../../kwin/effects.cpp:246
#19 0x00007f61ac003bf7 in KWin::Effect::paintScreen (this=this@entry=0xc68d70, mask=mask@entry=0, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#20 0x00007f61adbb155b in KWin::EffectsHandlerImpl::paintScreen (this=0xd7e9a0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:243
#21 0x00007f61adb935bb in KWin::Scene::paintScreen (this=0x8d3710, mask=0x7fff3935e78c, region=0x7fff3935e830) at ../../kwin/scene.cpp:146
#22 0x00007f61adba817d in KWin::SceneOpenGL::paint (this=0x8d3710, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:499
#23 0x00007f61adb8d2b8 in KWin::Workspace::performCompositing (this=0x829a60) at ../../kwin/composite.cpp:443
#24 0x00007f61a94a926c in QObject::event (this=0x829a60, e=<optimized out>) at kernel/qobject.cpp:1157
#25 0x00007f61a883be9c in QApplicationPrivate::notify_helper (this=this@entry=0x6b4f70, receiver=receiver@entry=0x829a60, e=e@entry=0x7fff3935ef10) at kernel/qapplication.cpp:4562
#26 0x00007f61a884030a in QApplication::notify (this=0x7fff3935f550, receiver=0x829a60, e=0x7fff3935ef10) at kernel/qapplication.cpp:4423
#27 0x00007f61ad3071f6 in KApplication::notify (this=0x7fff3935f550, receiver=0x829a60, event=0x7fff3935ef10) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007f61a949456e in QCoreApplication::notifyInternal (this=0x7fff3935f550, receiver=0x829a60, event=0x7fff3935ef10) at kernel/qcoreapplication.cpp:915
#29 0x00007f61a94c5462 in sendEvent (event=0x7fff3935ef10, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#30 QTimerInfoList::activateTimers (this=0x6b5ab8) at kernel/qeventdispatcher_unix.cpp:611
#31 0x00007f61a94c54c0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x653ad0) at kernel/qeventdispatcher_unix.cpp:868
#32 0x00007f61a94c5618 in QEventDispatcherUNIX::processEvents (this=0x653ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#33 0x00007f61a88e1a3f in QEventDispatcherX11::processEvents (this=0x653ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#34 0x00007f61a94932bf in QEventLoop::processEvents (this=this@entry=0x7fff3935f260, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f61a9493548 in QEventLoop::exec (this=0x7fff3935f260, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007f61a9498708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#37 0x00007f61adb46ec4 in kdemain (argc=3, argv=0x7fff3935f698) at ../../kwin/main.cpp:545
#38 0x00007f61ad74676d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=3, ubp_av=0x7fff3935f698, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff3935f688) at libc-start.c:226
#39 0x00000000004006d1 in _start ()

This bug may be a duplicate of or related to bug 299333.

Possible duplicates by query: bug 316327, bug 314730, bug 314673, bug 314196, bug 314018.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2013-03-16 20:39:06 UTC
run "kcmshell4 kwincompositing"
in the 3rd tab, UNcheck "suspend compositing for fullscreen windows"

*** This bug has been marked as a duplicate of bug 299333 ***