Bug 316327

Summary: KDE crashes with driver behaving oddly (Intel Mobility Series 4)
Product: [Plasma] kwin Reporter: Stephan Diestelhorst <stephan.diestelhorst>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.10.1   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Stephan Diestelhorst 2013-03-07 18:19:48 UTC
Application: kwin (4.10.1)
KDE Platform Version: 4.10.1
Qt Version: 4.8.2
Operating System: Linux 3.2.0-38-generic x86_64
Distribution: Ubuntu 12.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Switching from external monitor to laptop screen using xrandr.  I will also attach an Xorg0.log.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x7f92e8c21040, rb=0x25153e0, unit=0) at brw_wm_surface_state.c:959
#7  0x00007f92e943dbf0 in brw_update_renderbuffer_surfaces (brw=0x7f92e8c21040) at brw_wm_surface_state.c:1052
#8  0x00007f92e9427788 in brw_upload_state (brw=0x7f92e8c21040) at brw_state_upload.c:503
#9  0x00007f92e941486f in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7fffdcc45b90, arrays=0x2732c28, ctx=0x7f92e8c21040) at brw_draw.c:482
#10 brw_draw_prims (ctx=0x7f92e8c21040, arrays=0x2732c28, prim=0x7fffdcc45b90, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=29, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007f92e90830d4 in vbo_draw_arrays (ctx=0x7f92e8c21040, mode=4, start=0, count=<optimized out>, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x00007f9302614e4c in KWin::GLVertexBufferPrivate::corePainting (this=0x28aaf60, region=..., primitiveMode=4, hardwareClipping=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1254
#13 0x00007f93026150cd in KWin::GLVertexBuffer::render (this=0x246d270, region=..., primitiveMode=4, hardwareClipping=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1363
#14 0x00007f9302615152 in KWin::GLVertexBuffer::render (this=0x246d270, primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1355
#15 0x00007f93068c6a1a in KWin::SceneOpenGL2::doPaintBackground (this=<optimized out>, vertices=...) at ../../kwin/scene_opengl.cpp:529
#16 0x00007f93068c9fa6 in KWin::SceneOpenGL::paintBackground (this=0x28ab0e0, region=...) at ../../kwin/scene_opengl.cpp:364
#17 0x00007f93068b9e9d in KWin::Scene::paintSimpleScreen (this=0x28ab0e0, orig_mask=8, region=...) at ../../kwin/scene.cpp:331
#18 0x00007f93068b89d2 in KWin::Scene::finalPaintScreen (this=0x28ab0e0, mask=8, region=..., data=...) at ../../kwin/scene.cpp:186
#19 0x00007f93068dc914 in KWin::EffectsHandlerImpl::paintScreen (this=0x2a4a080, mask=8, region=..., data=...) at ../../kwin/effects.cpp:254
#20 0x00007f93068ba9fa in KWin::Scene::paintScreen (this=0x28ab0e0, mask=0x7fffdcc462a8, region=0x7fffdcc463f0) at ../../kwin/scene.cpp:140
#21 0x00007f93068ce913 in KWin::SceneOpenGL::paint (this=0x28ab0e0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:308
#22 0x00007f93068b33f9 in performCompositing (this=0x2278f60) at ../../kwin/composite.cpp:610
#23 KWin::Compositor::performCompositing (this=0x2278f60) at ../../kwin/composite.cpp:541
#24 0x00007f93068b3e4e in KWin::Compositor::slotCompositingOptionsInitialized (this=0x2278f60) at ../../kwin/composite.cpp:275
#25 0x00007f9301908781 in QMetaObject::activate (sender=0x22fd050, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#26 0x00007f93017e53c7 in QFutureWatcherBase::event (this=<optimized out>, event=0x7f92dc0013f0) at concurrent/qfuturewatcher.cpp:344
#27 0x00007f9300c757b4 in notify_helper (e=0x7f92dc0013f0, receiver=0x22fd050, this=0x2153d60) at kernel/qapplication.cpp:4556
#28 QApplicationPrivate::notify_helper (this=0x2153d60, receiver=0x22fd050, e=0x7f92dc0013f0) at kernel/qapplication.cpp:4528
#29 0x00007f9300c7a583 in QApplication::notify (this=0x7fffdcc47100, receiver=0x22fd050, e=0x7f92dc0013f0) at kernel/qapplication.cpp:4417
#30 0x00007f9306009006 in KApplication::notify (this=0x7fffdcc47100, receiver=0x22fd050, event=0x7f92dc0013f0) at ../../kdeui/kernel/kapplication.cpp:311
#31 0x00007f93018f432c in QCoreApplication::notifyInternal (this=0x7fffdcc47100, receiver=0x22fd050, event=0x7f92dc0013f0) at kernel/qcoreapplication.cpp:915
#32 0x00007f93018f810a in sendEvent (event=0x7f92dc0013f0, receiver=0x22fd050) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x20f31f0) at kernel/qcoreapplication.cpp:1539
#34 0x00007f9300d1e97a in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#35 QEventDispatcherX11::processEvents (this=0x20f4ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:75
#36 0x00007f93018f2e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f93018f30b7 in QEventLoop::exec (this=0x7fffdcc47080, flags=...) at kernel/qeventloop.cpp:204
#38 0x00007f93018f8407 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#39 0x00007f9306864cbb in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:537
#40 0x00007f930645e76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=3, ubp_av=0x7fffdcc477f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffdcc477e8) at libc-start.c:226
#41 0x0000000000400671 in _start ()

This bug may be a duplicate of or related to bug 299333.

Possible duplicates by query: bug 314730, bug 314673, bug 314196, bug 314018, bug 313416.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2013-03-07 18:43:29 UTC

*** This bug has been marked as a duplicate of bug 299333 ***