Bug 314730

Summary: kwin crashes when attempting to enable dual monitor setup
Product: [Plasma] kwin Reporter: sparhawk <kdebugs>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.9.4   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description sparhawk 2013-02-08 23:29:32 UTC
Application: kwin (4.9.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-23-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

I'm using a laptop and connected an external monitor to the mini DVI port. KDE lets me select it from the "HDMI1" settings. No idea why. Anyway, I attempted to position this external monitor "left of" the internal monitor. The screen flashes, and the setting reverts to "clone of" instead. Then kwin crashed. This was repeatable. However, when I attempted "right of", it worked. I then selected "left of" after that and it was all fine.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fce8d963780 (LWP 2155))]

Thread 2 (Thread 0x7fce7eb16700 (LWP 2162)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fce9d908cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fce9d908d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fce95a0ce9a in start_thread (arg=0x7fce7eb16700) at pthread_create.c:308
#4  0x00007fcea09dfcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fce8d963780 (LWP 2155)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0xbe83e0, rb=0xb7f890, unit=0) at brw_wm_surface_state.c:1109
#7  0x00007fce84c4eaa0 in brw_update_renderbuffer_surfaces (brw=0xbe83e0) at brw_wm_surface_state.c:1205
#8  0x00007fce84c38ae2 in brw_upload_state (brw=brw@entry=0xbe83e0) at brw_state_upload.c:498
#9  0x00007fce84c261d7 in brw_try_draw_prims (max_index=5, min_index=2438320648, ib=<optimized out>, nr_prims=<optimized out>, prim=0x7fff9155d1f0, arrays=<optimized out>, ctx=0xbe83e0) at brw_draw.c:493
#10 brw_draw_prims (ctx=0xbe83e0, prim=0x7fff9155d1f0, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:589
#11 0x00007fce847a5b54 in vbo_draw_arrays (ctx=0xbe83e0, mode=4, start=0, count=6, numInstances=1, baseInstance=<optimized out>) at ../../../../../src/mesa/vbo/vbo_exec_array.c:645
#12 0x00007fce9d35e89e in KWin::GLVertexBufferPrivate::corePainting (this=0xdea930, region=..., primitiveMode=4, hardwareClipping=<optimized out>) at ../../../kwin/libkwineffects/kwinglutils.cpp:1218
#13 0x00007fce9d35edbd in KWin::GLVertexBuffer::render (this=this@entry=0xde8af0, region=..., primitiveMode=primitiveMode@entry=4, hardwareClipping=hardwareClipping@entry=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1341
#14 0x00007fce9d35ee41 in KWin::GLVertexBuffer::render (this=0xde8af0, primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1333
#15 0x00007fcea0d6b7d1 in KWin::SceneOpenGL::paintBackground (this=this@entry=0xb561d0, region=...) at ../../kwin/scene_opengl.cpp:210
#16 0x00007fcea0d5b310 in KWin::Scene::paintSimpleScreen (this=this@entry=0xb561d0, orig_mask=orig_mask@entry=8, region=...) at ../../kwin/scene.cpp:323
#17 0x00007fcea0d58f82 in KWin::Scene::finalPaintScreen (this=0xb561d0, mask=8, region=..., data=...) at ../../kwin/scene.cpp:192
#18 0x00007fcea0d785c3 in KWin::EffectsHandlerImpl::paintScreen (this=0xeaaca0, mask=mask@entry=8, region=..., data=...) at ../../kwin/effects.cpp:246
#19 0x00007fce9f1cabf7 in KWin::Effect::paintScreen (this=this@entry=0x10f5510, mask=mask@entry=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#20 0x00007fcea0d7856b in KWin::EffectsHandlerImpl::paintScreen (this=0xeaaca0, mask=mask@entry=8, region=..., data=...) at ../../kwin/effects.cpp:243
#21 0x00007fce9f1cabf7 in KWin::Effect::paintScreen (this=this@entry=0xee46a0, mask=mask@entry=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#22 0x00007fcea0d7856b in KWin::EffectsHandlerImpl::paintScreen (this=0xeaaca0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:243
#23 0x00007fcea0d5a5cb in KWin::Scene::paintScreen (this=0xb561d0, mask=0x7fff9155d89c, region=0x7fff9155d940) at ../../kwin/scene.cpp:146
#24 0x00007fcea0d6f18d in KWin::SceneOpenGL::paint (this=0xb561d0, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:499
#25 0x00007fcea0d542c8 in KWin::Workspace::performCompositing (this=0xa75480) at ../../kwin/composite.cpp:443
#26 0x00007fce9c67026c in QObject::event (this=0xa75480, e=<optimized out>) at kernel/qobject.cpp:1157
#27 0x00007fce9ba02e9c in QApplicationPrivate::notify_helper (this=this@entry=0x9c60d0, receiver=receiver@entry=0xa75480, e=e@entry=0x7fff9155e020) at kernel/qapplication.cpp:4562
#28 0x00007fce9ba0730a in QApplication::notify (this=0x7fff9155e660, receiver=0xa75480, e=0x7fff9155e020) at kernel/qapplication.cpp:4423
#29 0x00007fcea04ce1d6 in KApplication::notify (this=0x7fff9155e660, receiver=0xa75480, event=0x7fff9155e020) at ../../kdeui/kernel/kapplication.cpp:311
#30 0x00007fce9c65b56e in QCoreApplication::notifyInternal (this=0x7fff9155e660, receiver=0xa75480, event=0x7fff9155e020) at kernel/qcoreapplication.cpp:915
#31 0x00007fce9c68c462 in sendEvent (event=0x7fff9155e020, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 QTimerInfoList::activateTimers (this=0x9c6c88) at kernel/qeventdispatcher_unix.cpp:611
#33 0x00007fce9c68c4c0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x959ad0) at kernel/qeventdispatcher_unix.cpp:868
#34 0x00007fce9c68c618 in QEventDispatcherUNIX::processEvents (this=0x959ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#35 0x00007fce9baa8a3f in QEventDispatcherX11::processEvents (this=0x959ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#36 0x00007fce9c65a2bf in QEventLoop::processEvents (this=this@entry=0x7fff9155e370, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007fce9c65a548 in QEventLoop::exec (this=0x7fff9155e370, flags=...) at kernel/qeventloop.cpp:204
#38 0x00007fce9c65f708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#39 0x00007fcea0d0ded4 in kdemain (argc=1, argv=0x7fff9155e7a8) at ../../kwin/main.cpp:545
#40 0x00007fcea090d76d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fff9155e7a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff9155e798) at libc-start.c:226
#41 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 314673, bug 314196, bug 314018, bug 313416, bug 313059.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2013-02-08 23:37:19 UTC

*** This bug has been marked as a duplicate of bug 299333 ***