Bug 314018

Summary: Crash during double click on third mouse button
Product: [Plasma] kwin Reporter: orchegion
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description orchegion 2013-01-28 04:37:21 UTC
Application: kwin (4.9.5)
KDE Platform Version: 4.9.5
Qt Version: 4.8.3
Operating System: Linux 3.5.0-22-lowlatency x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
i was zooming on pics in Gwenview, as soon i double clicked the third button (mouse-wheel button), the app crashed

No more things noticeable by my point of view

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4a5cc1b780 (LWP 1972))]

Thread 3 (Thread 0x7f4a33cec700 (LWP 2125)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4a5936bcd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f4a5936bd09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f4a5147fe9a in start_thread (arg=0x7f4a33cec700) at pthread_create.c:308
#4  0x00007f4a5c442cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4a431e9700 (LWP 7066)):
#0  0x00007f4a5c43c023 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f4a580ea023 in qt_safe_select (nfds=16, fdread=0x7f4a38000ac8, fdwrite=0x7f4a38000d60, fdexcept=0x7f4a38000ff8, orig_timeout=0x0) at kernel/qcore_unix.cpp:83
#2  0x00007f4a580ee9e4 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f4a38000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007f4a580ef572 in QEventDispatcherUNIX::processEvents (this=0x7f4a380008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007f4a580bd2bf in QEventLoop::processEvents (this=this@entry=0x7f4a431e8dc0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4a580bd548 in QEventLoop::exec (this=0x7f4a431e8dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4a57fbeb10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f4a5809f478 in QDnotifySignalThread::run (this=0x2d1cba0) at io/qfilesystemwatcher_dnotify.cpp:179
#8  0x00007f4a57fc1aec in QThreadPrivate::start (arg=0x2d1cba0) at thread/qthread_unix.cpp:338
#9  0x00007f4a5147fe9a in start_thread (arg=0x7f4a431e9700) at pthread_create.c:308
#10 0x00007f4a5c442cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4a5cc1b780 (LWP 1972)):
[KCrash Handler]
#6  gen7_update_renderbuffer_surface (brw=0x267ff90, rb=0x23a8760, unit=0) at gen7_wm_surface_state.c:471
#7  0x00007f4a41c4daa0 in brw_update_renderbuffer_surfaces (brw=0x267ff90) at brw_wm_surface_state.c:1205
#8  0x00007f4a41c37ae2 in brw_upload_state (brw=brw@entry=0x267ff90) at brw_state_upload.c:498
#9  0x00007f4a41c251d7 in brw_try_draw_prims (max_index=5, min_index=793573768, ib=<optimized out>, nr_prims=<optimized out>, prim=0x7fff2f4cf970, arrays=<optimized out>, ctx=0x267ff90) at brw_draw.c:493
#10 brw_draw_prims (ctx=0x267ff90, prim=0x7fff2f4cf970, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:589
#11 0x00007f4a41777b54 in vbo_draw_arrays (ctx=0x267ff90, mode=4, start=0, count=6, numInstances=1, baseInstance=<optimized out>) at ../../../../../src/mesa/vbo/vbo_exec_array.c:645
#12 0x00007f4a58dc176d in KWin::GLVertexBufferPrivate::fallbackPainting (this=0x23f26a0, region=..., primitiveMode=primitiveMode@entry=4, hardwareClipping=hardwareClipping@entry=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1255
#13 0x00007f4a58dc1d9d in KWin::GLVertexBuffer::render (this=this@entry=0x23023e0, region=..., primitiveMode=primitiveMode@entry=4, hardwareClipping=hardwareClipping@entry=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1343
#14 0x00007f4a58dc1e41 in KWin::GLVertexBuffer::render (this=0x23023e0, primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1333
#15 0x00007f4a5c7ce71d in KWin::SceneOpenGL::paintBackground (this=this@entry=0x230f440, region=...) at ../../kwin/scene_opengl.cpp:210
#16 0x00007f4a5c7be310 in KWin::Scene::paintSimpleScreen (this=this@entry=0x230f440, orig_mask=orig_mask@entry=8, region=...) at ../../kwin/scene.cpp:323
#17 0x00007f4a5c7bbf82 in KWin::Scene::finalPaintScreen (this=0x230f440, mask=8, region=..., data=...) at ../../kwin/scene.cpp:192
#18 0x00007f4a5c7db5c3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23da6a0, mask=mask@entry=8, region=..., data=...) at ../../kwin/effects.cpp:246
#19 0x00007f4a5ac2dbf7 in KWin::Effect::paintScreen (this=this@entry=0x2372340, mask=mask@entry=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#20 0x00007f4a5c7db56b in KWin::EffectsHandlerImpl::paintScreen (this=0x23da6a0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:243
#21 0x00007f4a5c7bd5cb in KWin::Scene::paintScreen (this=0x230f440, mask=0x7fff2f4cff9c, region=0x7fff2f4d0040) at ../../kwin/scene.cpp:146
#22 0x00007f4a5c7d218d in KWin::SceneOpenGL::paint (this=0x230f440, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:499
#23 0x00007f4a5c7b72c8 in KWin::Workspace::performCompositing (this=0x2270160) at ../../kwin/composite.cpp:443
#24 0x00007f4a580d326c in QObject::event (this=0x2270160, e=<optimized out>) at kernel/qobject.cpp:1157
#25 0x00007f4a57465e9c in QApplicationPrivate::notify_helper (this=this@entry=0x21353a0, receiver=receiver@entry=0x2270160, e=e@entry=0x7fff2f4d0720) at kernel/qapplication.cpp:4562
#26 0x00007f4a5746a30a in QApplication::notify (this=0x7fff2f4d0d60, receiver=0x2270160, e=0x7fff2f4d0720) at kernel/qapplication.cpp:4423
#27 0x00007f4a5bf311f6 in KApplication::notify (this=0x7fff2f4d0d60, receiver=0x2270160, event=0x7fff2f4d0720) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007f4a580be56e in QCoreApplication::notifyInternal (this=0x7fff2f4d0d60, receiver=0x2270160, event=0x7fff2f4d0720) at kernel/qcoreapplication.cpp:915
#29 0x00007f4a580ef462 in sendEvent (event=0x7fff2f4d0720, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#30 QTimerInfoList::activateTimers (this=0x2135f58) at kernel/qeventdispatcher_unix.cpp:611
#31 0x00007f4a580ef4c0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x20e3ad0) at kernel/qeventdispatcher_unix.cpp:868
#32 0x00007f4a580ef618 in QEventDispatcherUNIX::processEvents (this=0x20e3ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#33 0x00007f4a5750ba3f in QEventDispatcherX11::processEvents (this=0x20e3ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#34 0x00007f4a580bd2bf in QEventLoop::processEvents (this=this@entry=0x7fff2f4d0a70, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f4a580bd548 in QEventLoop::exec (this=0x7fff2f4d0a70, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007f4a580c2708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#37 0x00007f4a5c770ed4 in kdemain (argc=1, argv=0x7fff2f4d0ea8) at ../../kwin/main.cpp:545
#38 0x00007f4a5c37076d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fff2f4d0ea8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff2f4d0e98) at libc-start.c:226
#39 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 313416.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2013-01-28 06:54:02 UTC
Driver bug.

*** This bug has been marked as a duplicate of bug 299333 ***