Bug 313416

Summary: Kwin crashes while full screen on flash
Product: [Plasma] kwin Reporter: Frantzy Jean Philippe <hpfrantzy5>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.9.4   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Frantzy Jean Philippe 2013-01-17 19:22:38 UTC
Application: kwin (4.9.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
Every time I watch a flash video and increase the volume, the screen flickers and kwin crashes. I am able to duplicate this almost every time. I may sometime prevent the crash by only increasing the volume slightly seconds at a time.

*** Kwin does not actually crash *** or it may have restarted, if anything, this bug is annoying.
A fresh install of Kubuntu. I reinstalled and the same thing happened.
This happens on a google chrome browser, not chromium, but did not happen before chrome's most recent upgrade.

- Unusual behavior I noticed:
The screen flickers

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8d34e45780 (LWP 23275))]

Thread 2 (Thread 0x7f8d25eee700 (LWP 23282)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8d44deacd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f8d44dead09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f8d3ceeee9a in start_thread (arg=0x7f8d25eee700) at pthread_create.c:308
#4  0x00007f8d47ec1cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8d34e45780 (LWP 23275)):
[KCrash Handler]
#6  gen7_update_renderbuffer_surface (brw=0x9f0b60, rb=0x8e1780, unit=0) at gen7_wm_surface_state.c:471
#7  0x00007f8d27775aa0 in brw_update_renderbuffer_surfaces (brw=0x9f0b60) at brw_wm_surface_state.c:1205
#8  0x00007f8d2775fae2 in brw_upload_state (brw=brw@entry=0x9f0b60) at brw_state_upload.c:498
#9  0x00007f8d2774d1d7 in brw_try_draw_prims (max_index=5, min_index=2730540904, ib=<optimized out>, nr_prims=<optimized out>, prim=0x7fffa2c0bf50, arrays=<optimized out>, ctx=0x9f0b60) at brw_draw.c:493
#10 brw_draw_prims (ctx=0x9f0b60, prim=0x7fffa2c0bf50, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:589
#11 0x00007f8d272ccb54 in vbo_draw_arrays (ctx=0x9f0b60, mode=4, start=0, count=6, numInstances=1, baseInstance=<optimized out>) at ../../../../../src/mesa/vbo/vbo_exec_array.c:645
#12 0x00007f8d4484089e in KWin::GLVertexBufferPrivate::corePainting (this=0xbf3f90, region=..., primitiveMode=4, hardwareClipping=<optimized out>) at ../../../kwin/libkwineffects/kwinglutils.cpp:1218
#13 0x00007f8d44840dbd in KWin::GLVertexBuffer::render (this=0xbf20c0, region=..., primitiveMode=4, hardwareClipping=<optimized out>) at ../../../kwin/libkwineffects/kwinglutils.cpp:1341
#14 0x00007f8d48249b2e in renderQuads (hardwareClipping=false, normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at ../../kwin/scene_opengl.cpp:795
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>, hardwareClipping=false) at ../../kwin/scene_opengl.cpp:774
#16 0x00007f8d4824ff8b in KWin::SceneOpenGL::Window::performPaint (this=0xfd6440, mask=9, region=..., data=...) at ../../kwin/scene_opengl.cpp:593
#17 0x00007f8d4823bbc6 in KWin::Scene::finalDrawWindow (this=<optimized out>, w=0xda43b0, mask=9, region=..., data=...) at ../../kwin/scene.cpp:454
#18 0x00007f8d4825a46a in KWin::EffectsHandlerImpl::drawWindow (this=0xcbc940, w=w@entry=0xda43b0, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:310
#19 0x00007f8d4823b03a in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0xda43b0, mask=9, region=..., data=...) at ../../kwin/scene.cpp:439
#20 0x00007f8d4825a1da in KWin::EffectsHandlerImpl::paintWindow (this=0xcbc940, w=0xda43b0, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:273
#21 0x00007f8d4823de0d in KWin::Scene::paintWindow (this=<optimized out>, w=0xfd6440, mask=9, region=..., quads=...) at ../../kwin/scene.cpp:348
#22 0x00007f8d4823d16f in KWin::Scene::paintSimpleScreen (this=this@entry=0x8d3590, orig_mask=orig_mask@entry=8, region=...) at ../../kwin/scene.cpp:334
#23 0x00007f8d4823af82 in KWin::Scene::finalPaintScreen (this=0x8d3590, mask=8, region=..., data=...) at ../../kwin/scene.cpp:192
#24 0x00007f8d4825a5c3 in KWin::EffectsHandlerImpl::paintScreen (this=0xcbc940, mask=8, region=..., data=...) at ../../kwin/effects.cpp:246
#25 0x00007f8d4823c5cb in KWin::Scene::paintScreen (this=0x8d3590, mask=0x7fffa2c0cccc, region=0x7fffa2c0cd70) at ../../kwin/scene.cpp:146
#26 0x00007f8d4825118d in KWin::SceneOpenGL::paint (this=0x8d3590, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:499
#27 0x00007f8d482362c8 in KWin::Workspace::performCompositing (this=0x852a20) at ../../kwin/composite.cpp:443
#28 0x00007f8d43b5226c in QObject::event (this=0x852a20, e=<optimized out>) at kernel/qobject.cpp:1157
#29 0x00007f8d42ee4e9c in QApplicationPrivate::notify_helper (this=this@entry=0x6cfb50, receiver=receiver@entry=0x852a20, e=e@entry=0x7fffa2c0d450) at kernel/qapplication.cpp:4562
#30 0x00007f8d42ee930a in QApplication::notify (this=0x7fffa2c0da90, receiver=0x852a20, e=0x7fffa2c0d450) at kernel/qapplication.cpp:4423
#31 0x00007f8d479b01d6 in KApplication::notify (this=0x7fffa2c0da90, receiver=0x852a20, event=0x7fffa2c0d450) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007f8d43b3d56e in QCoreApplication::notifyInternal (this=0x7fffa2c0da90, receiver=0x852a20, event=0x7fffa2c0d450) at kernel/qcoreapplication.cpp:915
#33 0x00007f8d43b6e462 in sendEvent (event=0x7fffa2c0d450, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QTimerInfoList::activateTimers (this=0x6d0698) at kernel/qeventdispatcher_unix.cpp:611
#35 0x00007f8d43b6e4c0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x677ad0) at kernel/qeventdispatcher_unix.cpp:868
#36 0x00007f8d43b6e618 in QEventDispatcherUNIX::processEvents (this=0x677ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#37 0x00007f8d42f8aa3f in QEventDispatcherX11::processEvents (this=0x677ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#38 0x00007f8d43b3c2bf in QEventLoop::processEvents (this=this@entry=0x7fffa2c0d7a0, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007f8d43b3c548 in QEventLoop::exec (this=0x7fffa2c0d7a0, flags=...) at kernel/qeventloop.cpp:204
#40 0x00007f8d43b41708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#41 0x00007f8d481efed4 in kdemain (argc=3, argv=0x7fffa2c0dbd8) at ../../kwin/main.cpp:545
#42 0x00007f8d47def76d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=3, ubp_av=0x7fffa2c0dbd8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa2c0dbc8) at libc-start.c:226
#43 0x00000000004006d1 in _start ()

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2013-01-17 19:26:41 UTC
Driver bug, please attach the output of "qdbus org.kde.KWin /KWin supportInformation" nevertheless (includes GPU and settings, may point a way to avoid the crashy driver constellation)

*** This bug has been marked as a duplicate of bug 299333 ***