Bug 312905

Summary: Opus files metadata/collection support
Product: amarok Reporter: Mister Ypsilon <mrypsilons>
Component: generalAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED FIXED    
Severity: wishlist CC: bugs.kde.org, martin, mrypsilons
Priority: NOR    
Version: 2.7.0   
Target Milestone: 2.8   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 2.8

Description Mister Ypsilon 2013-01-08 20:16:19 UTC
Amarok can neither import Ogg-Opus files into the collection nor read their metadata if you directly add the file to a playlist.

Reproducible: Always

Steps to Reproduce:
1. Put an opus file into the collection folder (.oga / .opus / .ogg)
2. refresh collection
3. open the file directly
Actual Results:  
1-2: Amarok doesn't add the opus files to the collection
3: Amarok isn't able to read the metadata of the file

Expected Results:  
1-2: Opus files should added to the collection with metadata
3: Metadata should be determined

Amarok/Phonon with GStreamer backend play the file itself fine. It's only the metadata which is not detected.
Comment 1 Mister Ypsilon 2013-02-09 18:30:10 UTC
Just tried it with a newer taglib supporting Ogg-Opus tags. Still doesn't work in amarok.
Comment 2 Myriam Schweingruber 2013-02-09 18:35:51 UTC
Did you upgrade your Amarok to 2.7?
Comment 3 Mister Ypsilon 2013-02-10 10:56:42 UTC
Just updraded to 2.7, still doesn't work.
Comment 4 Myriam Schweingruber 2013-02-10 14:07:21 UTC
Thank you for the feedback.
Comment 5 Martin Brodbeck 2013-02-13 19:12:50 UTC
There is a pending patch on the reviewboard which addresses the opus metadata support. I think it might make it in HEAD really soon.
Comment 6 Mister Ypsilon 2013-02-15 12:25:15 UTC
Wow, thanks for the patch, works very well. I would only add ".oga" as a file suffix, I had to rename my whole music collection ;)
Comment 7 Matěj Laitl 2013-02-18 16:09:20 UTC
Git commit abd5c3ff4051c77075b39f827d58045f100a5be3 by Matěj Laitl, on behalf of Martin Brodbeck.
Committed on 12/02/2013 at 17:07.
Pushed by laitl into branch 'master'.

Add support for Opus files if compiled against TagLib > 1.8

FEATURES:
 * Added support for files in Opus codec if Amarok is compiled against recent
   enough TagLib (post 1.8). patch by Martin Brodbeck.
FIXED-IN: 2.8
REVIEW: 108542
DIGEST: Amarok now supports Opus codec with recent TagLib

M  +4    -0    CMakeLists.txt
M  +2    -0    ChangeLog
M  +1    -0    README
M  +2    -1    shared/FileType.cpp
M  +2    -1    shared/FileType.h
M  +17   -0    shared/FileTypeResolver.cpp
M  +3    -0    shared/config.h.cmake
M  +10   -0    shared/tag_helpers/TagHelper.cpp

http://commits.kde.org/amarok/abd5c3ff4051c77075b39f827d58045f100a5be3
Comment 8 Matěj Laitl 2014-08-11 22:40:00 UTC
*** Bug 338204 has been marked as a duplicate of this bug. ***