Bug 311226

Summary: Partitions that are not mounted sould be mounted automatically when you open them in a new tab
Product: dolphin Reporter: J.A. Moray <moray33>
Component: panels: placesAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: emmanuelpescosta099, kenny
Priority: NOR    
Version: 16.12.2   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In: 4.13.1

Description J.A. Moray 2012-12-05 22:18:53 UTC
When I do right click (in the places panel) / open in a new tab in a partition that are not mounted by default, it opens a new tab but the partition is not mounted automatically, it gives me this message: <<The location is empty>>.

Reproducible: Always
Comment 1 Emmanuel Pescosta 2012-12-12 16:18:53 UTC
I can reproduce it sometimes.

1. I plug in my usb stick
2. I open Dolphin
3. I open the context menu for the usb stick (right click) -> Open usb stick in a new tab

Most of the time (about 95%) the usb drive is successfully mounted, but sometimes (about 5%) the message "The location is empty" appears and nothing else happens.

When this strange bug appears, then I can restart Dolphin a few times and I can reproduce the same bug every time, but after 4 or more restarts, Dolphin can mount the usb drive without problems.

I will try to get some debug information to fix this bug ....
Comment 2 Frank Reininghaus 2014-04-16 20:21:35 UTC
*** Bug 333515 has been marked as a duplicate of this bug. ***
Comment 3 Emmanuel Pescosta 2014-04-26 11:09:23 UTC
Git commit bd4bc61f79e189a5b50056333eb737d4e1a0290c by Emmanuel Pescosta.
Committed on 24/04/2014 at 19:44.
Pushed by emmanuelp into branch 'KDE/4.13'.

Mount partitions when you open them in a new tab.

Instead of just emitting the slotItemMiddleClicked signal in
PlacesPanel::slotItemContextMenuRequested we now use triggerItem with
Qt::MiddleButton, which does set up the storage first and emit
the slotItemMiddleClicked signal afterwards.
FIXED-IN: 4.13.1
REVIEW: 117755

M  +3    -2    dolphin/src/panels/places/placespanel.cpp

http://commits.kde.org/kde-baseapps/bd4bc61f79e189a5b50056333eb737d4e1a0290c