Bug 304907

Summary: The grub selections in the shutdown/reboot popup are not clickable
Product: ksmserver Reporter: Mathias Homann <Mathias.Homann>
Component: uiAssignee: Lamarque V. Souza <lamarque>
Status: RESOLVED FIXED    
Severity: normal CC: cyberbeat, dlwillia, konstantinos.smanis, nico.kruber, wstephenson
Priority: NOR    
Version: 0.4   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 4.9.1

Description Mathias Homann 2012-08-10 05:34:32 UTC
you cannot choose the grub entry after long 
pressing the "restart computer" button in the shutdown interface. It is 
possible to select them but not to click on them or hit Enter.

Reproducible: Always

Steps to Reproduce:
1. have a computer with more than one choice of OS, with a grub menu to select from them
2. reboot KDE from a logged-in session; click and hold the "Reboot computer" button until the grub choices appear
3. observe that the various grub choices are not actually selectable
Actual Results:  
the grub choices are not clickable or selectable with <Enter>

Expected Results:  
It used to be possible to select one of the choices to directly boot to that grub entry

Workaround: log out normally, then reboot to the grub line of choice from KDM, works as expected
Comment 1 Nico Kruber 2012-08-10 08:11:31 UTC
same here
as a side note: in RC2, when the mouse was hovering an item it was not shown as "selected" but clicking on it worked
Comment 2 Lamarque V. Souza 2012-08-11 00:12:39 UTC
Git commit d3a824024c30cc4d1dee20e150fd3446d75642c1 by Lamarque V. Souza.
Committed on 11/08/2012 at 02:09.
Pushed by lvsouza into branch 'KDE/4.9'.

Fix problem with menus not clickable in QML shutdown dialog.
FIXED-IN: 4.9.1
(cherry picked from commit 14b0486208ac9f362d98d7948270d2b6295e1575)

M  +2    -0    ksmserver/themes/default/main.qml

http://commits.kde.org/kde-workspace/d3a824024c30cc4d1dee20e150fd3446d75642c1
Comment 3 Lamarque V. Souza 2012-08-11 00:12:40 UTC
Git commit 14b0486208ac9f362d98d7948270d2b6295e1575 by Lamarque V. Souza.
Committed on 11/08/2012 at 02:09.
Pushed by lvsouza into branch 'master'.

Fix problem with menus not clickable in QML shutdown dialog.
FIXED-IN: 4.9.1

M  +2    -0    ksmserver/themes/default/main.qml

http://commits.kde.org/kde-workspace/14b0486208ac9f362d98d7948270d2b6295e1575
Comment 4 Lamarque V. Souza 2012-08-13 20:55:24 UTC
*** Bug 305053 has been marked as a duplicate of this bug. ***
Comment 5 Nico Kruber 2012-08-16 12:50:56 UTC
actually, this bug should be extended to the other options in the shutdown dialogue, i.e. holding the "shutdown" option shows the currently unclickable "suspend-to-ram" and "suspend-to-disk" items

additionally, pre4.9 you cuold hold down the shutdown/reboot button, wait for the dropdown dialogue and release the mouse button on the action you wanted to be executed - this is now not possible anymore...
Comment 6 Konstantinos Smanis 2012-08-17 07:06:07 UTC
"Turn Off Computer > Suspend to RAM" still not working here.
Comment 7 Lamarque V. Souza 2012-08-17 13:11:48 UTC
Git commit 975e27f90dacb3c759a74d72dfe3911309a062e8 by Lamarque V. Souza.
Committed on 17/08/2012 at 15:09.
Pushed by lvsouza into branch 'KDE/4.9'.

Fix menu items not clickable problem in QML shutdown dialog.
FIXED-IN: 4.9.1

M  +3    -3    ksmserver/themes/default/main.qml

http://commits.kde.org/kde-workspace/975e27f90dacb3c759a74d72dfe3911309a062e8
Comment 8 Lamarque V. Souza 2012-08-17 13:11:49 UTC
Git commit 2519ac36f9218eb267e76d345172dc300c16b019 by Lamarque V. Souza.
Committed on 17/08/2012 at 15:09.
Pushed by lvsouza into branch 'master'.

Fix menu items not clickable problem in QML shutdown dialog.
FIXED-IN: 4.9.1

M  +3    -3    ksmserver/themes/default/main.qml

http://commits.kde.org/kde-workspace/2519ac36f9218eb267e76d345172dc300c16b019
Comment 9 Lamarque V. Souza 2012-08-17 13:12:43 UTC
(In reply to comment #5)
> additionally, pre4.9 you cuold hold down the shutdown/reboot button, wait
> for the dropdown dialogue and release the mouse button on the action you
> wanted to be executed - this is now not possible anymore...

This seems not possible in QML.
Comment 10 Nico Kruber 2012-08-17 16:46:16 UTC
(In reply to comment #9)
> (In reply to comment #5)
> > additionally, pre4.9 you cuold hold down the shutdown/reboot button, wait
> > for the dropdown dialogue and release the mouse button on the action you
> > wanted to be executed - this is now not possible anymore...
> 
> This seems not possible in QML.

there is no "on release" handler? too bad - this means, one click more for now :(
Comment 11 Lamarque V. Souza 2012-08-17 22:22:18 UTC
there is an onReleased slot but the onPressed event that has to preceed it is from a different window (the shutdown dialog window) not the menu window, so the onReleased is never emited by the menu item.
Comment 12 Nico Kruber 2012-08-18 09:00:32 UTC
hmm, ok - I guess, we'll have to wait for new QML versions to solve that one...
What about including the menu items, that currently only show after long-pressing the button, into the shutdown dialogue.
For restart, there will probably be too many entries since the user can add as many grub entries as he wants. But for shutdown, i.e. "suspend-to-ram", "suspend-to-disk", there are only two and the use of them is not so uncommon. I'd therefore propose to promote them to the shutdown dialogue itself. Visually, they could appear as sub-items of "shutdown", i.e. a little bit shifted to the right and smaller than the big ones.

Alternatively, instead of long-pressing, there could be an arrow to the right side of the "shutdown"/"restart" buttons which immediately shows the drop-down options. Accessing them this way would be much faster.
Comment 13 Lamarque V. Souza 2012-08-18 17:08:31 UTC
I already tested that before doing the current implementation and it was quite ugly. The fact that they are not so common is probably the reason they were hidden in a submenu in the first place.
Comment 14 Lamarque V. Souza 2012-08-18 17:09:23 UTC
Git commit a39dc6dcb0653ea9a039e380327813701815bed4 by Lamarque V. Souza.
Committed on 18/08/2012 at 19:06.
Pushed by lvsouza into branch 'KDE/4.9'.

Show menu instead of triggering default action when clicking on
KSMButton.qml's icon in shutdown dialog.

M  +14   -0    ksmserver/themes/default/KSMButton.qml

http://commits.kde.org/kde-workspace/a39dc6dcb0653ea9a039e380327813701815bed4
Comment 15 Lamarque V. Souza 2012-08-18 17:09:24 UTC
Git commit d2def80fc4f40de0d7eef9a65682ce9e8d208a0c by Lamarque V. Souza.
Committed on 18/08/2012 at 19:06.
Pushed by lvsouza into branch 'master'.

Show menu instead of triggering default action when clicking on
KSMButton.qml's icon in shutdown dialog.

M  +14   -0    ksmserver/themes/default/KSMButton.qml

http://commits.kde.org/kde-workspace/d2def80fc4f40de0d7eef9a65682ce9e8d208a0c
Comment 16 H.H. 2012-09-17 13:10:13 UTC
I have stumbled over this, too:

>additionally, pre4.9 you cuold hold down the shutdown/reboot button, wait for the dropdown dialogue and release the mouse button on the action you wanted to be executed - this is now not possible anymore...

will that be fixed in 4.9.2?

For now there are two problems:

a) it is not possible to click on the little arrow to show the submenu, the shutdown-action is executed (instead of the wanted sleep option)

b) even if I hold the button and wait, the submenu is shown , but I cannot select any entries: i have to release and only then are able to choose. 

I think you should not wait for qt fixing this but revert to the previous dialog.
Comment 17 Lamarque V. Souza 2012-09-17 15:39:36 UTC
(In reply to comment #16)
> I have stumbled over this, too:
> 
> >additionally, pre4.9 you cuold hold down the shutdown/reboot button, wait for the dropdown dialogue and release the mouse button on the action you wanted to be executed - this is now not possible anymore...
> 
> will that be fixed in 4.9.2?

No, it will not because it seems QML does not support that.
 
> For now there are two problems:
> 
> a) it is not possible to click on the little arrow to show the submenu, the
> shutdown-action is executed (instead of the wanted sleep option)

Are you refering to the white arrow pointing down that indicates that the button contains a context menu? I haver said that clicking on it would trigger a menu and it is also too small to click. In 4.9.1 you can click on the button's icon to trigger the context menu.

> b) even if I hold the button and wait, the submenu is shown , but I cannot
> select any entries: i have to release and only then are able to choose. 

As I said this seems to be a limitation in QML. Unless someone tells me how to implement this I do not see this working anymore.
 
> I think you should not wait for qt fixing this but revert to the previous
> dialog.

Sorry, this is not going to happen.