Bug 304144

Summary: KMix does not distinguish separate channels on one volume control
Product: kmix Reporter: Pavel Baranchikov <maednoldor>
Component: generalAssignee: Christian Esken <esken>
Status: RESOLVED FIXED    
Severity: normal    
Priority: NOR    
Version: 3.0   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: amixer output for the sound card
Splitting channels in the Sound Menu

Description Pavel Baranchikov 2012-07-27 15:05:08 UTC
I have Asus Xonar DS sound card, having multiple channels on one volume control. amixer output this the following way
-----8<---------------------------------------
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right - Rear Left - Rear Right - Front Center - Woofer - Side Left - Side Right
  Limits: Playback 135 - 255
  Mono:
  Front Left: Playback 207 [60%] [-24.00dB] [on]
  Front Right: Playback 207 [60%] [-24.00dB] [on]
  Rear Left: Playback 207 [60%] [-24.00dB] [on]
  Rear Right: Playback 207 [60%] [-24.00dB] [on]
  Front Center: Playback 207 [60%] [-24.00dB] [on]
  Woofer: Playback 207 [60%] [-24.00dB] [on]
  Side Left: Playback 207 [60%] [-24.00dB] [on]
  Side Right: Playback 207 [60%] [-24.00dB] [on]
-----8<---------------------------------------
KMix shows me all the channels as one "Master" control with one single slider

Reproducible: Always

Actual Results:  
I cannot change volume separately for front and rear channels, whilst I can do the job with alsamixer or amixer.

Expected Results:  
I think KMix should have sliders, orginized, similar to alsamixer: Center, Front, Rear, Woofer, Side.
Comment 1 Christian Esken 2012-08-04 14:55:24 UTC
If required you can split the channels on one volume control (use the context menu on the slider). It is possble on on sliders (perhaps with the exception of the Tray control). Please check and reprot back.
Comment 2 Pavel Baranchikov 2012-08-06 09:05:00 UTC
I can do the way you mentioned. But I still have the only "Master" channel in "select main channel" dialog - without amy splitting
Comment 3 Christian Esken 2012-08-14 07:17:16 UTC
Well, if you can't split then there is nothing to split. Are you sure your master has more channels? If yes, please post the "amixer" output for the affected soundcard (amixer -c 0, amixer -c 1, ...)
Comment 4 Pavel Baranchikov 2012-08-14 11:16:16 UTC
Created attachment 73158 [details]
amixer output for the sound card

I can split the Master channel in the KMix dialog, but I think I should be able to select a splitted channel as a main channel in my KMix plasmoid.
Comment 5 Christian Esken 2012-09-20 12:16:07 UTC
There is no KMix Plasmoid, so you cannot set it. Do you mean the popup from the Tray? Please post screenshot.
Comment 6 Christian Esken 2013-12-18 14:02:17 UTC
One can definitely show the separate channels, since some time also finely labeled: http://kmix5.wordpress.com/2011/07/21/enhanced-multichannel-card-support/

Traditionally it is not in the Sound Menu, but the bug reporter did not answer the question whetehr it is about the tray. Newer versions also allow to show it in the tray (not persistent yet, but possible), see attached screenshot.

Thus marking as fixed.
Comment 7 Christian Esken 2013-12-18 14:02:53 UTC
Created attachment 84158 [details]
Splitting channels in the Sound Menu
Comment 8 Christian Esken 2013-12-20 10:24:22 UTC
Git commit 0f7a603e1d327f76dbd6a62d08315b1956794d42 by Christian Esken.
Committed on 20/12/2013 at 10:17.
Pushed by esken into branch 'master'.

Configuration menu is now using Tabs to provide a more standard,
  convenient and pleasing layout
 Sound Menu: Play button reflects playback status and shows either
  "Play" or "Pause"
 Bugfixes and Features (CCBUGS, as most bugs are already closed). Hint: Some
bugs might have actually been alreay fixed ibn KDE4.11 or KDE4.12.

Bug ID	Severity	Summary
Related: bug 317926, bug 20, bug 315383, bug 299477, bug 256854, bug 296951, bug 303608, bug 214854, bug 319600
applet
volume control
position.

M  +9    -5    CMakeLists.txt
M  +41   -20   ChangeLog
M  +5    -1    apps/KMixApp.cpp
M  +167  -238  apps/kmix.cpp
M  +8    -13   apps/kmix.h
M  +3    -0    apps/kmixctrl.cpp
M  +3    -0    apps/kmixd.cpp
M  +18   -12   backends/mixer_backend.cpp
M  +1    -0    backends/mixer_backend.h
M  +229  -150  backends/mixer_mpris2.cpp
M  +23   -6    backends/mixer_mpris2.h
M  +8    -2    backends/mixer_oss.cpp
M  +1    -1    backends/mixer_pulse.cpp
M  +9    -9    core/ControlManager.cpp
M  +102  -15   core/GlobalConfig.cpp
M  +105  -47   core/GlobalConfig.h
M  +65   -31   core/kmixdevicemanager.cpp
M  +9    -4    core/mixdevice.cpp
M  +4    -12   core/mixdevice.h
M  +6    -4    core/mixer.cpp
M  +16   -10   core/mixertoolbox.cpp
M  +1    -1    core/version.h
M  +17   -3    core/volume.cpp
M  +9    -8    core/volume.h
M  +19   -6    gui/dialogchoosebackends.cpp
M  +1    -1    gui/dialogchoosebackends.h
M  +9    -2    gui/dialogviewconfiguration.cpp
M  +37   -10   gui/guiprofile.cpp
M  +27   -24   gui/guiprofile.h
M  +93   -118  gui/kmixdockwidget.cpp
M  +3    -4    gui/kmixdockwidget.h
M  +13   -11   gui/kmixerwidget.cpp
M  +296  -91   gui/kmixprefdlg.cpp
M  +82   -32   gui/kmixprefdlg.h
M  +87   -38   gui/mdwslider.cpp
M  +4    -2    gui/mdwslider.h
M  +69   -42   gui/viewbase.cpp
M  +1    -0    gui/viewbase.h
M  +25   -30   gui/viewdockareapopup.cpp
M  +1    -1    gui/viewdockareapopup.h
M  +4    -4    gui/viewsliders.cpp
M  +1    -1    gui/volumesliderextradata.h

http://commits.kde.org/kmix/0f7a603e1d327f76dbd6a62d08315b1956794d42