Bug 303509

Summary: crash when using bleachbit
Product: kwin Reporter: Moh <openweb>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Moh 2012-07-14 01:26:58 UTC
Application: kwin (4.8.4 (4.8.4))
KDE Platform Version: 4.8.4 (4.8.4) (Compiled from sources)
Qt Version: 4.8.2
Operating System: Linux 3.4.4-5.fc17.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

- Unusual behavior I noticed:
just lauching Bleachbit to clean my system as usual

that s it.but everytime it crash.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Bus error
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7ffda9346880 (LWP 930))]

Thread 2 (Thread 0x7ffd991c1700 (LWP 935)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x0000003924d84ac7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x39250919a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x0000003924d84af9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x0000003a28e07d14 in start_thread (arg=0x7ffd991c1700) at pthread_create.c:309
#4  0x0000003a28af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7ffda9346880 (LWP 930)):
[KCrash Handler]
#6  0x0000003911031e7d in lock (this=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff5df1df30) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/kshareddatacache.cpp:1255
#8  0x00000039110324d0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff5df1df30, _d=<optimized out>) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/kshareddatacache.cpp:1278
#9  0x000000391102a52e in KSharedDataCache::find (this=0x227fe20, key=..., destination=0x7fff5df1dfa0) at /usr/src/debug/kdelibs-4.8.4/kdecore/util/kshareddatacache.cpp:1630
#10 0x0000003913bf7b29 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x22a02e0, key=..., data=..., path=...) at /usr/src/debug/kdelibs-4.8.4/kdeui/icons/kiconloader.cpp:861
#11 0x0000003913bfc19e in KIconLoader::loadIcon (this=0x2269d80, _name=..., group=KIconLoader::Small, size=0, state=0, overlays=..., path_store=0x0, canReturnNull=true) at /usr/src/debug/kdelibs-4.8.4/kdeui/icons/kiconloader.cpp:1225
#12 0x0000003913d6d329 in KWindowSystem::icon (win=<optimized out>, width=32, height=32, scale=true, flags=12) at /usr/src/debug/kdelibs-4.8.4/kdeui/windowmanagement/kwindowsystem_x11.cpp:688
#13 0x000000391de4d7a6 in KWin::Client::getIcons (this=0x27aa5e0) at /usr/src/debug/kde-workspace-4.8.4/kwin/client.cpp:2066
#14 0x000000391de78b94 in KWin::Client::manage (this=0x27aa5e0, w=<optimized out>, isMapped=false) at /usr/src/debug/kde-workspace-4.8.4/kwin/manage.cpp:135
#15 0x000000391de424c2 in KWin::Workspace::createClient (this=0x228ec70, w=50331978, is_mapped=false) at /usr/src/debug/kde-workspace-4.8.4/kwin/workspace.cpp:569
#16 0x000000391de6a970 in KWin::Workspace::workspaceEvent (this=0x228ec70, e=0x7fff5df1ee80) at /usr/src/debug/kde-workspace-4.8.4/kwin/events.cpp:358
#17 0x000000391de5cdb8 in KWin::Application::x11EventFilter (this=0x7fff5df1f3e0, e=0x7fff5df1ee80) at /usr/src/debug/kde-workspace-4.8.4/kwin/main.cpp:359
#18 0x0000003911e3663c in qt_x11EventFilter (ev=0x7fff5df1ee80) at kernel/qapplication_x11.cpp:435
#19 qt_x11EventFilter (ev=0x7fff5df1ee80) at kernel/qapplication_x11.cpp:423
#20 0x0000003911e43beb in QApplication::x11ProcessEvent (this=0x7fff5df1f3e0, event=0x7fff5df1ee80) at kernel/qapplication_x11.cpp:3358
#21 0x0000003911e6b0a9 in QEventDispatcherX11::processEvents (this=0x2158740, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#22 0x000000390f57513f in QEventLoop::processEvents (this=this@entry=0x7fff5df1f0f0, flags=...) at kernel/qeventloop.cpp:149
#23 0x000000390f5753c8 in QEventLoop::exec (this=0x7fff5df1f0f0, flags=...) at kernel/qeventloop.cpp:204
#24 0x000000390f57a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#25 0x000000391de5f4ee in kdemain (argc=3, argv=0x7fff5df1f568) at /usr/src/debug/kde-workspace-4.8.4/kwin/main.cpp:541
#26 0x0000003a28a21735 in __libc_start_main (main=0x4008c0 <main(int, char**)>, argc=3, ubp_av=0x7fff5df1f568, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff5df1f558) at libc-start.c:226
#27 0x00000000004008f1 in _start ()

Possible duplicates by query: bug 303310, bug 303308, bug 284770.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-07-14 07:41:30 UTC
Bleachbit invalidates shared memory.
Google for it, there are tons of bug reports about this.

-> Don't use bleachbit (it's snake oil anyway, see eg. http://lwn.net/Articles/313679/) or at least do not let it override files (just deleting them is ok, but the other way corrupts random other applications if done on the wrong files)

*** This bug has been marked as a duplicate of bug 254741 ***