Bug 303123

Summary: Alt-Shift-F12 crashes desktop
Product: plasma4 Reporter: Alex Williams <alex.williams>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alex Williams 2012-07-06 20:32:57 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.0.0-22-generic i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
What I was doing when the application crashed:
Attempting to use Alt-shift-f12 to shut down "desktop effects" which seemed to be slowing the system to a crawl.

- Unusual behavior I noticed:
Very slow refresh rates on display - generally very slow responses overall

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76f8740 (LWP 2395))]

Thread 4 (Thread 0xad1ffb40 (LWP 2398)):
#0  0x0825bdcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x06abb315 in do_gettime (frac=0xad1fefb0, sec=0xad1fefa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x06ba5226 in QTimerInfoList::updateCurrentTime (this=0xac802074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x06ba557a in QTimerInfoList::timerWait (this=0xac802074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0x06ba3e23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xad1ff0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x06ba3ebd in timerSourcePrepare (source=0xac802040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x025d0872 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x025d0faf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x025d1201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x06ba48e7 in QEventDispatcherGlib::processEvents (this=0xac800468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x06b7050d in QEventLoop::processEvents (this=0xad1ff240, flags=...) at kernel/qeventloop.cpp:149
#12 0x06b707a9 in QEventLoop::exec (this=0xad1ff240, flags=...) at kernel/qeventloop.cpp:204
#13 0x06a5994c in QThread::exec (this=0x883e8a8) at thread/qthread.cpp:501
#14 0x06b4db5d in QInotifyFileSystemWatcherEngine::run (this=0x883e8a8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x06a5cde0 in QThreadPrivate::start (arg=0x883e8a8) at thread/qthread_unix.cpp:298
#16 0x02575d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x001faace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa9c33b40 (LWP 2401)):
#0  postEventSourcePrepare (s=0xac802c18, timeout=0x0) at kernel/qeventdispatcher_glib.cpp:262
#1  0x06ba40c7 in postEventSourceCheck (source=0xac802c18) at kernel/qeventdispatcher_glib.cpp:272
#2  0x025d0b7b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x025d1042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x025d1201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x06ba48e7 in QEventDispatcherGlib::processEvents (this=0xac8022d8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x06b7050d in QEventLoop::processEvents (this=0xa9c33240, flags=...) at kernel/qeventloop.cpp:149
#7  0x06b707a9 in QEventLoop::exec (this=0xa9c33240, flags=...) at kernel/qeventloop.cpp:204
#8  0x06a5994c in QThread::exec (this=0x9e28ce0) at thread/qthread.cpp:501
#9  0x06b4db5d in QInotifyFileSystemWatcherEngine::run (this=0x9e28ce0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x06a5cde0 in QThreadPrivate::start (arg=0x9e28ce0) at thread/qthread_unix.cpp:298
#11 0x02575d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x001faace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa8be2b40 (LWP 2402)):
#0  0x003b6416 in __kernel_vsyscall ()
#1  0x0257996b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x002083dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x01dda029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0x01dda06f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0x02575d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x001faace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb76f8740 (LWP 2395)):
[KCrash Handler]
#7  0x05ffb3d2 in ListView::updateSizeHint (this=0xa296788) at ../../../../plasma/applets/folderview/listview.cpp:209
#8  0x05ff77fb in qt_static_metacall (_a=0xbfa862e0, _id=12, _o=0xa296788, _c=<optimized out>) at ./abstractitemview.moc:96
#9  AbstractItemView::qt_static_metacall (_o=0xa296788, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfa862e0) at ./abstractitemview.moc:78
#10 0x06b886b1 in QMetaObject::activate (sender=0xa29b948, m=0x9145f8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#11 0x007b1765 in Plasma::Svg::repaintNeeded (this=0xa29b948) at ./svg.moc:221
#12 0x007b5015 in themeChanged (this=0xa28d020) at ../../plasma/svg.cpp:618
#13 Plasma::SvgPrivate::themeChanged (this=0xa28d020) at ../../plasma/svg.cpp:601
#14 0x007b6acb in qt_static_metacall (_a=0xbfa86470, _id=2, _o=0xa29b948, _c=<optimized out>) at ./svg.moc:114
#15 Plasma::Svg::qt_static_metacall (_o=0xa29b948, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfa86470) at ./svg.moc:106
#16 0x06b886b1 in QMetaObject::activate (sender=0x87fb890, m=0x9146d8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#17 0x007b8e15 in Plasma::Theme::themeChanged (this=0x87fb890) at ./theme.moc:199
#18 0x007c1072 in Plasma::ThemePrivate::notifyOfChanged (this=0x88f4ba0) at ../../plasma/theme.cpp:366
#19 0x007c1223 in qt_static_metacall (_a=0xbfa865c0, _id=8, _o=0x87fb890, _c=<optimized out>) at ./theme.moc:102
#20 Plasma::Theme::qt_static_metacall (_o=0x87fb890, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbfa865c0) at ./theme.moc:88
#21 0x06b886b1 in QMetaObject::activate (sender=0x88e5568, m=0x6ccf4d8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#22 0x06bdb625 in QTimer::timeout (this=0x88e5568) at .moc/release-shared/moc_qtimer.cpp:148
#23 0x06b91566 in QTimer::timerEvent (this=0x88e5568, e=0xbfa86acc) at kernel/qtimer.cpp:280
#24 0x06b8cac4 in QObject::event (this=0x88e5568, e=0xbfa86acc) at kernel/qobject.cpp:1157
#25 0x011e8ed4 in notify_helper (e=0xbfa86acc, receiver=0x88e5568, this=0x8805490) at kernel/qapplication.cpp:4559
#26 QApplicationPrivate::notify_helper (this=0x8805490, receiver=0x88e5568, e=0xbfa86acc) at kernel/qapplication.cpp:4531
#27 0x011ee30d in QApplication::notify (this=0xbfa86acc, receiver=0x88e5568, e=0xbfa86acc) at kernel/qapplication.cpp:4288
#28 0x00e57401 in KApplication::notify (this=0x87f5e38, receiver=0x88e5568, event=0xbfa86acc) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x06b7197e in QCoreApplication::notifyInternal (this=0x87f5e38, receiver=0x88e5568, event=0xbfa86acc) at kernel/qcoreapplication.cpp:876
#30 0x06ba6990 in sendEvent (event=0xbfa86acc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QTimerInfoList::activateTimers (this=0x8805654) at kernel/qeventdispatcher_unix.cpp:611
#32 0x06ba40f8 in timerSourceDispatch (source=0x8805620) at kernel/qeventdispatcher_glib.cpp:186
#33 timerSourceDispatch (source=0x8805620) at kernel/qeventdispatcher_glib.cpp:180
#34 0x06ba4132 in idleTimerSourceDispatch (source=0x88079c0) at kernel/qeventdispatcher_glib.cpp:233
#35 0x025d0d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0x025d1125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0x025d1201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06ba4887 in QEventDispatcherGlib::processEvents (this=0x87b4ea0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0x012a1aaa in QGuiEventDispatcherGlib::processEvents (this=0x87b4ea0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x06b7050d in QEventLoop::processEvents (this=0xbfa86d54, flags=...) at kernel/qeventloop.cpp:149
#41 0x06b707a9 in QEventLoop::exec (this=0xbfa86d54, flags=...) at kernel/qeventloop.cpp:204
#42 0x06b75eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#43 0x011e6a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#44 0x00c20a7b in kdemain (argc=1, argv=0xbfa86f54) at ../../../../plasma/desktop/shell/main.cpp:120
#45 0x0804850b in main (argc=1, argv=0xbfa86f54) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 302011, bug 299077.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-17 14:04:30 UTC

*** This bug has been marked as a duplicate of bug 299077 ***