Bug 302968

Summary: Please add support for hybrid suspend at style of pm-suspend-hybrid.
Product: solid Reporter: Rafael <EagleScreen>
Component: powermanagementAssignee: Lukáš Tinkl <lukas>
Status: RESOLVED LATER    
Severity: wishlist CC: afiestas, ask4support, chris.taylor, kynde, m.wege, maghoff, markovic.milan, mh+kde-bugs, miflab, mystica, pete, saintdev, simonandric5, vectro
Priority: NOR    
Version: 4.8.4   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=293699
Latest Commit: Version Fixed In:

Description Rafael 2012-07-03 15:13:03 UTC
Powerdevil now has only options for suspend to RAM (Sleep) and suspend to disk (Hibernate).
If I always suspend to disk, I have to wait some time to compuer to wake-up if I need to use it quickly, and if I always suspend to RAM, I suffer the risk of data loss if I do not use computer for a long time and battery is discharged or AC power is unplugged.
Hybrid suspend is the solution for this, it does both a suspend to RAM and a suspend to disk, and only resume from disk when needed, for instance if the battery was totally discharged and RAM was lost.
Please consider adding hybrid suspend method to Powedevil and KDE shutdown options. Or consider to replace Sleep and Hibernate in favor of only Hybrid method.

Reproducible: Always

Steps to Reproduce:
1. Install KDE on your favorite GNU/Linux distribution.
2. Look at suspend options.
3. You won't see an Hybrid suspend option.
Actual Results:  
3. You won't see an Hybrid suspend option.

Expected Results:  
Hybrid suspend should be available.
Comment 1 m.wege 2012-10-15 21:22:59 UTC
Hybrid suspend is supported by the kernel since 3.6. Could this mean that KDE would only need a button for triggering it?
Comment 2 Alex Fiestas 2013-03-03 17:26:34 UTC
Lukas, Dan tells me you are working on this, how is it going?
Comment 3 Lukáš Tinkl 2013-03-05 12:08:41 UTC
Quite good, I have the patchset on my disk, going to create the review soon :)
Comment 4 Lukáš Tinkl 2013-03-08 13:27:14 UTC
https://git.reviewboard.kde.org/r/109351/ (kdelibs)
https://git.reviewboard.kde.org/r/109352/ (kde-workspace)
Comment 5 m.wege 2013-03-08 13:43:57 UTC
great. Thanks for the work.
Comment 6 Lukáš Tinkl 2013-03-27 08:56:20 UTC
Git commit a6c2fcc8581747fe4285508ed6fef25fbe28bef6 by Lukáš Tinkl.
Committed on 27/03/2013 at 09:55.
Pushed by lukas into branch 'KDE/4.10'.

Add hybrid suspend method to libsolid

REVIEW: 109351

M  +7    -0    solid/solid/org.freedesktop.PowerManagement.xml
M  +24   -1    solid/solid/powermanagement.cpp
M  +11   -8    solid/solid/powermanagement.h
M  +1    -0    solid/solid/powermanagement_p.h

http://commits.kde.org/kdelibs/a6c2fcc8581747fe4285508ed6fef25fbe28bef6
Comment 7 Lukáš Tinkl 2013-04-07 08:24:55 UTC
*** Bug 293699 has been marked as a duplicate of this bug. ***
Comment 8 Ian Turner 2013-10-15 11:48:38 UTC
After upgrading to KDE 4.11.2, I'm still not seeing hybrid suspend as an option under the "K" menu or systemsettings. Is there additional GUI work required?
Comment 9 Lukáš Tinkl 2013-10-15 15:32:09 UTC
Unfortunately, it turned out to be very problematic from the user's POV (very long resume times on most hardware)
Comment 10 Mike H 2014-07-29 18:50:36 UTC
Hello Lukas,

I own an Asus laptop, that I installed a proper Vertex-4 SSD into. With 4GB of memory onboard, and ~450MB/s write speeds, hibernation by itself takes maybe 3-4 seconds on kernel 3.15.  This is very nice, when I plan to leave the laptop off for a long time. 

But the boot loader, even with instant timeout, and UEFI firmware's quick loading speed, then waiting for the kernel to initially boot and get into a state where it can resume takes about 15-20 seconds.  Not terribly much shorter than a full boot but definitely nicer to have my session still going, and not lose my running programs. 

However, I would _love_ to be able to simply close the lid, have the 3 second write-to-disk but then stay in ram should the laptop _not_ be unused for a terribly long period of time. 

In short, if I walk away 5 minutes - I want instant resume.
Leave laptop for the weekend? - I want my session preserved still. 

So to test, I've attempted to simply use systemd "systemctl suspend-hybrid" manually.

For "sleep" resumes, this is all of instantaneous.  But, due to sleep intercepting all keypresses, I had to let the battery finally die before testing the resume-from-hibernation aspect of the 'hybrid' command. 

Again, the exact same amount of time as previous hibernate resumes. 15-20 seconds.

This is _entirely_ acceptable to me.  

Praytell, are your patches still applicable to KDE 4.13.2?  Or, will(or does already) any of the v5 developments include the Hybrid Suspend option? 

I am desperately wanting this feature, and wonder what sort of speed issues your own testing revealed - i am not seeing them.
Comment 11 miflab 2014-10-23 18:52:07 UTC
2 years later and we don't have any solution? Nice...
I have BIOS and HDD system and I doesn't have any speed issues in using hybrid sleep.
Comment 12 Tommi Kyntola 2014-11-08 12:19:10 UTC
The possiblity to optionally use the hybrid-suspension was not added at all because it might be slow to some people or perhaps to those not needing/wanting it in the first place?
Sound a bit Gnome to me.
Just my 2c.
Comment 13 Jacek Szafarkiewicz 2015-04-12 09:55:38 UTC
Is there any chances for these feature?
Comment 14 Peter Lewis 2015-05-23 13:55:26 UTC
Hi,

This should be re-opened, since it has not been resolved and should be implemented in the latest Plasma. Hybrid sleep works perfectly well, and KDE's UI should support it.

Thanks!
Comment 15 milanspk 2016-02-11 12:54:27 UTC
any news about this?
Comment 16 Christoph Feck 2016-06-15 12:36:26 UTC
For Plasma 5, see bug 358957.
Comment 17 ask4support 2019-07-20 11:54:04 UTC
(In reply to Peter Lewis from comment #14)
> Hi,
> 
> This should be re-opened, since it has not been resolved and should be
> implemented in the latest Plasma. Hybrid sleep works perfectly well, and
> KDE's UI should support it.
> 
> Thanks!

I agree, I've managed to get button in sddm, yet I'm missing it in KDE.