Bug 301403

Summary: Kwin sudden crash
Product: [Plasma] kwin Reporter: Otso Helenius <kde>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Flags: mgraesslin: Intel+
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Otso Helenius 2012-06-07 21:55:41 UTC
Application: kwin (4.8.3 (4.8.3))
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.2
Operating System: Linux 3.4.0-1.fc17.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
The crash report assistant suddenly appeared after kwin restarted while I was browsing the net with firefox.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f518bbdd880 (LWP 967))]

Thread 2 (Thread 0x7f5177fff700 (LWP 972)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00000037c0d84ac7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x37c10919a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00000037c0d84af9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x000000379dc07d14 in start_thread (arg=0x7f5177fff700) at pthread_create.c:309
#4  0x000000379d8f199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f518bbdd880 (LWP 967)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x1e7e320, rb=0x1e758c0, unit=0) at brw_wm_surface_state.c:959
#7  0x00007f517e0dbbc0 in brw_update_renderbuffer_surfaces (brw=0x1e7e320) at brw_wm_surface_state.c:1052
#8  0x00007f517e0c5e90 in brw_upload_state (brw=brw@entry=0x1e7e320) at brw_state_upload.c:503
#9  0x00007f517e0b38b7 in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7ffffbab8a20, arrays=0x1eeee98, ctx=0x1e7e320) at brw_draw.c:482
#10 brw_draw_prims (ctx=0x1e7e320, arrays=0x1eeee98, prim=0x7ffffbab8a20, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007f517e1d8583 in vbo_draw_arrays (ctx=0x1e7e320, mode=4, start=0, count=6, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x0000003fca00dc27 in KWin::GLVertexBufferPrivate::corePainting (this=0x2072720, region=..., primitiveMode=4) at /usr/src/debug/kde-workspace-4.8.3/kwin/libkwineffects/kwinglutils.cpp:1188
#13 0x0000003fca00dd25 in KWin::GLVertexBuffer::render (this=0x2028a20, region=..., primitiveMode=4) at /usr/src/debug/kde-workspace-4.8.3/kwin/libkwineffects/kwinglutils.cpp:1297
#14 0x0000003fc9cb71a0 in renderQuads (normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene_opengl.cpp:788
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene_opengl.cpp:768
#16 0x0000003fc9cbdad8 in KWin::SceneOpenGL::Window::performPaint (this=0x237adb0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene_opengl.cpp:592
#17 0x0000003fc9ca8cde in KWin::Scene::finalDrawWindow (this=<optimized out>, w=<optimized out>, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene.cpp:438
#18 0x0000003fc9cc81d5 in KWin::EffectsHandlerImpl::drawWindow (this=0x212ad90, w=w@entry=0x2724040, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:286
#19 0x00007f517c245d4d in KWin::BlurEffect::drawWindow (this=<optimized out>, w=0x2724040, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects/blur/blur.cpp:389
#20 0x0000003fc9cc816b in KWin::EffectsHandlerImpl::drawWindow (this=0x212ad90, w=w@entry=0x2724040, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:283
#21 0x0000003fc500ddaa in KWin::Effect::drawWindow (this=<optimized out>, w=0x2724040, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/libkwineffects/kwineffects.cpp:181
#22 0x0000003fc9cc816b in KWin::EffectsHandlerImpl::drawWindow (this=0x212ad90, w=w@entry=0x2724040, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:283
#23 0x0000003fc9ca7d56 in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x2724030, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene.cpp:429
#24 0x0000003fc9cc8695 in KWin::EffectsHandlerImpl::paintWindow (this=0x212ad90, w=w@entry=0x2724040, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:249
#25 0x0000003fc500deaa in KWin::Effect::paintWindow (this=<optimized out>, w=0x2724040, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/libkwineffects/kwineffects.cpp:156
#26 0x0000003fc9cc862b in KWin::EffectsHandlerImpl::paintWindow (this=0x212ad90, w=w@entry=0x2724040, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:246
#27 0x00007f517c2313c8 in KWin::TranslucencyEffect::paintWindow (this=<optimized out>, w=0x2724040, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects/translucency/translucency.cpp:108
#28 0x0000003fc9cc862b in KWin::EffectsHandlerImpl::paintWindow (this=0x212ad90, w=0x2724040, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:246
#29 0x0000003fc9ca873b in KWin::Scene::paintWindow (this=this@entry=0x1e760e0, w=0x237adb0, mask=9, region=..., quads=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene.cpp:385
#30 0x0000003fc9ca95d9 in KWin::Scene::paintSimpleScreen (this=this@entry=0x1e760e0, orig_mask=orig_mask@entry=8, region=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene.cpp:330
#31 0x0000003fc9ca7c84 in KWin::Scene::finalPaintScreen (this=0x1e760e0, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene.cpp:198
#32 0x0000003fc9cc83a3 in KWin::EffectsHandlerImpl::paintScreen (this=0x212ad90, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:222
#33 0x0000003fc500df17 in KWin::Effect::paintScreen (this=this@entry=0x22503e0, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/libkwineffects/kwineffects.cpp:141
#34 0x0000003fc9cc834b in KWin::EffectsHandlerImpl::paintScreen (this=0x212ad90, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:219
#35 0x0000003fc500df17 in KWin::Effect::paintScreen (this=this@entry=0x22eb200, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/libkwineffects/kwineffects.cpp:141
#36 0x0000003fc9cc834b in KWin::EffectsHandlerImpl::paintScreen (this=0x212ad90, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/effects.cpp:219
#37 0x0000003fc9caa878 in KWin::Scene::paintScreen (this=0x1e760e0, mask=0x7ffffbab9b1c, region=0x7ffffbab9be0) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene.cpp:156
#38 0x0000003fc9cbe5fd in KWin::SceneOpenGL::paint (this=0x1e760e0, damage=..., toplevels=...) at /usr/src/debug/kde-workspace-4.8.3/kwin/scene_opengl_glx.cpp:459
#39 0x0000003fc9ca4ab1 in KWin::Workspace::performCompositing (this=0x20299a0) at /usr/src/debug/kde-workspace-4.8.3/kwin/composite.cpp:417
#40 0x00000037a618ab1c in QObject::event (this=0x20299a0, e=<optimized out>) at kernel/qobject.cpp:1157
#41 0x0000003fbe7ca37c in QApplicationPrivate::notify_helper (this=this@entry=0x1cc3160, receiver=receiver@entry=0x20299a0, e=e@entry=0x7ffffbaba2c0) at kernel/qapplication.cpp:4551
#42 0x0000003fbe7ce7fa in QApplication::notify (this=0x7ffffbaba900, receiver=0x20299a0, e=0x7ffffbaba2c0) at kernel/qapplication.cpp:4412
#43 0x0000003fc0245a56 in KApplication::notify (this=0x7ffffbaba900, receiver=0x20299a0, event=0x7ffffbaba2c0) at /usr/src/debug/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#44 0x00000037a61763ee in QCoreApplication::notifyInternal (this=0x7ffffbaba900, receiver=0x20299a0, event=0x7ffffbaba2c0) at kernel/qcoreapplication.cpp:915
#45 0x00000037a61a6d52 in sendEvent (event=0x7ffffbaba2c0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#46 QTimerInfoList::activateTimers (this=0x1cc3b58) at kernel/qeventdispatcher_unix.cpp:611
#47 0x00000037a61a6db0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x1c77740) at kernel/qeventdispatcher_unix.cpp:868
#48 0x00000037a61a6f08 in QEventDispatcherUNIX::processEvents (this=0x1c77740, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#49 0x0000003fbe86b10f in QEventDispatcherX11::processEvents (this=0x1c77740, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#50 0x00000037a617513f in QEventLoop::processEvents (this=this@entry=0x7ffffbaba610, flags=...) at kernel/qeventloop.cpp:149
#51 0x00000037a61753c8 in QEventLoop::exec (this=0x7ffffbaba610, flags=...) at kernel/qeventloop.cpp:204
#52 0x00000037a617a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#53 0x0000003fc9c5f2be in kdemain (argc=3, argv=0x7ffffbabaa88) at /usr/src/debug/kde-workspace-4.8.3/kwin/main.cpp:541
#54 0x000000379d821735 in __libc_start_main (main=0x4008c0 <main(int, char**)>, argc=3, ubp_av=0x7ffffbabaa88, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffffbabaa78) at libc-start.c:226
#55 0x00000000004008f1 in _start ()

Possible duplicates by query: bug 301131, bug 300886, bug 299333.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-06-07 22:03:17 UTC
intel?
which GPU in particular?
i assume opengl acceleration in FF is active?

*** This bug has been marked as a duplicate of bug 299333 ***
Comment 2 Otso Helenius 2012-06-07 22:47:18 UTC
Yes, FF is accelerated. GPU is Intel GMA HD (QM57).