Bug 300797

Summary: Crash when deleting folder.
Product: [Applications] dolphin Reporter: Marek ┼áimon <marek.simon>
Component: generalAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 2.0   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Marek Šimon 2012-05-29 08:32:13 UTC
Application: dolphin (2.0)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
Opened home dir.
Tried to delete a folder with large amount of data (28 GB).
Dolphin reported that size of Trash is overgone.
I tried it four times and then it crash.
(KDE from kubuntu)

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb776a740 (LWP 14799))]

Thread 3 (Thread 0xb5819b40 (LWP 14800)):
#0  0x0094d789 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0x00931368 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0119da3b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0119006e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x011901c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0188f8e7 in QEventDispatcherGlib::processEvents (this=0xb4f00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x0185b50d in QEventLoop::processEvents (this=0xb5819240, flags=...) at kernel/qeventloop.cpp:149
#7  0x0185b7a9 in QEventLoop::exec (this=0xb5819240, flags=...) at kernel/qeventloop.cpp:204
#8  0x0174494c in QThread::exec (this=0x83a6160) at thread/qthread.cpp:501
#9  0x01838b5d in QInotifyFileSystemWatcherEngine::run (this=0x83a6160) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01747de0 in QThreadPrivate::start (arg=0x83a6160) at thread/qthread_unix.cpp:298
#11 0x031d3d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0093face in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb4bb7b40 (LWP 14801)):
#0  0x002a4416 in __kernel_vsyscall ()
#1  0x00931380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0119da3b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0119006e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x011901c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0188f8e7 in QEventDispatcherGlib::processEvents (this=0xb4200468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x0185b50d in QEventLoop::processEvents (this=0xb4bb7240, flags=...) at kernel/qeventloop.cpp:149
#7  0x0185b7a9 in QEventLoop::exec (this=0xb4bb7240, flags=...) at kernel/qeventloop.cpp:204
#8  0x0174494c in QThread::exec (this=0x8437918) at thread/qthread.cpp:501
#9  0x01838b5d in QInotifyFileSystemWatcherEngine::run (this=0x8437918) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01747de0 in QThreadPrivate::start (arg=0x8437918) at thread/qthread_unix.cpp:298
#11 0x031d3d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0093face in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb776a740 (LWP 14799)):
[KCrash Handler]
#7  QList (this=0xbfea5f38, l=...) at /usr/include/qt4/QtCore/qlist.h:122
#8  QForeachContainer (t=..., this=0xbfea5f38) at /usr/include/qt4/QtCore/qglobal.h:2340
#9  KDirLister::Private::cachedItemsJobForUrl (this=0xcca29e9c, url=...) at ../../kio/kio/kdirlister.cpp:277
#10 0x00f89bb0 in KDirListerCache::updateDirectory (this=0x83cbcf0, _dir=...) at ../../kio/kio/kdirlister.cpp:680
#11 0x00f8f154 in KDirListerCache::slotFilesAdded (this=0x83cbcf0, dir=...) at ../../kio/kio/kdirlister.cpp:849
#12 0x018736b1 in QMetaObject::activate (sender=0x83cbc90, m=0x113fa98, local_signal_index=2, argv=0xbfea6278) at kernel/qobject.cpp:3547
#13 0x00f9d425 in OrgKdeKDirNotifyInterface::FilesAdded (this=0x83cbc90, _t1=...) at ./kdirnotify.moc:131
#14 0x00f9d607 in qt_static_metacall (_a=0xbfea63bc, _id=2, _o=0x83cbc90, _c=<optimized out>) at ./kdirnotify.moc:64
#15 OrgKdeKDirNotifyInterface::qt_static_metacall (_o=0x83cbc90, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfea63bc) at ./kdirnotify.moc:56
#16 0x00f9d6fc in OrgKdeKDirNotifyInterface::qt_metacall (this=0x83cbc90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfea63bc) at ./kdirnotify.moc:107
#17 0x0062aa38 in QDBusConnectionPrivate::deliverCall (this=0x82fa3d0, object=0x83cbc90, msg=..., metaTypes=..., slotIdx=-861757796) at qdbusintegrator.cpp:947
#18 0x00634c8d in QDBusCallDeliveryEvent::placeMetaCall (this=0x8b34d10, object=0x83cbc90) at qdbusintegrator_p.h:103
#19 0x01877c7b in QObject::event (this=0x83cbc90, e=0x8b34d10) at kernel/qobject.cpp:1195
#20 0x0415fed4 in notify_helper (e=0x8b34d10, receiver=0x83cbc90, this=0x827f938) at kernel/qapplication.cpp:4559
#21 QApplicationPrivate::notify_helper (this=0x827f938, receiver=0x83cbc90, e=0x8b34d10) at kernel/qapplication.cpp:4531
#22 0x0416530d in QApplication::notify (this=0x8b34d10, receiver=0x83cbc90, e=0x8b34d10) at kernel/qapplication.cpp:4288
#23 0x01c26b21 in KApplication::notify (this=0xbfea73a8, receiver=0x83cbc90, event=0x8b34d10) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x0185c97e in QCoreApplication::notifyInternal (this=0xbfea73a8, receiver=0x83cbc90, event=0x8b34d10) at kernel/qcoreapplication.cpp:876
#25 0x01860ad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x825fc18) at kernel/qcoreapplication.cpp:1500
#27 0x01860e0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#28 0x0188f494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#29 postEventSourceDispatch (s=0x827fe80) at kernel/qeventdispatcher_glib.cpp:279
#30 0x0118fcda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x011900e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0x011901c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0x0188f887 in QEventDispatcherGlib::processEvents (this=0x8260780, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0x04218aaa in QGuiEventDispatcherGlib::processEvents (this=0x8260780, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x0185b50d in QEventLoop::processEvents (this=0xbfea6b60, flags=...) at kernel/qeventloop.cpp:149
#36 0x0185b7a9 in QEventLoop::exec (this=0xbfea6b60, flags=...) at kernel/qeventloop.cpp:204
#37 0x046b20c9 in QDialog::exec (this=0x8bc56a8) at dialogs/qdialog.cpp:554
#38 0x01b66f31 in KDialogQueue::Private::slotShowQueuedDialog (this=0x8b30b08) at ../../kdeui/dialogs/kdialog.cpp:1103
#39 0x0186ec01 in QMetaCallEvent::placeMetaCall (this=0x86d3c78, object=0x98bab10) at kernel/qobject.cpp:525
#40 0x01877c7b in QObject::event (this=0x98bab10, e=0x86d3c78) at kernel/qobject.cpp:1195
#41 0x0415fed4 in notify_helper (e=0x86d3c78, receiver=0x98bab10, this=0x827f938) at kernel/qapplication.cpp:4559
#42 QApplicationPrivate::notify_helper (this=0x827f938, receiver=0x98bab10, e=0x86d3c78) at kernel/qapplication.cpp:4531
#43 0x0416530d in QApplication::notify (this=0x86d3c78, receiver=0x98bab10, e=0x86d3c78) at kernel/qapplication.cpp:4288
#44 0x01c26b21 in KApplication::notify (this=0xbfea73a8, receiver=0x98bab10, event=0x86d3c78) at ../../kdeui/kernel/kapplication.cpp:311
#45 0x0185c97e in QCoreApplication::notifyInternal (this=0xbfea73a8, receiver=0x98bab10, event=0x86d3c78) at kernel/qcoreapplication.cpp:876
#46 0x01860ad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#47 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x825fc18) at kernel/qcoreapplication.cpp:1500
#48 0x01860e0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#49 0x0188f494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#50 postEventSourceDispatch (s=0x827fe80) at kernel/qeventdispatcher_glib.cpp:279
#51 0x0118fcda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#52 0x011900e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#53 0x011901c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#54 0x0188f887 in QEventDispatcherGlib::processEvents (this=0x8260780, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#55 0x04218aaa in QGuiEventDispatcherGlib::processEvents (this=0x8260780, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x0185b50d in QEventLoop::processEvents (this=0xbfea7314, flags=...) at kernel/qeventloop.cpp:149
#57 0x0185b7a9 in QEventLoop::exec (this=0xbfea7314, flags=...) at kernel/qeventloop.cpp:204
#58 0x01860eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#59 0x0415da74 in QApplication::exec () at kernel/qapplication.cpp:3820
#60 0x0039e1da in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#61 0x0804850b in ?? ()
#62 0x0086e4d3 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#63 0x08048531 in _start ()

This bug may be a duplicate of or related to bug 278431.

Possible duplicates by query: bug 291576, bug 287939, bug 287396, bug 278431.

Reported using DrKonqi
Comment 1 Peter Penz 2012-05-29 10:49:57 UTC

*** This bug has been marked as a duplicate of bug 278431 ***