Bug 300786

Summary: appShouldConserveResources() always return true even when on AC
Product: solid Reporter: Daniel Nicoletti <dantti12>
Component: powermanagementAssignee: Dario Freddi <drf>
Status: RESOLVED FIXED    
Severity: normal CC: Christoph.Berg, lukas
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Daniel Nicoletti 2012-05-29 00:11:16 UTC
I had to disable the code that checks if Apper
should conserve resources since it always return true,
even on an AC powered machine or when my laptop
it plugged on AC. I have checked the DBus path
of upower and it reports correctly so it seems a bug on
the library, there is also a similar bug at nepomuk:
https://bugs.kde.org/show_bug.cgi?id=294438

Solid::PowerManagement::appShouldConserveResources()

Thanks.

Reproducible: Always
Comment 1 Daniel Nicoletti 2012-06-21 14:28:34 UTC
*** Bug 294438 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Nicoletti 2012-06-21 14:29:35 UTC
This commit fixes the issue:
http://commits.kde.org/kdelibs/05f1a19291af5c16745b76c3e0944c5b80ef5870
Comment 3 Lukáš Tinkl 2012-06-21 15:44:22 UTC
Git commit 9c30ec613ca2f64e0649e2a066e781b07cc54f21 by Lukas Tinkl.
Committed on 21/06/2012 at 17:43.
Pushed by lukas into branch 'frameworks'.

Make sure we have valid values for powermanager, watch for
unregistration to reset values

(hand forward port of 05f1a19291af5c16745b76c3e0944c5b80ef5870 by Daniel
Nicoletti)

M  +68   -26   tier1/solid/src/solid/powermanagement.cpp
M  +1    -0    tier1/solid/src/solid/powermanagement_p.h

http://commits.kde.org/kdelibs/9c30ec613ca2f64e0649e2a066e781b07cc54f21
Comment 4 Daniel Nicoletti 2012-12-19 15:16:43 UTC
Git commit 0018b7647a7409afc30000c14e516ffe21bb3ec1 by Daniel Nicoletti.
Committed on 19/12/2012 at 16:15.
Pushed by dantti into branch 'KDE/4.10'.

Make sure appShouldConserveResources returns the cached value

M  +26   -22   solid/solid/powermanagement.cpp

http://commits.kde.org/kdelibs/0018b7647a7409afc30000c14e516ffe21bb3ec1
Comment 5 Daniel Nicoletti 2012-12-19 15:40:59 UTC
Git commit ecf4d9180593aecd6156f519947971b6b9a256f6 by Daniel Nicoletti.
Committed on 19/12/2012 at 16:15.
Pushed by dantti into branch 'KDE/4.9'.

Make sure appShouldConserveResources returns the cached value

M  +26   -22   solid/solid/powermanagement.cpp

http://commits.kde.org/kdelibs/ecf4d9180593aecd6156f519947971b6b9a256f6