Bug 299707

Summary: knotify crashes trying to NotifyBySound
Product: phonon-backend-vlc Reporter: Francesco Riosa <vivo75+kde>
Component: generalAssignee: Harald Sitter <sitter>
Status: RESOLVED DUPLICATE    
Severity: crash CC: bcooksley, fabo, jb, martin.sandsmark, myriam
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Francesco Riosa 2012-05-09 20:19:41 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.8.3 (4.8.3) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.3.4-vs2.3.3.3 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
after last upgrade desktop often freeze for few seconds and then become responsive again, konqui show the knotify crash window

however the problem may be in the vlc backend

knotify area log:
[...]
knotify(21405) KNotify::event: 68  ref= 0
knotify(21405) KNotify::event: 69  ref= 0
knotify(21405) NotifyBySound::notify:  going to play  "/usr/share/sounds/KDE-Sys-Warning.ogg"
[crash]
knotify(22354) NotifyByPopup::slotServiceOwnerChanged: "org.freedesktop.Notifications" "" "_"
knotify(22354) KNotify::event: 1  ref= 0
knotify(22354) KNotify::event: 2  ref= 0
[...]
knotify(22354) KNotify::event: 8  ref= 0
knotify(22354) KNotify::event: 9  ref= 0
knotify(22354) KNotify::event: 10  ref= 0
knotify(22354) NotifyBySound::notify:  going to play  "/usr/share/sounds/KDE-Sys-Warning.ogg"
[crash]
knotify(22367) NotifyByPopup::slotServiceOwnerChanged: "org.freedesktop.Notifications" "" "_"
knotify(22367) KNotify::event: 1  ref= 0
knotify(22367) KNotify::event: 2  ref= 0
[...]
knotify(22367) KNotify::event: 176  ref= 0
knotify(22367) KNotify::event: 177  ref= 0
knotify(22367) NotifyBySound::notify:  going to play  "/usr/share/sounds/KDE-Sys-Warning.ogg"
[crash]
knotify(25171) NotifyByPopup::slotServiceOwnerChanged: "org.freedesktop.Notifications" "" "_"
knotify(25171) KNotify::event: 1  ref= 0
knotify(25171) KNotify::event: 2  ref= 0
[...]
knotify(25171) KNotify::event: 11  ref= 0
knotify(25171) KNotify::event: 12  ref= 0
knotify(25171) NotifyByPopup::slotServiceOwnerChanged: "org.freedesktop.Notifications" ":1.14" ""
knotify(26042) KNotify::event: 1  ref= 0
knotify(26042) KNotify::event: 2  ref= 0
knotify(26042) NotifyByPopup::slotServiceOwnerChanged: "org.freedesktop.Notifications" "" ":1.14"
knotify(26042) KNotify::event: 3  ref= 0
knotify(26042) KNotify::event: 4  ref= 0
[...]
knotify(26042) KNotify::event: 17  ref= 0
knotify(26042) KNotify::event: 18  ref= 0
knotify(26042) NotifyBySound::notify:  going to play  "/usr/share/sounds/KDE-Sys-App-Message.ogg"
[crash]
knotify(26377) NotifyByPopup::slotServiceOwnerChanged: "org.freedesktop.Notifications" "" "_"

The crash can be reproduced every time.

-- Backtrace:
Application: KNotify (knotify4), signal: Bus error
[KCrash Handler]
#6  0x00007f7e1bd553f3 in ?? () from /lib64/ld-linux-x86-64.so.2
#7  0x00007f7e1bd5c6fd in ?? () from /lib64/ld-linux-x86-64.so.2
#8  0x00007f7e1bd58236 in ?? () from /lib64/ld-linux-x86-64.so.2
#9  0x00007f7e1bd5beba in ?? () from /lib64/ld-linux-x86-64.so.2
#10 0x00007f7e13ed3f56 in ?? () from /lib64/libdl.so.2
#11 0x00007f7e1bd58236 in ?? () from /lib64/ld-linux-x86-64.so.2
#12 0x00007f7e13ed44ef in ?? () from /lib64/libdl.so.2
#13 0x00007f7e13ed3ff1 in dlopen () from /lib64/libdl.so.2
#14 0x00007f7e0053cfc1 in module_Load (p_this=0x8523f8, psz_file=<optimized out>, p_handle=0x7fff13a770b0, lazy=<optimized out>) at posix/plugin.c:62
#15 0x00007f7e00527846 in module_InitDynamic (obj=0x8523f8, path=0x94bf20 "/usr/lib64/vlc/plugins/access/libaccess_smb_plugin.so", fast=<optimized out>) at modules/bank.c:536
#16 0x00007f7e00527b45 in AllocatePluginFile (st=0x7fff13a77100, relpath=0x940ab0 "access/libaccess_smb_plugin.so", abspath=0x94bf20 "/usr/lib64/vlc/plugins/access/libaccess_smb_plugin.so", bank=0x7fff13a77300) at modules/bank.c:479
#17 AllocatePluginDir (bank=0x7fff13a77300, maxdepth=3, absdir=<optimized out>, reldir=0x8fe090 "access") at modules/bank.c:440
#18 0x00007f7e00527bee in AllocatePluginDir (bank=0x7fff13a77300, maxdepth=4, absdir=<optimized out>, reldir=0x0) at modules/bank.c:444
#19 0x00007f7e00527d4f in AllocatePluginPath (p_this=0x8523f8, path=0x91ab60 "/usr/lib64/vlc/plugins", mode=<optimized out>) at modules/bank.c:353
#20 0x00007f7e00528280 in AllocateAllPlugins (p_this=0x8523f8) at modules/bank.c:282
#21 module_LoadPlugins (obj=0x8523f8) at modules/bank.c:189
#22 0x00007f7e004ca612 in libvlc_InternalInit (p_libvlc=0x8523f8, i_argc=12, ppsz_argv=0x7fff13a776c0) at libvlc.c:247
#23 0x00007f7e007c6e19 in libvlc_new (argc=11, argv=<optimized out>) at core.c:59
#24 0x00007f7e009f60fb in LibVLC::init () at /usr/src/debug/media-libs/phonon-vlc-0.5.0/phonon-backend-vlc-0.5.0/src/utils/libvlc.cpp:118
#25 0x00007f7e009e8166 in Phonon::VLC::Backend::Backend (this=0x84c7e0, parent=<optimized out>) at /usr/src/debug/media-libs/phonon-vlc-0.5.0/phonon-backend-vlc-0.5.0/src/backend.cpp:88
#26 0x00007f7e009e8793 in qt_plugin_instance () at /usr/src/debug/media-libs/phonon-vlc-0.5.0/phonon-backend-vlc-0.5.0/src/backend.cpp:56
#27 0x00007f7e19645bbf in QPluginLoader::instance (this=0x7fff13a77f50) at plugin/qpluginloader.cpp:204
#28 0x00007f7e00f12c06 in Phonon::KdePlatformPlugin::createBackend (this=<optimized out>, newService=...) at /usr/src/debug/kde-base/phonon-kde-4.8.3/phonon-kde-4.8.3/phonon/platform_kde/kdeplatformplugin.cpp:130
#29 0x00007f7e00f1321c in Phonon::KdePlatformPlugin::createBackend (this=0x877780) at /usr/src/debug/kde-base/phonon-kde-4.8.3/phonon-kde-4.8.3/phonon/platform_kde/kdeplatformplugin.cpp:183
#30 0x00007f7e1b404c19 in Phonon::FactoryPrivate::createBackend (this=0x873400) at /usr/src/debug/media-libs/phonon-4.6.0-r1/phonon-4.6.0/phonon/factory.cpp:130
#31 0x00007f7e1b40641f in Phonon::Factory::backend (createWhenNull=<optimized out>) at /usr/src/debug/media-libs/phonon-4.6.0-r1/phonon-4.6.0/phonon/factory.cpp:460
#32 0x00007f7e1b406dd5 in Phonon::Factory::createAudioOutput (parent=0x874410) at /usr/src/debug/media-libs/phonon-4.6.0-r1/phonon-4.6.0/phonon/factory.cpp:356
#33 0x00007f7e1b3fc10e in createBackendObject (this=0x8738d0) at /usr/src/debug/media-libs/phonon-4.6.0-r1/phonon-4.6.0/phonon/audiooutput.cpp:138
#34 Phonon::AudioOutputPrivate::createBackendObject (this=0x8738d0) at /usr/src/debug/media-libs/phonon-4.6.0-r1/phonon-4.6.0/phonon/audiooutput.cpp:133
#35 0x00007f7e1b3f83e9 in Phonon::AudioOutputPrivate::init (this=0x8738d0, c=Phonon::NotificationCategory) at /usr/src/debug/media-libs/phonon-4.6.0-r1/phonon-4.6.0/phonon/audiooutput.cpp:111
#36 0x000000000041080c in Player::Player (this=0x873d60) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3/knotify/notifybysound.cpp:58
#37 0x000000000040f8d5 in PlayerPool::getPlayer (this=0x7db418) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3/knotify/notifybysound.cpp:98
#38 0x000000000040fd21 in NotifyBySound::notify (this=0x7d5e10, eventId=19, config=0x81f178) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3/knotify/notifybysound.cpp:242
#39 0x000000000040b622 in KNotify::emitEvent (this=0x7fff13a79c60, e=0x81f170) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3/knotify/knotify.cpp:230
#40 0x000000000040bee7 in KNotify::event (this=0x7fff13a79c60, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=14680248) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3/knotify/knotify.cpp:149
#41 0x000000000040c154 in KNotifyAdaptor::event (this=0x7ae570, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=14680248) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3/knotify/knotify.cpp:289
#42 0x000000000040c29b in KNotifyAdaptor::qt_static_metacall (_o=0x7ae570, _c=<optimized out>, _id=4, _a=0x7fff13a78e60) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3_build/knotify/knotify.moc:218
#43 0x000000000040c3fb in KNotifyAdaptor::qt_metacall (this=0x7ae570, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff13a78e60) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3_build/knotify/knotify.moc:260
#44 0x00007f7e199effd0 in QDBusConnectionPrivate::deliverCall (this=0x649520, object=0x7ae570, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:947
#45 0x00007f7e199f116d in QDBusConnectionPrivate::activateCall (this=0x649520, object=0x7ae570, flags=273, msg=...) at qdbusintegrator.cpp:857
#46 0x00007f7e199f1a5b in QDBusConnectionPrivate::activateObject (this=0x649520, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#47 0x00007f7e199f1b4b in QDBusActivateObjectEvent::placeMetaCall (this=0x874660) at qdbusintegrator.cpp:1537
#48 0x00007f7e1967f3a6 in QObject::event (this=0x7fff13a79c60, e=<optimized out>) at kernel/qobject.cpp:1195
#49 0x00007f7e1a311092 in notify_helper (e=0x874660, receiver=0x7fff13a79c60, this=0x659460) at kernel/qapplication.cpp:4554
#50 QApplicationPrivate::notify_helper (this=0x659460, receiver=0x7fff13a79c60, e=0x874660) at kernel/qapplication.cpp:4526
#51 0x00007f7e1a316c99 in QApplication::notify (this=0x7fff13a79c90, receiver=0x7fff13a79c60, e=0x874660) at kernel/qapplication.cpp:4415
#52 0x00007f7e1b895d7d in KApplication::notify (this=0x7fff13a79c90, receiver=0x7fff13a79c60, event=0x874660) at /usr/src/debug/kde-base/kdelibs-4.8.3/kdelibs-4.8.3/kdeui/kernel/kapplication.cpp:311
#53 0x00007f7e19663c3c in QCoreApplication::notifyInternal (this=0x7fff13a79c90, receiver=0x7fff13a79c60, event=0x874660) at kernel/qcoreapplication.cpp:876
#54 0x00007f7e19667565 in sendEvent (event=0x874660, receiver=0x7fff13a79c60) at kernel/qcoreapplication.h:231
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6312b0) at kernel/qcoreapplication.cpp:1500
#56 0x00007f7e19695dd3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#57 postEventSourceDispatch (s=0x657da0) at kernel/qeventdispatcher_glib.cpp:279
#58 0x00007f7e15efa1a3 in g_main_dispatch (context=0x65a720) at gmain.c:2539
#59 g_main_context_dispatch (context=0x65a720) at gmain.c:3075
#60 0x00007f7e15efa4e0 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x65a720, self=<optimized out>) at gmain.c:3146
#61 g_main_context_iterate (context=0x65a720, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3083
#62 0x00007f7e15efa5a4 in g_main_context_iteration (context=0x65a720, may_block=1) at gmain.c:3207
#63 0x00007f7e1969623f in QEventDispatcherGlib::processEvents (this=0x632770, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#64 0x00007f7e1a3c17de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#65 0x00007f7e196621f2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#66 0x00007f7e19662437 in QEventLoop::exec (this=0x7fff13a79bf0, flags=...) at kernel/qeventloop.cpp:204
#67 0x00007f7e19667977 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#68 0x0000000000409f45 in main (argc=1, argv=0x7fff13a7a038) at /usr/src/debug/kde-base/knotify-4.8.3/knotify-4.8.3/knotify/main.cpp:73

Reported using DrKonqi
Comment 1 Francesco Riosa 2012-05-09 20:56:35 UTC
hmmm, after digging a bit furter I'm quite sure the problem is inside vlc or in the 
"/usr/lib64/vlc/vlc-cache-gen" -f "/usr/lib64/vlc/plugins/"
crash with a bus error

it's unfortunate that this make knotify crash too but it's your choice to consider it a bug in either knotify or phonon-vlc
Comment 2 Myriam Schweingruber 2012-05-10 10:38:14 UTC
Please see https://bugs.kde.org/show_bug.cgi?id=288057#c5 and check your versions.

*** This bug has been marked as a duplicate of bug 288057 ***