Bug 299477

Summary: KMix Does Not Unmute Master Audio Channel
Product: kmix Reporter: Will Keaney <keaneyw>
Component: generalAssignee: Christian Esken <esken>
Status: RESOLVED FIXED    
Severity: normal CC: psychonaut
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In: 4.10

Description Will Keaney 2012-05-06 00:09:33 UTC
Hardware: 00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04), Conexant codec.
Backend: GStreamer + PulseAudio + ALSA; kernel 3.3.1.
Master Channel: Master

Muting the Master channel works as expected, and is reflected in alsamixer as well.
Unmuting in KMix does not unmute the channel; alsamixer shows the channel still muted, and no audio is produced, though KMix shows the channel as unmuted.

Reproducible: Always

Steps to Reproduce:
1. Set KMix master channel to "Master"
2. Mute master channel in KMix
3. Unmute master channel in KMix
Actual Results:  
Master channel remains muted, though KMix UI shows it unmuted.

Expected Results:  
KMix mixer status should reflect the actual state of the hardware.
Unmuting in KMix should unmute the channel the hardware.
Comment 1 Will Keaney 2012-05-06 00:14:12 UTC
Toggling mute in alsamixer is reflected immediately in KMix.
Comment 2 Christian Esken 2012-10-03 23:23:14 UTC
You list PulseAudio and ALSA as Backend. Hopefully you are not using a mixed operating mode, as this can easily lead to issues as you described. Which sound backend do you use (PulseAudio, direct ALSA or both)? Please also copy the output from
    KMix menu => Help => Hardware information

--- General information: ---

For controlling your soundcard hardware details there are two choices:
1) With Pulseaudio: Please use KMix's main menu "Setting -> Audio Setup" to get access to a detailed soundcard setup. This is still Pulseaudio, but you usually are able to control all relevant audio aspects.
2) Without Pulseaudio: If you want to see the ALSA-Controls then please deactivate Pulseaudio. For openSUSE this is in YaST -> Sound. For other distributions please refer to your Linux distribution documentation, Wiki or in appropriate internet forums.
Comment 3 Tristan Miller 2012-11-20 09:34:07 UTC
I am experiencing exactly the same problem.  KMix mutes correctly, but does not unmute correctly.  The systray icon indicates that the sound is unmuted, but the channel remains muted.  Unmuting from alsamixer works.  When muting or unmuting from alsamixer, the mute status is immediately and correctly reflected in KMix.

I am running KMix 4.2 / KDE 4.9.3 / openSUSE 12.2 / x86-64.  The sound device is an 82801JI (ICH10 Family) HD Audio Controller using the snd_hda_intel kernel driver on Linux 3.4.11.

Here is the output from KMix menu => Help => Hardware information which you requested:

Sound drivers supported: PulseAudio + ALSO + OSS + MPRIS2
Sound drivers used: ALSA
Comment 4 Tristan Miller 2012-11-20 09:36:38 UTC
Looks like there's a typo in that output.  Here's a corrected version:

Sound drivers supported: PulseAudio + ALSA + OSS + MPRIS2
Sound drivers used: ALSA
Comment 5 Christian Esken 2012-11-20 13:36:10 UTC
Quiet likely fixed in KDE 4.10. If you can, please test the beta.
Comment 6 Christian Esken 2013-12-18 14:05:30 UTC
No reply within 6 months => closing ticket
Comment 7 Tristan Miller 2013-12-18 14:43:27 UTC
I upgraded my OS a few days ago.  Now with KDE 4.11.4 I can no longer reproduce the problem.
Comment 8 Christian Esken 2013-12-20 10:24:21 UTC
Git commit 0f7a603e1d327f76dbd6a62d08315b1956794d42 by Christian Esken.
Committed on 20/12/2013 at 10:17.
Pushed by esken into branch 'master'.

Configuration menu is now using Tabs to provide a more standard,
  convenient and pleasing layout
 Sound Menu: Play button reflects playback status and shows either
  "Play" or "Pause"
 Bugfixes and Features (CCBUGS, as most bugs are already closed). Hint: Some
bugs might have actually been alreay fixed ibn KDE4.11 or KDE4.12.

Bug ID	Severity	Summary
Related: bug 317926, bug 20, bug 315383, bug 256854, bug 304144, bug 296951, bug 303608, bug 214854, bug 319600
applet
volume control
position.

M  +9    -5    CMakeLists.txt
M  +41   -20   ChangeLog
M  +5    -1    apps/KMixApp.cpp
M  +167  -238  apps/kmix.cpp
M  +8    -13   apps/kmix.h
M  +3    -0    apps/kmixctrl.cpp
M  +3    -0    apps/kmixd.cpp
M  +18   -12   backends/mixer_backend.cpp
M  +1    -0    backends/mixer_backend.h
M  +229  -150  backends/mixer_mpris2.cpp
M  +23   -6    backends/mixer_mpris2.h
M  +8    -2    backends/mixer_oss.cpp
M  +1    -1    backends/mixer_pulse.cpp
M  +9    -9    core/ControlManager.cpp
M  +102  -15   core/GlobalConfig.cpp
M  +105  -47   core/GlobalConfig.h
M  +65   -31   core/kmixdevicemanager.cpp
M  +9    -4    core/mixdevice.cpp
M  +4    -12   core/mixdevice.h
M  +6    -4    core/mixer.cpp
M  +16   -10   core/mixertoolbox.cpp
M  +1    -1    core/version.h
M  +17   -3    core/volume.cpp
M  +9    -8    core/volume.h
M  +19   -6    gui/dialogchoosebackends.cpp
M  +1    -1    gui/dialogchoosebackends.h
M  +9    -2    gui/dialogviewconfiguration.cpp
M  +37   -10   gui/guiprofile.cpp
M  +27   -24   gui/guiprofile.h
M  +93   -118  gui/kmixdockwidget.cpp
M  +3    -4    gui/kmixdockwidget.h
M  +13   -11   gui/kmixerwidget.cpp
M  +296  -91   gui/kmixprefdlg.cpp
M  +82   -32   gui/kmixprefdlg.h
M  +87   -38   gui/mdwslider.cpp
M  +4    -2    gui/mdwslider.h
M  +69   -42   gui/viewbase.cpp
M  +1    -0    gui/viewbase.h
M  +25   -30   gui/viewdockareapopup.cpp
M  +1    -1    gui/viewdockareapopup.h
M  +4    -4    gui/viewsliders.cpp
M  +1    -1    gui/volumesliderextradata.h

http://commits.kde.org/kmix/0f7a603e1d327f76dbd6a62d08315b1956794d42